1. azndud3's Avatar
    Hi all ,
    I updated my firmware on my Galaxy S5 using ODIN.It was just from an older 4.4.2 to a newer 4.4.2 firmware. I only reset phone to default factory settings via the stock settings menu. I did not install CWM and delete dalvik cache before flash.
    Anyways since i updated firmware when i charge my phone it goes very hot. Furthermore the batt indicator percentage takes a very long time to go up more %. If i plug the phone into a pc usb slot (where the current is much lower than a usb wall socket charge) the phones battery % actually decreases instead of charging.
    If i put the phone in ultra power saving mode it charges properly and quickly. My phone doesnt eat much battery when in idle mode. Eats like 5% every 7 hours idle.But when i use it the battery drains quick.
    I'm guessing it must be a service thats draining the batt when using
    the phone.And when i flashed the phone not all the settings were wiped?Maybe a file config stayed back and is making the battery drain?
    My question is how can i fix this issue?
    How would i make sure my phone is totally reset so that there are no settings/files from previous install that could be eating my batt life?
    Any suggestions/ideas would be appreciated.
    Thanks for reading n help
    04-16-2015 05:20 AM
  2. Golfdriver97's Avatar
    You can try going into recovery. Follow instructions for the S3: http://forums.androidcentral.com/sam...2-s3-tab2.html
    04-16-2015 09:11 AM
  3. Rukbat's Avatar
    Or you can go to Settings/General/Battery and see what's using most of your battery. (Use the phone until the battery drops to about 50% first, so the readings mean something.)
    04-16-2015 09:13 PM
  4. azndud3's Avatar
    Hi ,
    Thanks for the replies. Yep i didnt go into recovery mode tthis time around to wipe it clean before the firmware update.
    What options do you suggest I should select when i boot in recovery mode ? Also is it safe to clear davik cache without resetting the phone ?

    Illl detail what i did that got me into this battery problem below

    i had stock 4.4.2 (phone was on the 4.4 2 April 2014 firmware when purchased) few months later OTA updated to July 2014 and had Philz Touch recovery installed.
    I booted up in recovery mode and cleared davik cache and selected all the other available options to wipe phone memory. I downgraded to 4.4.2 April and booted my phone. It seems to still be eating alot of battery (just like the batt problem happening now - despite having already cleared davik cache and phone memory before flash) so i flashed the rom again this time to 4.4.2 Nov 2014. When i booted it was slow and i realised i forgot to clear phone memory. So i went to settings factory restore. I did not go into recovery mode to clear davik cache.I then used odin to flash to 4.4.2 Nov 2014. And thats where i am up to now with the battery problems.

    Rukbat - I checked the batt info and it shows that the screen is eating up the most battery 33% Android system 18% which is good.
    My problem is that when i charge the phone the battery percentage goes down and drains.It also gets quite hot.
    tried plugging in a diff battery and it still drains when charging.. It only charges in power saving mode.

    I dont know how to fix this
    Thanks for reading
    04-17-2015 10:27 AM

Similar Threads

  1. Automatically start casting when chrome opens up
    By Mitchell Gray1 in forum Google Chromecast
    Replies: 3
    Last Post: 04-17-2015, 03:18 AM
  2. Replies: 1
    Last Post: 04-16-2015, 08:38 PM
  3. how to retrieve snote files from lost phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-16-2015, 05:44 AM
  4. Replies: 1
    Last Post: 04-16-2015, 04:42 AM
  5. What does sync really do for a phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-16-2015, 03:14 AM
LINK TO POST COPIED TO CLIPBOARD