1. aroch1234's Avatar
    I have a moto x 2014 running android 5.0 with root. Over the past few months I've noticed that the phone app is using a lot of battery. But its not the stock phone app thats on my homescreen so I thought it was weird. I did some digging and found out that its the com.android.phone process that's using all this battery. I've tried everything to get rid of this problem but nothing has worked. It seems like its been draining more battery than the last few months. I've tried deleting all of my apps except for stock apps to see if one of them was the problem but that wasnt it. I've even tried to freeze the process but that disables my data. I think it has something to do with messaging but I don't know how to stop it. This can't be a normal thing since it hasn't always been there. Please help I'm so desperate!!!
    Attached Thumbnails Phone process draining battery, why?-screenshot_2015-06-03-23-28-11.jpg   Phone process draining battery, why?-screenshot_2015-06-03-23-28-14.jpg   Phone process draining battery, why?-screenshot_2015-06-03-23-25-55.jpg   Phone process draining battery, why?-screenshot_2015-06-03-23-14-15.jpg   Phone process draining battery, why?-screenshot_2015-06-03-23-14-20.jpg  

    06-06-2015 08:19 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. I would try a cache clear in recovery. Follow this: https://motorola-global-portal.custh...p/30,6720,9197

    And use the external steps. Instead of selecting reset device, there should be a cache clear option. This will not delete any personal information. Also something to keep in mind is this: with some devices, depending on the kernel, a cache clear can take upwards of several minutes. My Nex5 takes about 10 for this process, I wouldn't be surprised if it takes about the same for your X.
    06-06-2015 08:32 AM
  3. aroch1234's Avatar
    Just tried that but it didn't work
    06-06-2015 09:08 AM
  4. Golfdriver97's Avatar
    You might need to consider doing a factory reset.
    06-06-2015 09:25 AM
  5. aroch1234's Avatar
    I've done that before and that doesn't work either
    06-06-2015 09:46 AM
  6. Golfdriver97's Avatar
    Maybe reflashing the ROM?

    From the ZenFone 2.
    Android Central Ambassador Team Leader
    06-06-2015 11:59 AM
  7. aroch1234's Avatar
    tried that too. Even got rid of the root to see if that would do anything but it didn't help either
    06-07-2015 07:37 PM

Similar Threads

  1. why is my phone not syncing with google
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-12-2015, 10:10 AM
  2. Replies: 1
    Last Post: 06-10-2015, 07:35 AM
  3. Why has my Andriod nitro400 stopped working?
    By AC Question in forum AT&T Nitro HD
    Replies: 1
    Last Post: 06-10-2015, 07:30 AM
  4. How to restore my phone??plz help...
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2015, 07:29 AM
  5. G4 G3 Battery
    By chamomiami in forum LG G4
    Replies: 2
    Last Post: 06-06-2015, 08:37 AM
LINK TO POST COPIED TO CLIPBOARD