1. aymal0088's Avatar
    Hey all,

    rooting rookie here.

    I rooted my bionic a few months back to take advantage of hotspot. I rooted through pete's root, have superuser.

    never flashed my rom, so i'm still on stock. Using system version: 5.9.905

    I tried to unroot through pete's root again, but it gave me an adb error on the last step.

    I tried to unroot via es file explorer, but when I try to check off root explorer, it says superuser denied permission.

    I need to unroot it to send back to verizon for warranty. Received the new phone today. Prior to that I did a factory reset. Could that have messed up my root?

    Also, when I use Root Checker and run "Verify Root Access", superuser denies it too, and the results in root checker say :"Sorry! This device does not have proper root access".

    What does that mean, and which steps can I take to unroot it to completely stock?

    Will Verizon void my warranty if I just send it in like that? If so, then i'd rather save the money and put it towards the next nexus.

    Thanks!! And sorry if this has been answered several times, I've searched through the threads but did not come across a problem that described the same issues as mine.

    Also, if it helps, I don't think I did a recovery, so that's out of the window.

    09-25-2012 10:46 AM
  2. WebOS Refugee's Avatar
    My guess would be that the file permissions have gotten hosed in some fashion. I had to do some work on my phone a while back, including a factory reset, after which Titanium Backup (which requires root) complained about those permissions, asked whether it was okay to repair them, did so, and all was well.

    In the absence of TB, you might try just rerunning Pete's to see whether it overwrites the current permissions with the required ones.
    09-25-2012 12:14 PM
  3. aymal0088's Avatar
    Thanks, I will try that now.
    09-25-2012 03:45 PM
  4. aymal0088's Avatar
    didn't do it for me. Do you have any other suggestions that I could try?
    09-25-2012 05:59 PM
  5. aymal0088's Avatar
    this is the error message I get from pete's

    ERROR: adb could not be granted root access

    Try again from the start, but if the problem continues, check your version
    of Gingerbread -- hopefully you don't have a version where this exploit
    was fixed.
    09-26-2012 06:30 PM
  6. rhodest7's Avatar
    Might be late on my reply here...But Pete's no longer works on the Bionic, Motofail will work for you...and I have used Ginger unroot from the Market to unroot my bionic in the pas,t it worked Great.
    09-29-2012 09:08 AM
  7. WebOS Refugee's Avatar
    You might also try this option, mentioned by SamuriHL in another forum yesterday.
    09-30-2012 01:17 AM
  8. Hello_Robert's Avatar
    Download rsd lite 5.7.... find a vzx. 902 file that is stock. Put ur phone in fastboot mode.. flash the vzx file to your phone... then update OTA to. 905.. done..

    Good luck..

    bradenfontaine likes this.
    09-30-2012 07:48 PM
  9. titans30dude's Avatar
    Get the app called ginger unroot...worked great for me

    Sent from my SCH-I535 using Android Central Forums
    10-06-2012 07:35 PM
  10. mud.pony's Avatar
    Cancelled, figured out my own answer to my question .
    10-22-2012 09:01 PM

Similar Threads

  1. Can't UNroot
    By PreGk in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 40
    Last Post: 01-26-2012, 10:27 PM
  2. Can't unroot using OneClick Uninstaller
    By nmoreman in forum Epic 4G Rooting, ROMs, and Hacks
    Replies: 6
    Last Post: 12-06-2010, 10:57 AM
  3. So I rooted on 2.1, updated to OTA 2.2, and now I can't unroot. Help/advice?
    By mike86325#AC in forum Motorola X Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 10-13-2010, 03:58 PM
  4. Am i screwed?
    By butta75 in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 5
    Last Post: 07-12-2010, 12:48 AM
  5. Can i unroot my evo to install froyo and then re-root it?
    By sergio_sss in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 06-30-2010, 01:33 PM