1. Shanikki73's Avatar
    Have an unlocked dual-sim BLU Advance 5.0. Every time I receive a call (to either of my SIM numbers) and I try to answer, the call will drop and the person who called hears a busy tone. I can return the calls and then I have no problems with the call. Help. Need to be able to receive calls!! I have tried swiping the screen to the right as I did with other android phones (standard to answer calls, right?) The phone also offers the option to tap a button labelled "answer" in the notification section at the top if I am in an app. Neither method works
    04-13-2016 05:53 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you discussed this with your carrier? You might need to try a replacement SIM card.
    Laura Knotek likes this.
    04-14-2016 01:17 AM
  3. Shanikki73's Avatar
    Hi B. Diddy
    Thanks for the welcome. Have been visiting the forum for a while. very helpful even if I am just browsing. I did what you suggested and the tech guy there could not figure it out either. He tried a new SIM too. and that did not work. When I got home I tried a little bit of troubleshooting. I removed one SIM, tried the phone with one.Then I tried the other. Each time same result. I can call out and have a normal conversation, but when the call is returned, it would drop as soon as I answer. Then I tried something else. If I left the phone locked and a call came in, I would get the usual swipe to answer screen. If I answered from there, the call would not drop. If I left the phone unlocked or was in an app, the call would come in as a small drop down notification somethings and other times as a swipe to answer option. When i tapped to answer from that notification the call would drop. BTW the phone is running Android 5.1
    What can I try next that does not interfere with the warrantee in case I have to return which I won't bother to do if this is a simple problem..I hope
    04-15-2016 06:17 PM
  4. B. Diddy's Avatar
    Try booting into Safe Mode, which temporarily disables all 3rd party apps. On most Android devices, while powered on, press and hold Power until the Power Off menu appears. Press and hold the Power Off selection until the Safe Mode prompt appears. Tap OK.


    If the problem disappears in Safe Mode, then something you installed is causing the problem. You may have to uninstall apps one by one until the problem disappears. If the problem persists in Safe Mode, then it's more likely to be a hardware or firmware problem. In that case, I'd contact Blu for warranty repair or replacement.
    Shanikki73 likes this.
    04-15-2016 06:49 PM
  5. Javier P's Avatar
    Strange that it only works when the phone is locked. I've never used a Blu device but I guess the settings should be similar. Try this. Go to settings - SIM cards - connection priority and make sure that 'voice' is selected.
    B. Diddy likes this.
    04-15-2016 06:58 PM
  6. Shanikki73's Avatar
    Eureka!!!! Got it to work. Went to safe mode like you said. Worked with no problems in safe mode. So I proceeded as instructed to remove apps. The first suspect I removed was the antivirus...and bingo, calls came in with nary a hint of the previous trouble. lol.

    Then senior moment kicked in and I forget the name of the offending app. So I go back to Google play to look for and give it the worst rating of its life, would you believe that I couldn't find it..Scary disappearing evil android app moment...

    So I love my $60 android again...
    Thanks B. Diddy
    B. Diddy likes this.
    04-16-2016 06:34 PM
  7. B. Diddy's Avatar
    Great! If the antivirus app was installed from Google Play, you should be able to find it in your My Apps list, under All (which is the entire history of your installations).
    04-16-2016 07:37 PM
  8. Shanikki73's Avatar
    Yep found it. It was AVL. Not sure why but I think it saw some of my apps (including AC forums ) and some services as risky. But I couldn't find a way to allow apps I knew to be ok. Oh well, you live:you learn.
    B. Diddy likes this.
    04-16-2016 07:49 PM

Similar Threads

  1. Always On Screen shows a notification....
    By oneformula in forum Samsung Galaxy S7 edge
    Replies: 3
    Last Post: 02-04-2017, 03:23 PM
  2. How do I connect my S5 to friendcaster pro
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-18-2016, 05:43 PM
  3. How to delete photos from gallery on HTC One phone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-18-2016, 05:40 PM
  4. why is my camera not responding
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-13-2016, 05:54 PM
  5. why is my camera not responding
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-13-2016, 05:49 PM
LINK TO POST COPIED TO CLIPBOARD