1. Elvis334's Avatar
    I have a Blu Studio C HD (not rooted). It has worked flawlessly for nearly two years.

    Three weeks ago is started acting stupid. Apps slowed down, jerky, you know the story.
    Also, USB decided not to work. (This was an (unrelated?) PC issue and has been fixed).
    Phone Memory was full so I used Ccleaner and it helped. Also ran AVG and Malwarebytes.

    Last week I had had enough and decided to start removing apps until I found the one that was causing the issue. First I ran Ccleaner, AVG, and Maliwarebytes. The found no issues. I backed up everything. Then I removed WeatherChannel. No help. Removed Iheartradio. No help. Removed Pandora. No help. Then the phone would not let me open “settings” any longer to continue removing Apps.
    I decided “Fine. I will wipe it and start over.”

    Powered off. Removed battery the Sim card and SD Card. Reinstalled battery

    Volume up and Volume down at same time and then (also) power button.
    Volume up to recovery mode. (android robot with exclamation point)
    Power button = menu
    Volume down to “Wipe Date/Factory reset”
    Bottom left button thing for enter

    “Yes – delete…” enter

    --wiping data..
    Formatting /data..
    Fromatting /cashe…
    Data wipe complete.

    Reboot enter

    “BLU” Splash screen comes up
    eventually it goes away and “Waiting Sim Card Initalitaion” appears
    then
    the waving android guy comes up – setup language screen / Emergency call screen– enter NEXT

    Then I get an error message
    “Unfortunately, BootReceiver has stopped” or “Unfortunately GooglePlay has stopped”
    OK
    NEXT
    Nothing happens.

    Or “Waiting Sim Card Initalitaion” reappears

    I never get to the second setup screen.

    I have tried with the SIM card installed. Phone does not see it.

    So I tried:

    Volume up and Volume down at same time and then (also) power button.
    Volume down to Factory Test.

    I ran the Factory Test and the phone DOES see this card. Tried a different card. It recognizes it also. I tried both cards at the same time. Phone sees the cards but does not read them.

    So it is not the SIM card.

    The Backup did not work (unrelated?) so I do not have a backup.

    Is it possible the KITKAT file is corrupt?
    Can I upgrade to KITKAT 4.4?
    Can I upgrade to Lollipop?

    Via USB or SD Card?

    Thanks
    09-07-2016 02:40 PM

Similar Threads

  1. Can't choose any new phones as current phone in profile?
    By libra89 in forum Site Feedback & Help
    Replies: 4
    Last Post: 09-26-2016, 11:46 AM
  2. Is There A Classified Section Anywhere In Here?
    By Gunny Fitz in forum Samsung Galaxy Note 7
    Replies: 4
    Last Post: 09-08-2016, 01:06 PM
  3. Replies: 0
    Last Post: 09-07-2016, 02:07 PM
  4. Can The FM Activation In the S7 Be Used To Transmit?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-07-2016, 10:18 AM
  5. Why is Clear Security Credentials in Android 6.01 greyed out?
    By Terry Hubbs in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 09-07-2016, 10:08 AM
LINK TO POST COPIED TO CLIPBOARD