1. Nodnerb's Avatar
    Anyone have any ideas what to try? I am using an unlocked at&t captivate on my canadian fido network. I am using the same apn settings I've used on other androids. I have the fido network selected(green radio button), did a restart. Double and tripple checked my settings and tried a few variations on line. No luck so far.

    This is what I am using:

    apn: internet.fido.ca
    username: fido
    Password: fido
    mmsc: http://mms.fido.ca
    mms proxy: 205.151.011.013
    mms port: 80
    mcc: 302
    mnc: 370

    Am I missing something, simple I hope?
    01-05-2011 01:16 PM
  2. jhinman's Avatar
    I have a Rogers Captivate on fido and it works fine. I leave user name and password blank but other then that use the same settings.

    You might want to check and make sure data roaming is check. I have found Non Fido/ rogers unlocked phones often think they are always roaming when they have a fido sim because they don't realize rogers and fido are the same network.
    04-05-2011 06:50 AM
  3. power18002003561's Avatar
    hey can you guys use your stock wifi hotspots cause i have a unlocked rogers Captivate on att and it says i need to call rogers care
    09-04-2011 08:43 PM
LINK TO POST COPIED TO CLIPBOARD