1. AC Question's Avatar
    For probably about a month, I had my chromebook set up to unlock with my phone (the s8 running android 7.0). One day, out of nowhere, it stopped working. Yes, both of my devices were connected to bluetooth and wifi. They were directly next to each other every time I tried unlocking my chromebook. So, today, I tried deleting the pair made between my devices and setting smart lock up over again. When I tried connecting the two with bluetooth, the first step of the process, the chromebook wouldn't even recognize my phone's existence. No matter how many times I tried, my chromebook wouldn't be able to see or connect to my phone. I tried it the other way around, too, because my chromebook would pop up on my phone, but every time I tried pairing them it would give me the message "failed to connect". I mean, It's not life and death that I'm able to use smart lock on my chromebook, it's just so much faster.
    Sim8 likes this.
    06-27-2017 05:01 PM
  2. anon(238680)'s Avatar
    Welcome to the forums. Did either of the devices get an update recently? That would be my first choice of cause. Baring that, isolate each device and determine whether BT and wifi are working. When you say the Book can't see the S8, that would indicate the S8 is not set as visible, which would be reinforced when you say the S8 can see the Book but won't connect. Trouble shooting is isolate, determine good or bad, determine problem, isolate fix. I have also asked that your post be moved the Chromebook forum for more help.

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Android Central.
    Sim8 likes this.
    06-27-2017 05:19 PM
  3. Cam_neely's Avatar
    For probably about a month, I had my chromebook set up to unlock with my phone (the s8 running android 7.0). One day, out of nowhere, it stopped working. Yes, both of my devices were connected to bluetooth and wifi. They were directly next to each other every time I tried unlocking my chromebook. So, today, I tried deleting the pair made between my devices and setting smart lock up over again. When I tried connecting the two with bluetooth, the first step of the process, the chromebook wouldn't even recognize my phone's existence. No matter how many times I tried, my chromebook wouldn't be able to see or connect to my phone. I tried it the other way around, too, because my chromebook would pop up on my phone, but every time I tried pairing them it would give me the message "failed to connect". I mean, It's not life and death that I'm able to use smart lock on my chromebook, it's just so much faster.

    I have the exact same thing happening with my S8. Did you find a solution?
    10-12-2017 03:18 AM
  4. MobileNick's Avatar
    I just tried with my Acer Chromebook 14 - same issue as others here. Prior phone (Moto G5 Plus) connected just fine and was able to use it to unlock the Chromebook. Something to do with BT 5.0 maybe??
    10-18-2017 06:20 PM
  5. tonyinorlando's Avatar
    I just tried with my Acer Chromebook 14 - same issue as others here. Prior phone (Moto G5 Plus) connected just fine and was able to use it to unlock the Chromebook. Something to do with BT 5.0 maybe??
    Ever since my Acer Chromebook 14 was updated on 10/13, I can no longer connect my N6p via bluetooth either. I do, however, have access to the Play Store now so I'll live with entering my password to access my Chromebook for now.
    10-23-2017 04:53 PM
  6. bstringy's Avatar
    Ever since my Acer Chromebook 14 was updated on 10/13, I can no longer connect my N6p via bluetooth either. I do, however, have access to the Play Store now so I'll live with entering my password to access my Chromebook for now.
    Having the same issue Acer Chromebook 14 and Galaxy S8.
    11-01-2017 12:24 PM
  7. dcwiker05's Avatar
    Having the same issue Acer Chromebook 14 and Galaxy S8.
    Same issue, Samsung Chromebook Plus, Samsung S8 and Pixel 2 XL both have the issue
    11-14-2017 07:56 PM
  8. pete1118's Avatar
    Same issue, Samsung Chromebook Plus, Samsung S8 and Pixel 2 XL both have the issue
    Pixel 2 XL, N23 Yoga and a Chromebit here also not working.
    11-22-2017 04:37 AM
  9. CADVID80's Avatar
    Same here. Trying like hell to connect Pixel XL 2 to Asus Chromebook Flip C302. They show in both devices BT lists, I hit pair and it shows the matching code, I hit pair again on both devices then for a brief moment the Chromebook shows as connected but then I get a pop up saying failed to connect. Tried rebooting both devices, forgetting and adding again, nothing works. Just want to be able to use the smart lock feature instead of entering PW every time.
    11-28-2017 05:08 PM
  10. pmp6nl's Avatar
    I am having the same issue with a S8 and Samsung Chromebook Plus. Seems to be a bug or something. It works some times, but mostly doesn't. Anyone find a resolution?
    12-08-2017 12:55 PM
  11. trgfunds's Avatar
    Having the exact same problem, Dell Chromebook 7310 13 inch / Samsung Galaxy S7 - Have reset everything, removed devices from my account, enabled disabled "Trust Agents", enabled disabled setup, bluetooth, settings, etc. etc. etc. etc. etc. just like all the forums say... now the laptop won't even find the phone. YES I am sure bluetooth is enabled. YES I am sure they are close enough. YES I am looking at the instructions. YES I have searched the forums. This isn't rocket science. Frustrated as hell. :/
    12-16-2017 06:20 PM
  12. MobileNick's Avatar
    So just bought an ASUS chromebit and that has the same result trying to connect BT to my Galaxy S8. I assume then something about BT on the S8 just doesn't play nice with Chrome OS in general.

    But ... good news is that even though "fails to connect" - it is still paired and apparently that is good enough to use phone to unlock the Chrome device! That was my primary motivation to have my phone paired with Chrome, so even if it fails to connect, I can still unlock (both Chromebook and Chromebit) so I am happy about that I didn't even think to try before - when it said "failed to connect" I just gave up. For whatever reason, today I tried to do the BT unlock and it worked!
    01-14-2018 02:15 PM
  13. happyboy7's Avatar
    I've got this problem too. My Samsung Note 8 was unlocking via bluetooth my Chromebook perfectly until last week when my phone updated to Oreo. I've tried unpairing/repairing numerous times but I keep getting Failed to connect. I can still use bluetooth headphones on the Chromebook, and also on the Note 8. So, bluetooth works independently, just not between the Chromebook and phone. Weird!
    04-08-2018 02:49 PM
  14. jvangurp's Avatar
    For probably about a month, I had my chromebook set up to unlock with my phone (the s8 running android 7.0). One day, out of nowhere, it stopped working. Yes, both of my devices were connected to bluetooth and wifi. They were directly next to each other every time I tried unlocking my chromebook. So, today, I tried deleting the pair made between my devices and setting smart lock up over again. When I tried connecting the two with bluetooth, the first step of the process, the chromebook wouldn't even recognize my phone's existence. No matter how many times I tried, my chromebook wouldn't be able to see or connect to my phone. I tried it the other way around, too, because my chromebook would pop up on my phone, but every time I tried pairing them it would give me the message "failed to connect". I mean, It's not life and death that I'm able to use smart lock on my chromebook, it's just so much faster.
    05-04-2018 12:20 PM
  15. jvangurp's Avatar
    ASUS C302 with a Moto Z Play here - same problem. I experienced this a few months ago and after many repeated attemps with forgetting BT devices and pairinbg and repairing it eventually worked, however currently I'm stuck as well, trying the same things over and over again. It's very frustrating.
    05-04-2018 12:21 PM
  16. Dave Harbud's Avatar
    Same problem with my Toshiba Chromebook 2 and Nokia 7 Plus.
    05-06-2018 04:38 AM
  17. diva700's Avatar
    Same problem with my Asus Chromebook Flip and Moto G5 Plus. Cannot re-connect Smart Lock since upgrading phone from Moto G3.
    05-26-2018 12:32 PM
  18. Sim8's Avatar
    Similar problem with Acer Chromebook R11 and Samsung Galaxy Note 3 (too ancient now?)
    06-02-2018 02:19 PM
  19. Jay Maxwell1's Avatar
    Still for my chromebook plus and S8. Anybody find a work around?
    07-13-2018 05:51 AM
  20. Koffeeshop77's Avatar
    Still for my chromebook plus and S8. Anybody find a work around?
    you have to let it ask twice, as in,
    the first number it shows to verify on you mobile device is wrong(as in,way off)
    i rejected that on my mobile AS SOON AS IT SOON POPPED UP,
    then i waited...
    and out of nowhere (like 30 sec later) it was still trying to connect,
    at that time i still did had not touched anything on the chromebook (samsung pro),
    yet there matching CODES regenerated on both devices, i hit pair on the phone and and accept on the book and and they are now paired.

    it's really more of a keep trying and you will get it kind of deal, i almost stopped after i found this thread, then i noticed the pairing codes did not match and tried it quite a few more times not accepting that i couldn't get a code to match up, when i took a pause i had matching codes, don't know why they made it so difficult must be a glitch in software. wanted to share for others, good luck.
    08-23-2018 04:16 AM
  21. spyware89's Avatar
    Hi All, Potential fix below
    I have been having this issue since I switched from my Nexus 6p to my Moto x4 AndroidOne edition a few months ago. (Samsung Chromebook Pro) and honestly just gave up because I was running in the unstable dev channel for my chromebook anyway.
    I switched back to stable last week and was still having this issue (After powerwashing multiple times.) I just got it to work finally, by going to chrome://flags on my chromebook, and enabling a flag that said 'use newblue Bluetooth daemon' just because I was curious. But I did that and it is working now for me.

    TL,DNR
    1. Unpair both from each other
    2. Disable smart lock on chromebook
    3. Enable smart lock on phone, add trusted place or device (Optional?)
    4. Turn on flag above
    5. Reboot chromebook
    6. Have phone unlocked, turn on smart lock on chromebook, follow steps.
    7. Profit
    09-27-2018 11:13 PM
  22. Bhmm's Avatar
    Hi All, Potential fix below
    I have been having this issue since I switched from my Nexus 6p to my Moto x4 AndroidOne edition a few months ago. (Samsung Chromebook Pro) and honestly just gave up because I was running in the unstable dev channel for my chromebook anyway.
    I switched back to stable last week and was still having this issue (After powerwashing multiple times.) I just got it to work finally, by going to chrome://flags on my chromebook, and enabling a flag that said 'use newblue Bluetooth daemon' just because I was curious. But I did that and it is working now for me.

    TL,DNR
    1. Unpair both from each other
    2. Disable smart lock on chromebook
    3. Enable smart lock on phone, add trusted place or device (Optional?)
    4. Turn on flag above
    5. Reboot chromebook
    6. Have phone unlocked, turn on smart lock on chromebook, follow steps.
    7. Profit
    Just want to say thank you. I had this issue with my Nokia 6.1 Android One...with Pie. Smart lock would stay disabled even after connecting the chromebook HP X2 with the device. But the above solution worked for me. Thank you. Searched the web, googled with no solution. Until your post. I'm on the latest stable chrome 71. Please note I did not have an issue with bluetooth pairing before this fix ...but that would still not enable the smart lock. The new smart lock setting is under "Connected Devices" and does not need the two devices to bluetooth paired in the the Bluetooth Setting category. But I think it's uses bluetooth since this what the flag is changing.
    12-29-2018 02:14 PM
  23. joelbon's Avatar
    Hi All, Potential fix below
    I have been having this issue since I switched from my Nexus 6p to my Moto x4 AndroidOne edition a few months ago. (Samsung Chromebook Pro) and honestly just gave up because I was running in the unstable dev channel for my chromebook anyway.
    I switched back to stable last week and was still having this issue (After powerwashing multiple times.) I just got it to work finally, by going to chrome://flags on my chromebook, and enabling a flag that said 'use newblue Bluetooth daemon' just because I was curious. But I did that and it is working now for me.

    TL,DNR
    1. Unpair both from each other
    2. Disable smart lock on chromebook
    3. Enable smart lock on phone, add trusted place or device (Optional?)
    4. Turn on flag above
    5. Reboot chromebook
    6. Have phone unlocked, turn on smart lock on chromebook, follow steps.
    7. Profit
    Just wanted to say that this worked for me. Although, the flag name as of June 5, 2019 is called "Newblue". It took me awhile to find the flag, but once I found it and enabled it then I was able to get smart lock to work perfectly. THANK YOU
    06-05-2019 02:21 PM
  24. ptkelly's Avatar
    I can't get it to work with my Pixel 3 either. It worked 18 months ago but a new Chromebook or a new version of Chrome OS took it away never to return. Whenever I see instructions posted on how to do it I give it a shot with utter futility.
    06-06-2019 06:47 AM

Similar Threads

  1. How do I disable safe mode using my PC/adb?
    By Hasibuzzaman Tonmoy in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 06-28-2017, 12:11 AM
  2. Replies: 1
    Last Post: 06-27-2017, 05:48 PM
  3. Replies: 1
    Last Post: 06-27-2017, 05:11 PM
  4. Problem woth Viber on Alcatel Pixi 4027D
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2017, 04:57 PM
  5. S8 Bluetooth skipping , stuttering.
    By gsaintpeter in forum Ask a Question
    Replies: 0
    Last Post: 06-27-2017, 04:48 PM
LINK TO POST COPIED TO CLIPBOARD