1. pinoyavenger's Avatar
    Hello from the Philippines!

    I'm new to the forums.

    I hope you can help me understand why both my Moga Pro controller and Sony Smartwatch won't connect with my Acer devices running Jelly Bean:
    Acer Z2 Phone: Acer Liquid Z2 - Full phone specifications
    Acer B1 Tablet: Acer Iconia Tab B1-A71 - Full phone specifications

    I tried both accessories with the phone and tablet - neither works. I followed the instructions and downloaded the required apps but I still can't get either to work.

    However, when I tried them on an old generic Gingerbread phone from China, both accessories worked perfectly!

    I thought maybe one of the apps I installed might be causing the problems so some setting I set, so I reset both devices, downloaded the required apps again, and tried to pair.
    Still nothing.

    I just don't get. Can anybody help?
    Thanks in advance!

    12-11-2013 09:38 PM

Similar Threads

  1. Flashes 4.4 GPS ROM and radio. Now stuck on boot loop.
    By quicksilver53 in forum HTC One Rooting, ROMs & Hacks
    Replies: 22
    Last Post: 12-27-2013, 01:23 AM
  2. USB storage only works when I enable "USB DEBUGGING"
    By Qyseus in forum Google Nexus 5
    Replies: 1
    Last Post: 12-11-2013, 09:27 PM