1. mypokerface's Avatar
    I just got a used Dell Streak 7 Android tablet, it has Android 2.2.2 , I don't know if it's rooted, I have no access to the app market because it has all previous owners stuff on it. I can't even delete their photos from it, I do it, but i reboot and the photos are back. It does not keep any of the settings that I change either when I reboot. It is the wifi & T-mobile version, even though there is no outside branding for T-mobile on device itself.

    I just want to wipe it clean and start all over again, but cannot get it to reset, tried both software version and the little button by the SD card slot. I would like to upgrade to Android 3.2 if possible also, but my main purpose right now is to wipe all the previous owners stuff off of it, set up the market place with my account and move forward (and hopefully get it to remember the settings I set when I reboot, because it's a pain in the butt to everytime re-enter my home wifi code).

    help, please!
    12-24-2011 08:29 PM
  2. phantomodopera's Avatar
    I THINK u have to hold the power button while you hit the little hole by the sd card with a pin- Not positive though
    12-27-2011 07:54 PM
  3. mypokerface's Avatar
    I'm going to try to do the reinstall by putting the update.pkg on an SD card. Do you think there will be a way too root a Streak 7 and install ice-cream sandwich after it comes out?
    12-27-2011 08:40 PM
  4. phantomodopera's Avatar
    Doesnt the update package just update the OS? It will keep the previous owners info you are trying to get rid of. I think you need to do the factory reset, then do the update.
    12-28-2011 07:09 AM
  5. mypokerface's Avatar
    i've been trying the factory reset without reinstalling, and it doesn't do anything for deleteing the data. I'm hoping that reloading 2.2.2 will do it. I haven't found any other way, if that doesn't work, I don't know what else to do.
    12-29-2011 12:11 PM
  6. phantomodopera's Avatar
    I found the following- I would think you would want to do the emergency recovery.
    Dell Streak 7 hard reset - PDA Smartphone PNA hard reset soft reset
    12-29-2011 08:32 PM
  7. mypokerface's Avatar
    thank I will try it.
    12-31-2011 04:12 AM
  8. mypokerface's Avatar
    I tried to reload from SD card, held the volumn up and power button, got the menu, selected the SD card restored. Started, then stopped, said "E:Error in /mnt/sdcard/sdcard2/update.pkg.dec" any ideas?
    01-06-2012 01:04 AM
  9. swim33's Avatar
    I have tried the same thing with 3.2 and if you have 2.2.2 and are trying to use a 2.2.2 "update" it won't work because your device recognizes that it is the same and not an update therefore keeps the original that is on your device.
    04-08-2012 10:24 PM
  10. Franco Paziente's Avatar
    I know this post is an year old but I'm having the exact same problem here I've been looking at many forums and no luck. have you found any solution by now.
    12-30-2012 07:10 PM