1. rebelhell's Avatar
    I just picked up the Venue 8 7840 and I love it so far. However it keeps complaining that the SD Card is being removed. It's 32g Sandisk Extreme. Seems to work fine for half a day or so and then complains I ejected it. I've re-inserted and tried rebooting but the problem keeps popping back up. Any suggestions?

    Posted via the Android Central App
    04-08-2015 09:43 AM
  2. mstrblueskys's Avatar
    I had a phone that did this to me. I treated it like an old Nintendo cartridge and just blew into the SD slot and on the SD card to make sure all the connections were as clean as I could lazily make them. It worked. Maybe it will help you! Check the little lock switch too and make sure it's completely unlocked (or locked, if that's how you're rolling). Switches can monkey things up. Otherwise try formatting the card when you have it in the tablet.
    04-08-2015 09:53 AM
  3. rebelhell's Avatar
    Just cleaned the card with alcohol. Can't really get in there to clean the contacts inside but I blew it out with compressed air. Formatted fine inside the tablet, we'll see how long it lasts. Thanks for the fast reply.

    Posted via the Android Central App
    04-08-2015 09:59 AM
  4. rebelhell's Avatar
    The problem persists...
    I've ordered a new SD card, well give that a go I guess. Not sure what else to try.

    Posted via the Android Central App
    04-10-2015 07:40 AM
  5. PhilWitt's Avatar
    I had the same problem. A different SD card fixed it. Haven't had the issue again.
    04-10-2015 10:51 AM
  6. rebelhell's Avatar
    The new card seems to have fixed the problem...
    The old one still seems to work fine in my PC though. Guess I'll keep it around for a Raspberry Pi project or something. Thanks for the help guys.

    Posted via the Android Central App
    04-13-2015 12:59 AM
  7. scopeman's Avatar
    Well, I just picked up my new Dell tablet and I am having the exact same problem. Can you tell me what kind of SD card you ended up using? I may have to get the same one.

    Posted via the Android Central App
    05-24-2015 09:17 PM
  8. Bossy573's Avatar
    SanDisk Ultra 128GB UHS-I/Class 10 Micro SDXC Memory Card Up To 48MB/s With Adapter- SDSDQUAN-128G-G4A [Newest Version]

    I have this and not a single problem.
    05-25-2015 05:38 PM
  9. rebelhell's Avatar
    I'm using a SanDisk Extreme 64 gb card. Of course the one I was having trouble with was also a SanDisk so... Not sure how that helps.

    Posted via the Android Central App
    05-28-2015 03:46 AM
  10. mge1201's Avatar
    I am also having this issue and using SanDisk Extreme Plus 64GB UHS Speed Class 3.
    06-01-2015 07:59 PM
  11. scopeman's Avatar
    Well it's been several months now and this aggravating problem is still plaguing me. Even, after upgrading to lollipop. I am ready to dispose of this tablet as soon as I see what the new tablets coming out will look like. Sad though, the screen is beautiful, but the amount of bugs in this thing is so annoying.

    Posted via the Android Central App
    09-14-2015 12:36 PM
  12. rustumhind's Avatar
    Hi guys,

    I am facing the same issue. I have Dell Venue 8 Android tablet. I got 32gb SDXC Sandisk micro SD card but everytime I get the message that it has been unexpectedly removed. Can you please help with any tips you might have to solving this problem? Thanks in advance.
    11-27-2015 08:39 PM
  13. spacedogg's Avatar
    Bumping this thread. I just purchased a used Dell Venue 8 7000 and everything is great except that on occasion (a couple times per day) the tablet will say that the microSD card has been unexpectedly removed. I am using a 64GB SanDisk Extreme (SDSDQXL-064G-A46A - 64GB) which has the following specifications -- Class 10 / U3 / 60MB/s read and 40MB/s write).

    In my experience some microSD card readers can be really finicky or particular about what speed cards it will accept. In particular they are very particular about very fast microSD cards. For example I had one electronic device that loved Class 6 or slower microSD cards but hated (did not read) true Class 10 or higher speed microSD cards.

    The added problem in testing this theory is that manufacturers adopt very "loose" standards for different classes of speed. For example, a Sandisk Extreme is classified by the manufacturer as a Class 10 with 60MB/s read and 40MB/s write speed. But a 32GB Kingston microSD (SDCA10/32GBCR) will also be classified as a Class 10 by its respective manufacturer but will actually be closer to the speeds 20MB/s read and 10MB/s write which is closer to speed of a Sandisk Class 4 or Class 6.

    So my first test will be to try using my trusty old 32GB Kingston (SDCA10/32GBCR) Class 10 (similar to Sandisk Class 6 speeds) to see if a slower microSD will exhibit similar issues. My previous electronic device (camera) loved this Kingston Class 10 microSD card...so I am hoping this will solve the problem. Please note that the 64G Kingston Class 10 microSD...the manufacturer claims to be 90MB/s read and 80MB/s write so it may note work as well.

    Oh and the fact that the microSD has to be FAT32 is dumb. I wished that Dell had allowed other formats. Have to reformat my cards as I usually use EXT4 or NTFS. Oh well...
    12-15-2015 11:40 AM
  14. spacedogg's Avatar
    So I have been using my tablet for approximately 24 hours with the 32GB Kingston SDCA10/32GBCR Class 10 microSD. Not a single error message. I will probably keep using this microSD card for now. I may experiment with a larger capacity 64GB microSD when I next get around to purchasing one.

    So looks like SanDisk Extreme is a bit of a hit or miss for people with this tablet (posts #1 and #10 above confirm that SanDisk Extreme does not play nicely with this tablet). I would concur with that conclusion. I would probably recommend maybe trying a slower tier from SanDisk like their SanDisk Ultra line. But, I would stay away from anything faster like the SanDisk Extreme, Extreme Plus, Extreme Pro etc...keep those for other devices.
    12-16-2015 04:55 PM
  15. mraza1983's Avatar
    I have a Venue 10 7040 and I was getting the same "whining" from the device. I initially had a PNG card, and the would mount and I mount on its own. I tried a sandisk memory card which wouldn't unmounted entirely, leaving the options to unmounted unselectable from settings. The card that worked for me was the 128 GB Patriot model PSF128GMCSDXC10, which has been running for two weeks now without a single hitch.
    08-12-2016 12:40 AM

Similar Threads

  1. Problem with moving Apps to SD card
    By Ricardo Paes in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-11-2015, 08:06 AM
  2. How do I see apps on my sd card in a different device?
    By AC Question in forum General Help and How To
    Replies: 6
    Last Post: 04-10-2015, 08:56 AM
  3. removing start up tune
    By Stephen Murt in forum HTC One M9
    Replies: 2
    Last Post: 04-08-2015, 04:09 PM
  4. Verizon charged my card...
    By jeepentj in forum Samsung Galaxy S6 edge
    Replies: 2
    Last Post: 04-08-2015, 03:30 PM
  5. How can I remove the case from my S3?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 04-08-2015, 10:30 AM
LINK TO POST COPIED TO CLIPBOARD