11-03-2012 11:12 AM
34 12
  1. dmevis's Avatar
    i was unable to install the upgrade. Saw your post about going back to .902, then .905, then ICS. This also worked for me.
    Thank you.
    10-25-2012 12:51 AM
  2. mwyarm's Avatar
    On 905 with root and update failed. Tried factory reset and still fails. My error but also lost my backup in the process. So, can someone provide links and required files to 902 so i can try that?
    10-25-2012 10:21 AM
  3. PhoenixMike's Avatar
    Remember how you could do a full restore using the full 905 flash file if you were on Gingerbread?

    That file is now available for 246.
    I looked and cannot find it. Can you please link it?

    Sent from my Galaxy Nexus using Android Central Forums
    10-25-2012 11:52 AM
  4. Ry's Avatar
    I looked and cannot find it. Can you please link it?

    Sent from my Galaxy Nexus using Android Central Forums
    Lefty Drummer likes this.
    10-25-2012 12:34 PM
  5. moonshiner420's Avatar
    For those of you who have had the update fail on them, go the link below and follow the instructions to flash the .246 fxz file. After multiple attempts at downloading and installing the file from OTA, I finally gave up and went this direction. I'm now running on ICS and my phone is running smooth as butter!

    Link to flash .246 fxz file:
    10-25-2012 01:56 PM
  6. fandrax's Avatar
    So, I looked in the /cache/ folder where the OTA is stored as "Blur_Version.5.9.905.XT875.Verizon.en.US.zip" and found a last_log file in the /cache/recovery/ folder. At the end of the log file there are these statements:
    Verifying current system...
    file "/system/bin/mount_ext3.sh" doesn't have any of expected sha1 sums; checking cache
    failed to stat "/cache/saved.file": no such file or directory
    failed to load cache file
    script aborted: "assert failed: apply_patch_check("/system/bin/mount_ext3.sh", "1810bb2ccd607e2f6cfbeafa158bb3a89629d60b7","3a8382950bd4a6226349607d099afcbd93653d48")
    E:Error in /cache/
    (Status 7)
    Installation aborted.

    From this I infer that a checksum is being applied to the mount_ext3.sh file and the installation is aborted if the checksum does not match. Coincidentally, that is the file that has a couple of chmod commands added to it to keep root permanent. I don't know if a factory reset will put that file back to its original state. I also don't know if it would be possible to restore root after doing so. I also don't know what other checks may fail if that one succeeds. However, it seems clear that VZW is, at a minimum, attempting to prevent rooted phones from taking the OTA to ICS by failing the installation on phones that have used the forever root method to maintain root through OTA updates.
    I had the same issue with multiples fails. I reverted to the old mount_ext3.sh file and the update went through without an issues. Thanks oldguy1950
    10-25-2012 08:29 PM
  7. Egz's Avatar
    My phone was mostly stock, just rooted and annoying apps renamed. Woke up this morning, and saw it was ready to update. It failed. Then remembered about the apps, renamed them back to stock. Now my phone says there is no update.
    10-26-2012 06:51 AM
  8. friedenswind's Avatar
    hello fandrax, can you let me know how exactly doing what you did to make it work?
    10-28-2012 10:35 PM
  9. bparent's Avatar
    Would you be so kind to provide a copy of your old mount_ext3.sh so I can get my OTA update to work. I am getting the same error. Thanks.
    11-03-2012 11:12 AM
34 12

Similar Threads

  1. Hope do I stop ICS update warning on Galaxy Nexus?
    By BJB1 in forum General News & Discussion
    Replies: 0
    Last Post: 06-03-2012, 05:18 PM
  2. ICS update leaks on vzw doc!
    By Premium1 in forum Verizon HTC Rezound
    Replies: 52
    Last Post: 05-03-2012, 07:07 AM
  3. ICS update leaks on vzw doc!
    By Premium1 in forum Droid RAZR
    Replies: 5
    Last Post: 04-27-2012, 04:16 PM
  4. Update Swype on Stock GB?
    By Jaysus in forum HTC EVO 4G
    Replies: 5
    Last Post: 08-16-2011, 11:01 PM
  5. Froyo update failed on stock unrooted Bravo.
    By mordak in forum Motorola Bravo
    Replies: 4
    Last Post: 04-20-2011, 03:23 AM