1. dbell525's Avatar
    I rooted my Charge with the voodoochargekernel file and everything seemed to be working fine. Then using ROM Manager tried to backup my current ROM (EE4) and the phone will not finish booting. It hangs on the Samsung screen. The Volume/Home/Power press does not do anything either. Please help me fix this.
    09-04-2011 11:04 PM
  2. dbell525's Avatar
    Okay I reflashed to stock, ran the OTA update. Flashed the voodoo kernel via ODIN. Phone works except I can't boot to recovery. I'm on information overload trying to read up on how to fix this. I am now able to run adb, but have no real idea how to use it. When I run adb shell, I get the #. I'm not able to remount the sdcard no matter what I try. Can someone point me in the right direction. I need to be able to boot to recovery first I think.
    09-07-2011 10:35 PM
  3. piizzadude's Avatar
    which kernel did you flash and does it have CWM included? Most kernel flashes are just that, the kernel, no CWM included

    Go to this thread and flash the file there and see if you can get into recovery: http://forums.androidcentral.com/dro...4-0-0-8-a.html
    dbell525 likes this.
    09-07-2011 11:32 PM
  4. Halo's Avatar
    And do NOT use ROM Manager. It does not get along with the Charge as you found out the hard way.
    dbell525 likes this.
    09-08-2011 08:39 AM
  5. dbell525's Avatar
    which kernel did you flash and does it have CWM included? Most kernel flashes are just that, the kernel, no CWM included

    Go to this thread and flash the file there and see if you can get into recovery: http://forums.androidcentral.com/dro...4-0-0-8-a.html
    The file I used was VoodooChargeKernel4.tar.md5 from one of the sticky threads above. I'll try the one you referenced tonight. Thanks.
    09-08-2011 10:51 AM
  6. piizzadude's Avatar
    somewhere there is a SDcard fix for the issue you had above, if reflashing doesnt help let me know and I will try to find it. Not sure if it is here or on XDA
    09-08-2011 01:58 PM
  7. dbell525's Avatar
    Found this link.

    REPOST! [Fix]EE4 sdcard write protection for root users

    It states to flash via CWM. I'll give it a shot over the weekend probably. Don't think i have time tonight. Thanks.
    09-08-2011 02:57 PM
  8. piizzadude's Avatar
    no problem, let us know how it goes
    09-08-2011 05:45 PM
  9. dbell525's Avatar
    no problem, let us know how it goes
    Status: I flashed the same voodoochargekernel4.md5 again and then CWM 4.0.0.8 as suggested. I am rooted, have EXT4, can get to recovery boot. I backed up my ROM that I was running prior to this. I had flashed back to stock and then OTA'd to EE4. I also installed Launcher Pro plus several apps. Not sure if that is the issue or not but in the notification bar I'm getting Red Triangle w. "!". It says Unexpected Error: Send Error Report. When I click on the notification, a window pops up and goes away right away. The header says something about SMS Error Report, but doesn't stay up long enough to read. Also at least of few of my apps aren't running right. e.g. Dolphin Browser opens, then shuts down right away. Anything that isn't working right, I'm uninstalling hoping to isolate what's causing the error. Any ideas?
    09-09-2011 05:56 PM
  10. piizzadude's Avatar
    when you say that you backed up the ROM, did you mean through CWM? If so, there is the culprit. CWM on the CHarge is horrible at restoring those backups. You would save yourself aggravation if you just reflash the ROM, and then reinstall everything individually. I know it is a pain but you are going to have a ton of errors.

    If you backed them up with TiBup or mybackuppro, I would still say it might be a bad flash
    09-09-2011 06:13 PM
  11. dbell525's Avatar
    Since I didn't flash a ROM, should I expect the phone to behave as it did before I flashed the kernel and CWM? The error appears to be isolated to Go SMS. I reinstalled it and everything else I had uninstalled trying to isolate. No more error and everything seems to be running okay. I'll keep watching. Thanks much for your help.
    09-09-2011 06:27 PM
  12. piizzadude's Avatar
    sorry I forgot that we we just doing a kernel. yeah with flashing just a kernel, you shouldnt see any changes in the OS or anything else.

    Glad you got it isolated and fixed.
    dbell525 likes this.
    09-09-2011 06:31 PM
  13. dbell525's Avatar
    Yes I backed up w/ CWM. I didn't reflash since I just did the other day. I think I isolated the error to Go SMS. Reinstalled it and several other programs that weren't working and so far so good. Thx for the tip on a better backup.
    09-09-2011 07:29 PM
LINK TO POST COPIED TO CLIPBOARD