1. imnuts's Avatar
    So I spent the weekend working on some things, and one of them was trying to get CWM fixed up. I believe that I have all of the problems fixed, but I can only do so much testing on my own. The button mappings work, and I have been using this and similar versions (bugfixes and such added since then) for about a week now. I completely removed backup/restore as my attempt to get it to work properly didn't work, so I'm guessing something else is wrong with it than what I initially found and reported to Koush. I will try to keep this updated as updates come out for CWM as well. Flash with Odin/Heimdall

    Button Mapping
    Vol Up/Down - Navigate through the menus
    Power - Select Item
    Menu/Home/Back/Search - Go Back to the previous menu

    Flashing Tips
    Use the rear USB Ports on your computer if possible, and without a USB extension cable.
    When in Download mode with the battery out, put the battery back in and uncheck Auto-Reboot in Odin. When done flashing, remove the battery and USB cable, put the battery back in and reboot - credit to jami2976

    Known Issues
    Backup/Restore is still broken. DO NOT BACKUP OR RESTORE WITH CWM! CONSIDER THIS YOUR WARNING - Should no longer be an option you can see.
    Voodoo Lagfix status is not properly read from Recovery, use "adb mount" to verify your lagfix status.
    CWM Getting over-written by stock recovery - Flash a custom kernel or delete /system/etc/install-recovery.sh
    Failed to mount /sdcard error(s) - Perform the following commands with ADB:
    Code:
    adb shell
    umount /sdcard
    rm -f /sdcard
    mkdir /sdcard
    exit
    Type each line in and press enter. Do not skip a line, or you may loose data It seems to have worked for anyone that tested and had this issue.

    Download
    06-11-2011 01:32 AM
  2. imnuts's Avatar
    Reserved, just in case
    06-11-2011 01:33 AM
  3. Bravozero's Avatar
    I used this after updating to OTA EE4, this is a must have. Thank you very much, imnuts!
    06-11-2011 02:10 AM
  4. Halo's Avatar
    So I can flash this using ODIN after I do the OTA EE4 update (which in turn causes me to lose root)? Then use CWM to flash, say EE4 GummyCharged?
    06-11-2011 01:09 PM
  5. superstar1213's Avatar
    I tried flashing this file via Odin, and it soft bricked me. I had to reflash stock ED1 to get back to function.
    06-11-2011 01:27 PM
  6. muzhik's Avatar
    voodoo menu doesn't seem to work, always says: disabled (even if i try to enable it) running AB 4.1.1
    06-11-2011 02:40 PM
  7. Ghetto_Cowgirl's Avatar
    Mine does too but I'm getting 1500 in benchmarks so I assume even though it says it's disabled, it's not.
    06-11-2011 03:08 PM
  8. Raptor007's Avatar
    voodoo menu doesn't seem to work, always says: disabled (even if i try to enable it) running AB 4.1.1
    Currently the EE4 update does not work with AB4.1.1 so if you do the OTA or manual update you will have to wait for DroidXcon. Now once you have the EE4 update you can revert back to ED1 and upgrade through and get AB4.1.1 back you just won't have any of the software updates, just the radio update.

    For me I have take the OTA EE4 and I know kejar31 is looking into the email/exchange issues that GummyCHARGED has so you can go stock for a few days or try out imnuts EE4 Debloated V4.2.1.
    06-11-2011 04:04 PM
  9. Bravozero's Avatar
    I can confirm that Voodoo is working with EE4, it's much faster and by opening Terminal Emulator and typing "mount" without the quotes, it tells me the file system is EXT4.
    06-11-2011 05:44 PM
  10. KassaNovaKaine's Avatar
    Can anyone tell me why I'm booting into "android system recovery <3e>" "Samsung Recovery Utils for BML" ???

    The flashing of CWM went fine, and on first boot everything checked out. Now when I try to reboot back into CWM (home, vol up, power) I get to this screen. What's going on?
    06-11-2011 08:25 PM
  11. elucid's Avatar
    Reflash cwm in odin. I had to flash twice before it worked.

    Sent from my SCH-I510 using Tapatalk
    06-11-2011 09:17 PM
  12. muzhik's Avatar
    I can confirm that Voodoo is working with EE4, it's much faster and by opening Terminal Emulator and typing "mount" without the quotes, it tells me the file system is EXT4.
    phew, I get the same.. but I'm not on ee4, just ab 4.1.1

    Posted from AB 4.1.1 using Tapatalk
    06-12-2011 08:50 AM
  13. mcnasty150's Avatar
    One quick question the color is yellow now? or should it be red
    06-13-2011 09:00 AM
  14. Aixelsyd's Avatar
    One quick question the color is yellow now? or should it be red
    Yellow is correct now.
    06-13-2011 09:10 AM
  15. tarheelmike's Avatar
    Whenever I try to flash CWM w/ ODIN I get a softbrick. I did EE4 OTA update and have tried to flash this several times with the same result. Any suggestions would be appreciated. Yes I have used different USB etc... really trying to get rooted again and would appreciate the help.
    06-13-2011 09:36 AM
  16. whitepearl86's Avatar
    Whenever I try to flash CWM w/ ODIN I get a softbrick. I did EE4 OTA update and have tried to flash this several times with the same result. Any suggestions would be appreciated. Yes I have used different USB etc... really trying to get rooted again and would appreciate the help.
    i just soft bricked my phone too. No matter what i do odin wont flash me into cwm. I used odin to flash back to stock to unbrick then tried flashing cwm again. I keep getting fail message.

    Edit: I just factory reset phone thru recovery, then i tried flashing cwm thru odin. It failed about 4 times, i kept pulling out battery, reconnecting into dl mode and kept trying to flash. It finally went thru and i had successfully installed and rebooted into CWM recovery. Installed PBJ kernel and about to download and flash gummy charged
    06-13-2011 11:43 AM
  17. chadness's Avatar
    Whenever I try to flash CWM w/ ODIN I get a softbrick. I did EE4 OTA update and have tried to flash this several times with the same result. Any suggestions would be appreciated. Yes I have used different USB etc... really trying to get rooted again and would appreciate the help.
    Try try again. My phone would shut down halfway through, so I tried installing the battery before I started the flash, and that worked!
    06-13-2011 04:17 PM
  18. chadness's Avatar
    Can anyone tell me why I'm booting into "android system recovery <3e>" "Samsung Recovery Utils for BML" ???

    The flashing of CWM went fine, and on first boot everything checked out. Now when I try to reboot back into CWM (home, vol up, power) I get to this screen. What's going on?
    If you boot with the stock kernel, it reloads the stock recovery.
    06-13-2011 04:18 PM
LINK TO POST COPIED TO CLIPBOARD