1. Cyber Warrior's Avatar

    Yes, the Holy Grail has been discovered by djrbliss.

    He has taken the time (once again) to come up with a working root method for the newest Motorola smartphones: DROID RAZR M, DROID RAZR HD, DROID RAZR MAXX HD, and the Atrix HD. We've heard that not only does this root method work with the shipping Ice Cream Sandwich that is on the phones, but also the Jelly Bean leak for the DROID RAZR M, which means it should work on the final Jelly Bean over-the-air update for these phones.

    The method of rooting is pretty simple:

    • First make sure you have the current Motorola USB drivers installed from here.

    • Connect your phone to the PC and click on the "run.bat" file that you extracted.

    • It is important to follow the instructions in the PC program, as it will ask you to press a button combination of the Volume UP and Power at the same time.

    • If the program gives an error saying something like "run-as: Package 'com.motorola.bug2go' is unknown", then unfortunately you will have to wipe your data and cache partitions on the phone and try again (factory reset the phone).

    source: XDA Forums credit: djrbliss

    *Note: If for some reason that method fails to give you root once you boot back up and open a root-friendly app, try swapping out the su and Superuser.apk files with these two and then running it again.

    10-25-2012 09:02 AM
  2. jline123's Avatar
    Program is stuck on *daemon started successfully* Any ideas?
    10-28-2012 01:11 PM
  3. mike9670's Avatar
    What about bootloader and flashing a recovery?
    11-07-2012 02:03 PM
  4. bwat1009's Avatar
    Do you have usb debugging enabled? If not enable it and retry.
    12-03-2012 04:46 PM
  5. nickriviera12's Avatar
    Does anyone know if mattlgroff's creations will work on the Razr M? Looks like he made a very nice utility for the RAZR Maxx/HD.
    12-19-2012 10:06 AM
  6. rigdon420's Avatar
    Is this device UN rootable?

    Sent from my XT907 using Android Central Forums
    12-25-2012 01:45 AM
  7. Expodite's Avatar
    It keeps on saying
    'abd' is not recognized as an internal or external command, operable program or batch file.
    What can I do?
    12-27-2012 10:28 PM
  8. rigdon420's Avatar
    This method worked for me on jb, but with superSU instead of superuser
    01-08-2013 01:03 AM
  9. uscsailor's Avatar
    Just checking but does this process wipe you data?

    Sent from my iPad using Tapatalk HD
    01-25-2013 08:05 PM
  10. mams66's Avatar
    I got it to work after I switched out the su and superuser files that are provided.
    02-17-2013 11:34 PM
  11. uscsailor's Avatar
    Did you have to wipe before you tried again?

    Sent from my XT907 using Tapatalk 2
    02-20-2013 09:02 PM
  12. Tyler Johnson2's Avatar
    okay so i've tried this method too many times to count but yet my phone just wont root. i have tried to wipe my phone use a different computer to run the "Run.bat" file. i have checked for new drives for it everything that i have seen on the forums i've tried or so i think. if anyone could give so something else im all for it. also i have a driod razr m on the newest android version.

    nevermind i was using the ics when i had jb i got it thanks
    02-24-2013 02:46 PM
  13. mud.pony's Avatar
    Worked seamlessly after I swapped the su & Superuser files at the bottom of original post. Thanks so much!!
    03-30-2013 09:56 PM
  14. Ohhjamesk's Avatar
    Worked after I switched the SU and Superuser files at the end of post.

    also, how do i confirm that i have Superuser capabilities?
    04-05-2013 05:11 AM
  15. mud.pony's Avatar
    Any help with rooting after 4.1.2 update?? This method wont work for me anymore
    kirksucks likes this.
    04-23-2013 09:40 PM
  16. kaiser10123's Avatar
    hope to root my razr m when i get
    08-17-2013 12:43 AM
  17. Shawn Caldwell2's Avatar
    Alright I give up. How in the world do you do this step?

    *Note: If for some reason that method fails to give you root once you boot back up and open a root-friendly app, try swapping out the su and Superuser.apk files with these two and then running it again.

    •Download: su
    •Download: Superuser.apk
    09-28-2013 07:39 PM
  18. jstobaugh's Avatar
    Has anyone found an app that roots the phone? My computer is....well...less than trustworthy.
    12-01-2013 09:09 PM
  19. tevans90's Avatar
    Go into your terminal emulator and if you are super user then you should have a # instead of a $. Also try one of these commands;
    Su -i
    Sudo -i

    If they work then you have superuser
    12-05-2013 05:55 PM
  20. ckn71's Avatar
    Ok, I'm somewhat confused. Well, not really but here it is:

    I am LOCKED and NOT rooted. Android 4.1.2 / System 98.18.94.XT907.Verizon.en.US

    Recently I tried to root the phone with the intention of flashing CM on it, but I got nowhere using motofail, motochopper and RazrM utility and everything I could get my hands on. After some research on the web I found out that my system version can't be rooted, BL unlocked or downgraded. And then I found another post that stated that I can downgrade using RSDLite. My Questions are:

    1) Can 98.18.94 get rooted? (I guess the answer to that will be no)
    2) Can 98.18.94 get downgraded? (I guess the answer is no as well)

    I'm just trying to find a final answer so I can focus on other stuff again.

    On a side note. Not sure if this is the right place to ask, but what is the legal justification for Motorola/Verizon to prevent users from puting any damn android version on the phone they want? After all it is my phone right?
    01-03-2014 01:21 PM
  21. gshockxcc's Avatar
    Hi, new to the forum, and trying to root, but it won't generate the bug report when holding the Volume Up and Power. Tried several times. I have verified the version, 4.1.2., XT907, and USB debugging is on. Also, tried replacing su and Superuser files.


    Udate: Found this You Tube video that worked. Could be the key is to also "allow mock locations" and "unknown sources." I had to search for it, but "unknown sources" is located in Settings >> Security

    Hope this helps anyone else who might need it.
    03-16-2014 10:35 PM

Similar Threads

  1. [Sticky?] Newb guide -- How to root, recovery, and ROMs [Windows]
    By t0ast3d in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 03-10-2014, 02:33 PM
  2. [Guide] Root and/or Load JB on RAZR HD & HD MAXX
    By Cyber Warrior in forum Droid RAZR HD
    Replies: 7
    Last Post: 02-22-2014, 07:13 PM
  3. Super Easy Root Method for Tab 10.1 (Noob Friendly Guide)
    By hfx_nick in forum Samsung Galaxy Tab 10-inch
    Replies: 1
    Last Post: 11-14-2013, 06:17 AM
  4. [How-To] Rooting and Romming Guide for Dummies! (z4root method)
    By kentusmc in forum Motorola X Rooting, ROMs, and Hacks
    Replies: 5
    Last Post: 03-08-2011, 09:26 PM
  5. Simple Fast Root Method With Rooted 1.47.651.1 Stock ROM with NO ADBs...Check Here!
    By Tattrpuff in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 85
    Last Post: 07-28-2010, 12:39 PM