1. Mike Derbyshire's Avatar
    I have a 32gb class 4 ScanDisk MicroSD card for my Droid RAZR M (Jellybean 4.1.1). Everything was fine until sometime yesterday (I think). I noticed this morning that my morning wake-up alarm was not what I had set it to, but was a generic sound. I checked the settings and all my "custom" ringtones were missing. I then went to the files app & saw that the SD card read "0.00 GB available." Clicked on it and it says "SD card not found. Please check that SD card is properly inserted and mounted." Funny, seeing as I haven't removed the card since I got the phone & it was working just fine up to this point. I've tried using a card reader to plug into my desktop & the computer doesn't even recognize that there is a card in the reader. Id hate to do it but it looks like I might need to reformat the card thereby losing all of my pictures & music. The problem is that neither my phone nor my computer see the card. CAN ANYONE HELP??
    01-22-2013 10:56 AM
  2. usman's Avatar
    this happened to me also.. i learned that you have to format it with the phone itself not in the computer for it to stay. i have a 64gb of the same variant as yours. hope that helps.
    02-07-2013 09:38 AM
  3. Forrest Rogers's Avatar
    How do you format the sd card in the phone. My phone see it but can't use it
    02-07-2013 10:45 AM
  4. LTdesign's Avatar
    Mine has done this intermittently to TWO cards, eventually corrupting both of them.
    Actually, two phones....they sent me a replacement last week because of this very problem. The new one did the same problem.
    I've read a lot about this problem actually, with other devices, and with no definite solution.
    I'm about to start on my third card, with a fresh hard reset on the new phone, a full format of the card on the PC, and then a format by the phone itself on the card. At that point the card will never leave the phone itself. Maybe I can narrow this problem down somewhat. Maybe it's an app causing it or something....
    03-15-2013 04:06 AM
  5. Pete7874's Avatar
    I was using a Team 32GB Class 10 card in my Razr M. It worked fine for a few months. Then all of a sudden I was getting random dismounts, but it would start working again after I took the card out of the phone and inserted it back again... sometimes it took a few tries. Today, I couldn't get it to mount at all. The phone can't see it. I plugged it into my PC and it worked there, at least long enough so that I could copy the card's contents. After some time, even the PC stopped recognizing the card. Initially I thought my phone killed it, but after reading some reviews on this card, it seems it's prone to failure within a few months, so maybe it's just a crappy card. I am now using a Samsung 32GB Class 10 card. The actual transfer speeds are slightly lower on this Samsung as compared to Team, but let's hope it lasts.
    04-06-2013 01:40 PM
  6. Shelicksgirls's Avatar
    I have SD Card = 3.69gb
    in total
    avaliable memory = 3.15gb

    Dear Telecoms Provider

    By not selecting the dismounting 'card option' within 'settings'. Am I causing damage when physically removing the card with my hands?

    My 'apps' require me to properly mount the one and only (micro) SD Card. Even thou I know I have sufficient storage memory. The 'Merriam-Webster Dictionary' is only asking for 100mb.
    05-15-2013 03:12 PM
  7. calbrs04's Avatar
    I had this problem about a month ago. What happened with mine is that my phone got wet and water got into the sd card slot. My phone could still read other cards but the one that I originally had in there was corrupt to the point that not even my computer could read it. I did a warranty claim thru sandisk and all is good now.
    05-16-2013 02:25 PM
  8. jerry d1's Avatar
    I have the same problem and it occurred about the same time as your post; just last week in fact. The card has been working just fine since I inserted it into the phone when new. It's a 2GB card that I had from another device. I never took it out of the phone since putting it in there. Now the phone cannot format or mount it. It states: SD card is blank or has unsupported filesystem.

    This is an android problem because it seems too coincidental that everyone is having this problem with various SD cards. I will be speaking with Verizon to see if they can fix it; if not, I'm going to insist on an Windows phone. I like Android but if they keep corrupting SD cards then it's useless to me.
    01-27-2014 12:11 PM
  9. mrip's Avatar
    I had this problem about a month ago after I had to do a hard reset after an update from google play music. What I did was uninstall updates in the play music app bringing it back to the factory version then do a cache wipe. If you choose to reinstall the update it works as I did but I deleted it as I prefer the factory version better. Check all downloaded apps as some info is stored on the card. Settings-apps- dowloaded or all
    01-28-2014 01:38 AM
  10. Moltres_rider's Avatar
    Any solution??? SAME problem and I have valuable data on it!!! Restarting phone/ removing SD card did NOT help!!!

    Posted via Android Central App
    08-24-2014 11:19 AM
  11. A895's Avatar
    Any solution??? SAME problem and I have valuable data on it!!! Restarting phone/ removing SD card did NOT help!!!

    Posted via Android Central App
    Put micro SD card in another device to check to see if it still working, if it is, then I would hard reset your RAZR M device.
    08-25-2014 01:51 PM

Similar Threads

  1. Replies: 5
    Last Post: 05-22-2014, 03:13 PM
  2. Gingerbread update damaged my microSD card
    By ThatMatthew in forum HTC EVO 4G
    Replies: 12
    Last Post: 12-08-2012, 07:47 PM
  3. MicroSD card not working, need help!
    By diehardfan in forum General Help and How To
    Replies: 11
    Last Post: 07-23-2011, 06:47 PM
  4. How do i get my sd card to work
    By krod31 in forum HTC EVO 4G
    Replies: 4
    Last Post: 04-24-2011, 09:43 AM
  5. Help!!! my home button quit working
    By kristi in forum HTC EVO Shift 4G
    Replies: 1
    Last Post: 04-16-2011, 11:39 PM