07-10-2017 08:22 AM
35 12
  1. piratesofthejellybean's Avatar
    Hello everyone, pretty new to the forums and was wondering why I'm not able to install the Motorola Device Manager. When ever it says the installation is done, I try to see my device and it just takes me a new window telling me to download it. I try to download it again and it gives me option to fix the program or to uninstall it. I have tried both and tried to re download it many times, but it never seems to work. I am running 4.1.1 on the M and have never have been able to install it correctly (I didn't try to install it while on ICS). So has anyone on this forum had this problem or would know how to fix it? Help is greatly appreciated.
    03-24-2013 02:13 PM
  2. MotorolaGuy1's Avatar
    Hi there! I work for Motorola and I'd like to help you out.

    Are you using a Mac or Windows PC? Can you also explain what you clicked on when you did this: "I try to see my device and it just takes me a new window telling me to download it."
    03-25-2013 10:36 AM
  3. piratesofthejellybean's Avatar
    Thank you for responding MotorolaGuy1. I am using a Windows PC running Windows 7 Home Premium. The "I try to see my device and it just takes me a new window telling me to download it." part is sort of hard to explain. Mind if I post a picture or 2 showing what I mean when I say that?
    03-25-2013 10:47 AM
  4. MotorolaGuy1's Avatar
    A picture would be great.

    And as an FYI, there isn't a visibile entry under Programs for Motorola Device Manager. The bundle contains Motorola device drivers and an application that updates your phone software. This application will appear periodically when you connect your DROID RAZR M to your computer with the USB cable so it can check for software updates. You can also manually check for device software updates by clicking the icon in the lower right taskbar when you are connected.

    It sounds like you are managing to launch an update for Motorola Device Manager application itself. A picture would definitely help confirm what you are seeing.
    03-25-2013 11:17 AM
  5. piratesofthejellybean's Avatar
    Well, when I plug my phone back in, I get the option to install the device manager even though it says I have already installed it.
    03-25-2013 12:26 PM
  6. MotorolaGuy1's Avatar
    Unfortunately the screen shot did not attach to your message. Is there a different way you can try to attach it?

    Also, another thing to try, download and install the latest version from the Motorola website:
    03-25-2013 04:17 PM
  7. piratesofthejellybean's Avatar
    Ya I have tried to install the latest version from the Motorola website, but I haven't tried to install the latest version after uninstalling the existing program. So I will try that right now. I also have a link to the picture that couldn't be posted below.

    03-25-2013 05:17 PM
  8. MotorolaGuy1's Avatar
    Thanks for the screen shot! I see what's happening now.

    If Motorola Device Manager is not already installed to your computer, this screen will appear prompting you to install it from the device. If you have an internet connection, the latest version will be retrieved and installed to your computer. If you don't have an internet connection, the version of Motorola Device Manager pre-loaded to your device will install instead (which may not be the latest version).
    Note: Confirm your internet connection works by browsing using Internet Explorer, not just Firefox (if you are using that browser).

    Once Motorola Device Manager is installed, this prompt will no longer appear when you connect to the USB. Installing it from the Motorola website will achieve the same result.

    I hope that helps!
    DuckStupid likes this.
    03-25-2013 05:45 PM
  9. piratesofthejellybean's Avatar
    OK, now I've tried uninstalling and re installing the latest driver from the Motorola website and it is giving me a similar result. When I go to computer and try to access my device, it gives me this:


    Once I click on it, it takes me to the same screen I have been going through all this time. The screen it takes me to is seen below:

    03-25-2013 05:50 PM
  10. MotorolaGuy1's Avatar
    Ok, I'd just like to confirm, Motorola Device Manager is indeed already installed when you see this second screen? http://i.imgur.com/G65wEqD.jpg

    Do you see the entry "Motorola Device Manager" under Control Panel > Programs and Features?

    So essentially what you are saying is that it is trying to install over and over again?
    03-25-2013 06:01 PM
  11. piratesofthejellybean's Avatar
    Yes, I do see "Motorola Device Manager" under Programs and Features, but this window: http://i.imgur.com/wStlBOQ.png still pops up when I plug in my device. When I say "installing over and over again", I mean that it won't install and it still won't work no matter how many times I try to install it. The cycle goes like this:

    1. I plug in my device and this screen pops up: http://i.imgur.com/wStlBOQ.png

    2. I click on the "Install Motorola Device Manager" option. When I do that, this window pops up: http://i.imgur.com/G65wEqD.jpg

    3. I click on "Install Now" when the installation package is done downloading. It brings me to this screen: http://i.imgur.com/Avefa6t.png

    4. Since the program is installed, but won't work, I click "Repair". Once I have clicked on that, it goes through some processing screens and then this window pops up: http://i.imgur.com/USGqvwb.png

    5. Then I click "Finish" and when I unplug and re plug my phone into the computer, this screen pops: http://i.imgur.com/wStlBOQ.png and I am back to square one.
    03-25-2013 07:19 PM
  12. MotorolaGuy1's Avatar
    Thanks so much for your patience piratesofthejellybean! We looked into this and we believe we have a solution for what you are seeing.

    As I briefly explained above, the first prompt you see, http://i.imgur.com/wStlBOQ.png will only appear if Motorola Device Manager is not already installed onto your computer - more specifically, if the Motorola Device Drivers are not already installed to your computer - which is a sub-component of Motorola Device Manager.

    We believe while some of the Motorola Device Manager components are installing, the Motorola Drivers are not able to, which results in this loop you are seeing when you connect your M to the USB cable. We have seen the Motorola Device Drivers fail to install before, and usually this is tied to registry corruption.

    We'd like you to try out these steps to fix the problem:
    1) Download and Run the Microsoft Fix It tool Fix problems with programs that can't be installed or uninstalled
    2) You can choose to automatically fix problems, or select "Detect Problems and Let Me Select the Fixes to Apply"
    3) If you choose the latter, then choose "Installing" from the next prompt
    4) Find in the list "Motorola Mobile Drivers Installation x.x.x"
    5) Choose "Try Uninstall" and let the wizard finish.
    6) Now, install Motorola Device Manager again from the Motorola website. No need to connect your RAZR M during this step.
    7) If the installation succeeds, then connect your RAZR M and confirm that you no longer see the prompt http://i.imgur.com/wStlBOQ.png

    If that doesn't work, repeat Step #2-4, and at step 5 instead choose "No, try other fixes". Then repeat step 6 and 7 again. And finally, if that doesn't work, let the wizard run automatically to find any issues on its own and fix them (choose "Detect problems and apply fixes for me" at Step #2).

    We aren't exactly experts on the Microsoft Fix It tool, so we welcome you to play around with the various repair options to see if it fixes the installation of the Motorola Drivers.

    Please let us know how that works out for you!
    MLHL likes this.
    03-26-2013 10:59 PM
  13. piratesofthejellybean's Avatar
    Very, very interesting. So I went to install the Microsoft Fix It tool and when I tried to download it, it said I needed administrative power to download the program. So then I logged onto the profile with administrative power and then I tried to download the Device Manager (on the administrative profile) just to to see what would happen. Surprisingly, the installation actually worked this time. So I confirmed this by checking if the Device Manager notification was on the notification bar. It was, so then I went to go check if it would also work on the profile I was originally operating on. So I got the same notification on the notification bar which means it also works on the profile I was originally using. So the thing I am now wondering is how can I access the Device Manager now that I know it is installed?
    03-27-2013 05:32 PM
  14. MotorolaGuy1's Avatar
    Ah ha! Great troubleshooting work. Yes, you do need admin rights to install drivers on Windows. I am glad that you are now able to install Motorola Device Manager. We will look into avoiding any confusion in the future for users that have a similar setup as yourself.

    As for your new question - "how can I access Device Manager now that I know it is installed?":
    -As I mentioned above, there isn't a way to "launch" the device manager from the Start menu, if that's what you are looking for. The Device Manager gives you device drivers, which lets you "drag and drop" pictures, videos, music, other files between your RAZR M and your computer. There is no special menu to do this, just the basic Windows Explorer where you normally access files and folders.
    -Motorola Device Manager also contains an application that you can use to update your RAZR M software. This app delivers the same updates you can get wirelessly over your carrier's network or a Wi-Fi connection - it simply serves as an alternative method to update. When you connect your M to the USB cable, a check for sw updates will automatically occur. But you can check yourself from the icon in the taskbar that you've already seen. Here's specific instructions on how to do this: https://motorola-global-portal.custh...ail/a_id/87731

    I hope that helps! And thanks very much for the feedback!
    03-27-2013 09:46 PM
  15. piratesofthejellybean's Avatar
    Thank you so much MotorolaGuy1. No way I could have done this without you. Software update via USB cable seems like an interesting option for the next time there is a software update. Would you happen to know when the next time there is a software update for the Razr M???
    03-28-2013 11:55 AM
  16. MotorolaGuy1's Avatar
    You're most welcome.

    Updates for your RAZR M will get pushed automatically to your phone once they become available. If you tether your M to your computer on a regular basis, a notification will appear on your computer as well. Motorola Device Manager checks for updates once a week automatically. Unfortunately I don't have any time frames to give you right now for a future update.

    If you are ever curious about Android upgrades, you can find out if your M will get one by keeping tabs on our website:
    03-29-2013 07:34 PM
  17. Diane Allen's Avatar
    I have exactly the same problems but with a Defy mini, the drivers have been installed on the programming, but there is no icon on the tool bar, and I don't know what the driver is supposed to do because nothing is working, when I plug my phone in it downloads the photo's and video's to dropbox. But I have no means of putting music onto my telephone / SD card. Can you help me ?????
    06-29-2013 08:04 AM
  18. MLHL's Avatar
    That was harrowing. It took me 2 hours trying to sort this out until I found this post. I've never had this problem getting pictures off any of my androids before. Holy crap! Your instructions were great but it really shouldn't be that complicated.
    07-04-2013 04:38 PM
  19. Allison Restovic's Avatar
    I agree. Motorola should fix this issue so it's not as complicated.
    07-31-2013 04:51 PM
  20. robinottawa's Avatar
    If I understand correctly, it was just a matter of having admin rights on, wasn't it?

    Once installed, you just hook up your phone via USB and copy and paste away. Right? (I have to try this tonight.)
    08-06-2013 10:03 AM
  21. David Dube's Avatar
    This is absolutely the lamest management software I've ever encountered.
    09-10-2013 11:09 AM
  22. jgonnuscio's Avatar
    Hallelujah! Thank-you MotorolaGuy1 and piratesofthejellybean. My only regret is that it took me so long to find your postings. I am not very "device literate" and this was very intimidating. You made it easy!
    09-22-2013 10:02 PM
  23. Doug Barto's Avatar
    I can't find Device Manager.
    I'm using a Mac. Can you help me?
    10-09-2013 11:03 AM
  24. Mirrella's Avatar
    Endless hours were spent trying to connect my Motorola Razr to my computer. This finally worked:
    Go to Play store on the phone. Download Motorola PIM (all upper case).
    If you have an extended battery case/charger on the phone, remove the phone and insert the USB cable into the port on the top of the phone.
    Download Airdroid onto your phone and connect wirelessly
    12-04-2013 11:46 PM
  25. Alex Loia's Avatar
    Hi, I’m on a Mac on Mac OS X 10.9 Mavericks and I’m trying to install MDM but when it installs, I can’t find it anywhere. I’m trying to update my Moto G to Android 4.4.2. The Moto G arrived from Amazon just 2 days ago. It is US GSM version. when i check for an update on the phone, it says there is no update to install. Can someone help me with this? Thanks.
    12-19-2013 11:12 PM
35 12

Similar Threads

  1. Bypass Motorola Device Manager?
    By Pete7874 in forum Droid RAZR M
    Replies: 8
    Last Post: 01-08-2016, 09:57 AM
  2. Device Driver Error: MTP USB Device won't install
    By j0esmoe13 in forum AT&T Galaxy S II
    Replies: 17
    Last Post: 07-04-2015, 02:56 PM
  3. USB device driver won't install
    By dgale222 in forum AT&T Galaxy Note
    Replies: 1
    Last Post: 04-09-2012, 07:31 PM
  4. Odin won't detect phone, "unknown device" in device manager
    By cableguy1 in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 10-11-2010, 06:50 AM
  5. Replies: 3
    Last Post: 08-11-2010, 03:28 PM