1. ChrisC's Avatar
    My Razr M got the 4.1.2 update a few days ago, and seemed to work fine afterwards.

    However this weekend I discovered that GPS location wasn't working inside Google Maps app. It would pop up a message saying "please enable Google apps location access".

    Doing some Googling led me to forum discussions here and here, and so I then tried, without success, all of the following steps:
    - phone reboot
    - turned location pref off and back on (and re-agreed to the terms)
    - unchecked and rechecked all location sources
    - checked Google Maps for any settings to correct / cycle (none)
    - forced close GMaps and relaunched

    Critically, GPS location worked in other apps, including GPS Test and a service mapping app I use heavily (Recargo, check it out ...)

    So all that pointed to a Google Maps bug with the new version of Android. Version 6.14.2 of Google Maps is what came with the phone. Checking the Android app market for updates, I saw that version 6.14.3 was released on March 12th, and listed only "bug fixes" for whats new, so I suspected an app update might fix it on my phone.

    However, before I did that app update, I started typing up this post to A) document the problem and offer up a fix or B) ask for help with my continuing problem. In writing this post, I reread the two links above (on a real computer this time :/ ) and came across this important observation by one of the commenters down the page:

    That worked! I've had the problem since I received a system upgrade 3 days ago on my Motorola RAZR MAXX. I never realized that there were two separate places to enable location sharing, one under System Settings>Location Access (for non-Google apps) and the one under the Google account itself for Google apps. Crazy.
    CRAZY INDEED. Larry and Sergey, please go dope-slap whoever let that go to production.

    Found the pref, turn it on, went back to GMaps, boom, FIXED.

    Having Google Maps suddenly break for me partially screwed up my weekend ... On the positive side, checking out those Google Account prefs pages led me to disable Google AdMob ads personalization.

    Hopefully this writeup will help someone else out!
    maitaldar and neonworm like this.
    04-28-2013 04:00 PM
  2. Evelyn812's Avatar
    Thank you so much!!!! I was beginning to become very frustrated with this problem! I finally got in a situation that I needed directions to a place and it was too many and too new of an area to just memorize the directions. It is ridiculous that they have these weird settings but I'm glad somebody figured it out!
    06-04-2013 08:17 AM
  3. KathyWess2012's Avatar
    "Found the pref, turn it on, went back to GMaps, boom, FIXED." and " the one under the Google account itself for Google apps." I can't figure out what the second part means. I ended up registering for Google Central. All I wanted was Google Apps Preferences. How about a step-by-step? Thanks.
    11-11-2013 04:00 PM

Similar Threads

  1. Setting new 'Home' locations in Google Now/Maps
    By Gehan99 in forum Google / Samsung Galaxy Nexus
    Replies: 2
    Last Post: 04-16-2013, 04:10 PM
  2. My location in google maps
    By abnikki in forum Droid RAZR MAXX
    Replies: 3
    Last Post: 07-22-2012, 04:52 PM
  3. My Maps Fails to Load in Google Maps
    By baycruisers in forum Motorola Droid
    Replies: 11
    Last Post: 07-11-2010, 10:27 PM
  4. Text to Voice in Google Maps on the Moment?
    By Double Tap in forum Samsung Moment
    Replies: 4
    Last Post: 05-02-2010, 09:13 PM
  5. Alternate Routes in Google Maps
    By o2bnclemson in forum Android Apps
    Replies: 1
    Last Post: 03-28-2010, 10:44 AM
LINK TO POST COPIED TO CLIPBOARD