1. dslartoo's Avatar
    I have owned my RAZR MAXX HD since January. For the most part I'm quite happy with it (4G speeds are awesome, and it syncs my frequent emails immediately, which my old HTC Droid Incredible refused to do unless I synced it manually) but there is one quirk which keeps reappearing that is driving me UP. THE. WALL, and that is the incredibly frustrating "Searching for GPS" message that frequently comes up.

    In the past when I had this problem, I read on various sites that a useful fix for this was to go to the GPS/Location Access settings, and under Location Sources, uncheck "Verizon Location Services" and "Google Wi-Fi & mobile network location", leaving only "GPS Satellites" checked. I did that and the GPS started behaving itself again, but in the past couple of weeks it has stopped working. It's now to the point where I can't use the Navigator function at all, or use MapMyRun to record my daily runs. "Searching for GPS" appears and then it just sits there.

    I've tried the following:

    1. Clearing cache and data from the Maps application.

    2. Rebooting the phone.

    3. Re-checking the "Google Wi-Fi" and "Verizon Location Services" in GPS settings.

    4. Downloading and installing the "GPS Status and Tools" app from the Play Store.

    5. Using the aforementioned app to download A-GPS assistance data.

    6. Using the aforementioned app to reset / clear all cached GPS data.

    7. Re-downloading A-GPS assistance data again (in fact I set the app to download the data automatically on launch).

    As it stands right now the phone won't lock onto GPS satellites AT ALL. When I launch the GPS Status app, it displays "Looking for GPS location" and then just cycles, and cycles, and cycles. It won't fix onto a single of the 24 satellites that are shown in the app, even if I go outside my home and stand in the open under today's utterly cloudless sky.

    For fun, I rebooted the phone, started the GPS Status app, and went and sat in the middle of my driveway, reading a book. 15 minutes later it was still displaying "Looking for GPS location" and had not gotten a single fix.

    I am about to tear out my hair on this one. I could try a factory data reset but I'm terribly afraid that if I do it STILL won't resolve the issue and then there'll be nothing left but to smash the phone. I only see stories here about how happy people are with the speed of their GPS on this phone, so I have to wonder if I just have a bad unit or something.

    Any other suggestions you folks can pass on to me?

    Thanks in advance for any replies,
    04-12-2013 03:33 PM
  2. dslartoo's Avatar
    Nobody has any ideas? Please, I'm begging you.

    04-22-2013 02:04 PM
  3. djousma's Avatar
    Oddly, I notice similar behavior only when I have certain apps installed. here is my story. I use ENDOMONDO, which is a excercise tracking app that utilizes GPS to track, speed, location, etc of my running. I am usually out for an hour at a time. ENDOMONDO has in-ear status updates, including when GPS signal is lost, and aquired again. Shortly after getting my RMHD, and installed all the apps that I used to run on my original RAZR, i started getting many GPS problems like you mention. I too tested this with the GPS TEST app, and verified that the phone would/could not get/keep a GPS lock. Rebooting the phone would not fix the problem. I was so frustrated, that my next step was to deinstall all the added apps EXCEPT ENDOMONDO. Interestingly the problem went away, I went for weeks with no GPS problems. Then I started adding the apps back, one at a time over a period of weeks, and found that some of my added apps actually were the culprit to the problem.

    At that time, I found that the app POYNT was the one causing the problem. I immediately removed the app, and the problem has been gone now for several months. Just last week, I installed a new MP3 player called ROCKET Music Player to replace my use of Google music, and the problem re-appeared. I deinstalled ROCKET, and the problem went away. Interestingly, Rocket doesnt list access to GPS, but somehow it still was causing interference.

    I dont know what the root of the problem is, I only know that there is something going on that these two apps are doing something that causes GPS problems.

    My suggestion to you, it to either restart the phone in SAFE MODE, and use it for awhile to see if the problem goes away, and if so, is a pretty good indicator that an app you have added is the problem, or do as I did, and deinstall all of the apps, and slowly re-install them over time to see which one is causing the problem.
    04-23-2013 08:54 AM
  4. dslartoo's Avatar
    A good idea. The only real problem with that is that 99.9% of the apps installed on the phone were installed in the first two days. The issue cropped up two or three months into my usage of the phone, when I hadn't installed anything new at all. Only two apps have been installed since then and the issue was occurring before I put either of those two on there. I suppose it's a possibility that an update to one of those apps may have caused the problem.

    I may try removing a few of those, or possibly a factory data reset (someone on a different forum suggested that). I'll have to back up my photos and whatnot, but hey, small price to pay if that fixes the GPS.

    Thanks for the suggestion!

    04-23-2013 09:28 AM
  5. djousma's Avatar
    Phil, I understand what you are saying. I will say that it did take time for the problem to show up, same as you. But once it started, there was no getting rid of it. I too had done a factory reset, and it did fix the problem for a little while, but then still came back.

    If you dont want to deinstall all the apps initially, then just boot into SAFE mode, which basically disables any apps you have added, and see how that works. Use it that way for a long enough period to be convinced the problem is resolved. If the problem doesnt go away in SAFE mode, then you may have a hardware problem. If it does go away, then it is an app that you added.

    I fully understand that it is a real PITA to have to deinstall all apps, and add back one at a time. But for me, that was the only way to find out what was causing the problem. Luckily I am not a heavy app user, I only had about 20 or so to do that with. If you do a little prep, such as making a list of all your added apps, then deinstall them all, and test the phone, then keep track on that list of which ones were added and when, then when the problem reappears, you can just use that list to "back track" the problem by removing the apps one at a time from the list from last added and back.

    There is no magic tool(I've looked), to determine what the real problem is.
    04-23-2013 10:07 AM
  6. drosan1's Avatar
    finally found the fix after searching the web for over a month. The fix is so simple, its almost stupid. Guess, its MapQuest.
    Check out the solution
    Solved Searching for GPS Issue on Nexus 4 or Android Phones | AskStudent
    06-30-2013 03:01 PM
  7. Terry Wong1's Avatar
    I did a Factory Data Reset. . .still doesn't work.
    07-09-2013 12:31 AM
  8. wburghardt's Avatar
    I was having this problem too. It was a rogue app. Home Depot in this case. I've unistalled it and suddenly MapMyRun and Waze work again. Woohoo!
    06-19-2014 05:30 PM
  9. t0ked's Avatar
    A lot of times an app will be updated and that causes a problem even if it was installed months ago. My suggestion is to just do the factory reset.
    06-20-2014 04:53 PM

Similar Threads

  1. Google Maps Navigation Stuck Searching for GPS...
    By yacoub in forum T-Mobile Galaxy S 4G
    Replies: 25
    Last Post: 08-18-2016, 12:07 PM
  2. Searching for GPS
    By jherm04 in forum Motorola Xoom
    Replies: 2
    Last Post: 03-03-2011, 08:19 PM
  3. Searching For GPS....HELP!!
    By shaundiesel in forum Verizon Droid Incredible
    Replies: 8
    Last Post: 11-16-2010, 03:24 PM
  4. Searching for GPS
    By sloan31 in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 07-17-2010, 07:35 PM
  5. Replies: 9
    Last Post: 12-02-2009, 05:00 PM