1. linebusy's Avatar
    Don't know if it's a recent Maps update or if it's the KitKat update, but...
    Having frequent lock-ups while trying to use maps/navigation.

    Just registering the issue here for my fellow RMHD users.
    06-10-2014 07:16 PM
  2. Golfdriver97's Avatar
    Have you tried clearing cache on Maps?
    06-10-2014 11:30 PM
  3. linebusy's Avatar
    Have you tried clearing cache on Maps?
    No, but I did do a full reset of device after the kitkat update.
    My tablet is giving me problems with maps lately, too, which causes me to think that's where the issue lies (maps).
    06-11-2014 11:21 PM
  4. linebusy's Avatar
    Having hang-ups on my Asus tablet, too.... Seems that Maps is the culprit. An update appeared yesterday... maybe that will help.
    06-12-2014 08:12 AM
  5. kmf1's Avatar
    In phone settings, is your Location mode set to High accuracy?

    Sent from my Droid Razr Maxx HD using Tapatalk.
    06-12-2014 04:42 PM
  6. linebusy's Avatar
    06-12-2014 09:56 PM

Similar Threads

  1. Fix LG G2 Signal Issues with Root and Rom?
    By one eye bear in forum Sprint LG G2
    Replies: 18
    Last Post: 10-13-2015, 02:23 AM
  2. GPS not working on LG Optimus G (E970)?
    By FiretoFlames in forum General Help and How To
    Replies: 2
    Last Post: 08-16-2014, 10:04 AM
  3. Replies: 1
    Last Post: 06-14-2014, 03:20 AM
  4. Strange Power issues
    By Northern.dj in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-10-2014, 07:12 PM
  5. Replies: 0
    Last Post: 06-10-2014, 01:47 PM