1. Live2ride883's Avatar
    I picked up a Helo TC to use with my Maxx and after installing and removing the app, restarting my Maxx I still can't get it to work. It works fine with my N7 and I haven't tested it on my Xoom yet. I will be doing that at some point today.

    Has anyone been able to get the Helo TC to work on the Maxx?
    07-22-2012 10:07 AM
  2. Live2ride883's Avatar
    07-23-2012 08:55 PM
  3. chilei's Avatar
    I bought one and it hasn't worked. I took it back, got a new one without a problem but it still doesn't work. I then tried it on the ipad and the unit works. I know the information is not the solution you were hoping for but if nothing else you know you are not in the same boat.
    09-30-2012 06:47 PM
  4. youngti's Avatar
    You have to turn off the audio media effects. Under the device's Settings, select Sound\ scroll to the bottom and select speaker and then turn OFF Media Audio Effects.
    12-12-2012 03:24 PM
  5. Riley Lewis's Avatar
    I have gotten it to work. i had the same problem and after researching online. (suprisingly difficult to find any info, videos, how to guides and parts for the Helo TC) but turns out razr maxx seems to be the main phone to have problems with the Helo TC. but here is what i found helps get it to work. keep in mind its still a pain in the @$$ to do and i think its more luck then me actualy doing a step by step process... 1st. ur gonna need a webcam! without it, ur just gonna give up and get mad.. so hook ur razr maxx to the flight deck thing. plug the headphone jack in. (i dont think it matters if the phone is w volume keys facing up or down. ive done it both ways) ok so start the helo tc app. leave the helicopter off but close by for when u get it working... point the webcam at the remote IR lights. then when the app starts press hit the throttle so it can show you how much it dosnt work. then go to settings, and keep changing options 1 at a time. change channel, change helicopter type to the other one. keep switching things back n forth but everytime you switch something try the throttle, use the directional nob, hit all the buttons exxcept the trim.. u dont wana get it working then have to restart cus u cant get ur trim back right.. but if u keep doing this, eventually ull see the IR bulbs on the front of the flight deck either turn on solid blink.... once u see this happen, quickly go to ur setttings. LEAVE THE CHANEL! just make sure that its set to control the right style helicopter... then when you hit back, you should now be able to fly your helo tc.... much easier to deal with when u can see the IR lights through the webcam. but once its up, i think its awsome. the throttle response has a real slight delay but not more then half a sec or so.... hope this works for you.... i love my razr maxx but ima get a gay iphone just for my helo. i used my buddies iPhone and it worked so good. no hastles....
    01-01-2013 12:50 PM