1. jeffreynye's Avatar
    My keyboard now just stops working seemingly randomly. This has been happening since the afternoon of either Thursday 11/15 or Friday 11/16. It does not matter what keyboard app I'm using. I normally use Swiftkey, but this also happens with Swype and the standard keyboard.

    The keyboard pops up and the keys respond to the touches (i.e., key changes color and enlarged briefly, or whatever the relevant indicator is on whatever keyboard I'm using) but (a) no text appears in the input boxes, and (b) no word predictions pop up. Sometimes rebooting the phone fixes the problem, but sometimes it does not, and the problem has ultimately come back every time. The touchscreen otherwise works fine--it seems clear that this is purely a software issue.

    It doesn't matter what app I'm trying to type into--though I've noticed that sometimes I can bring the keyboard back to life by opening Facebook and trying to type in there. I assumed that meant that Facebook was the problem, but the Facebook app hadn't been updated for awhile when this started happening, and uninstalling Facebook didn't fix the problem.

    I downloaded the Addons Detector app for the purpose of identifying apps that were recently updated, thinking that doing so might help me identify other recent app updates that may have caused the problem. But even after rolling back or uninstalling anything that had been updated recently, the problem persists.

    The only other clue I have about this is that the keyboard issues have been coupled with severe battery drains. My battery used to drain about half way on a normal full day's use (15-18 hours or so). Since this issue started my batter drains fully before the workday is over (10 hours, max).

    11-19-2012 01:28 PM
  2. B. Diddy's Avatar
    Have you tried (1) rebooting, or (2) clearing the data from the Motorola Input, Swiftkey, and Swype apps in Manage Apps?
    bradenfontaine likes this.
    11-19-2012 01:41 PM
  3. bradenfontaine's Avatar
    any luck on what B. Diddy suggested?
    11-20-2012 03:14 PM
  4. carracerz14's Avatar
    Op posted at Android forums also, hasn't responded there yet either. I suggested that if the above doesn't work then a factory reset my be in order.

    It's strange that it does it for every keyboard you use, makes me think there may be something going on in the background that a reset would take care of.

    Try rebooting and clearing cache/data for the keyboard as B Diddy suggested first

    Sent from my RAZR MAXXIMUS
    bradenfontaine likes this.
    11-20-2012 03:46 PM
  5. jeffreynye's Avatar
    I've tried rebooting, and sometimes that works but sometimes doesn't. Clearing keyboard data did not work.

    I agree that it must be something in the background--but what?! Haven't had time to do a factory reset yet, and would obviously prefer not to. But if the problem doesn't resolve I guess I will give it a shot over the long weekend.
    11-21-2012 11:16 AM
  6. carracerz14's Avatar
    Honestly I don't know what it could be. Idk what apps you have etc. I would do the reset when you get time.

    Sent from my RAZR MAXXIMUS
    11-21-2012 11:48 AM
  7. ViolinKnits's Avatar
    I'm having the same problem. I haven't cleared the keyboard cache. Between this and rapid battery drain, I'm going for a factory reset. Eek.
    12-05-2012 08:44 PM
  8. yoloandaa's Avatar
    Go to app settings, all, then find something that says keyboard on it and clear the data, and BAM fixed
    06-08-2013 12:07 AM
  9. jeffrok's Avatar
    Are you sure it's in every app? It could be an app or web page problem. I know sometimes on my phone, typing in the Google mobile web page's search page won't work, but typing anywhere else will.

    Sent from my DROID RAZR using AC Forums mobile app
    06-08-2013 09:56 AM
  10. Phillip North's Avatar
    This has been happening to me for quite some time. I am ready to throw my phone out the window. Reboot, taking the battery out, clearing cache...nothing works. This is a droid issue over every phone with an older OS. It happens while on Ebay, browser, text messaging... I think it's just time for a new phone.
    09-15-2013 01:56 PM
  11. michelle dafforn's Avatar
    This happens to me on mine as well. As the OP said it happens in any app that requires typing. the touch screen works fine, and the keyboard looks as if its going to respond but no text appears in the text box. sometimes i can get it back by switching between different apps like browser facebook, whatsapp and messages and attempting type in all of them. eventually it comes back and works again. turning it on and off works most of the time but it's a oain and i shouldnt have to do it to send a mesage! i switched keyboards from the basic one to swiftkey and the problem persists. i checked the chache and there isn't any data in it for swiftkey so it isn't that.

    did the factory reset fix it? i dont want to have to do one but will if it works because this issue is a total pain!
    04-24-2014 07:44 AM
  12. xxjoStaxx's Avatar
    My R key won't work. It types e or et. Only way I can type r is if it's a suggestion. Cleared data and cache for Gboard, even disabled and enabled it. Any ideas other than a factory reset? It was working fine then suddenly stopped. Tried Swiftkey and resizing keyboard but problem persists. Plz help!!!!
    03-20-2017 07:48 PM

Similar Threads

  1. Hebrew Keyboard not working... Help please
    By abe2np in forum Sprint Galaxy Note 2
    Replies: 10
    Last Post: 10-23-2015, 09:26 AM
  2. SwiftKey Not work, help please!
    By Punkidish in forum HTC EVO 4G
    Replies: 3
    Last Post: 07-14-2010, 10:02 PM
  3. Press and Hold Feature on Keyboard not working
    By slwatts in forum HTC EVO 4G
    Replies: 17
    Last Post: 07-09-2010, 06:11 AM
  4. Landscape keyboard not working with Seidio Innocase.
    By mjesenovec in forum Motorola Droid
    Replies: 8
    Last Post: 02-07-2010, 02:33 AM
  5. Internet Not Working - Help Please?
    By thezob101 in forum General Help and How To
    Replies: 2
    Last Post: 10-30-2009, 09:03 PM