1. Jack33's Avatar
    I purchased a Sandisk 64GB micro SD card few months ago from Amazon and it worked fine. I formatted the card using the phone and was able to transfer all my work files and some music and video while still having plenty memory left over for other things. However, recently I've experienced a problem whereby when I plug the phone to the computer the computer will not read the 64gb SD card (sometimes it will read it, sometimes it won't). And other times it asks me if I want to reformat it (and lose all data). I don't think this is an SD card issue because if I take it out of the phone and put it in a SD card adapter the computer is able to read the 64gb card.

    Has anyone experienced this problem? Any suggestions? Thanks.
    11-05-2013 09:59 AM
  2. Haalcyon's Avatar
    It sounds like you're only having the problem when the card is in the phone. You may want to try:

    * Reinstalling the phone's drivers
    * toggling between MTP and PTP
    * Using a different USB cable

    ...and see if any of that helps.
    Jack33 likes this.
    11-05-2013 10:59 AM
  3. jeffrok's Avatar
    Aren't 64GB Micro-SD cards fairly new technology? Is it possible the firmware doesn't fully support them?
    Jack33 likes this.
    11-05-2013 02:24 PM
  4. Haalcyon's Avatar
    Aren't 64GB Micro-SD cards fairly new technology? Is it possible the firmware doesn't fully support them?
    They've been around for at least a year so they're not that new in my book. Most of the issues I've read of involve $amsung devices and specifically the S4 (though my old Note 8.0 ate a Sandisk Ultra too).

    Note 8.0
    11-05-2013 02:49 PM
  5. Jack33's Avatar
    Thanks for the reply. I've tried different cable, no difference. How do you reinstall phone's drivers and where is the MTP/PTP toggle? Thanks again.
    11-05-2013 04:13 PM
  6. B. Diddy's Avatar
    I'm not sure changing to MTP or PTP would help, because I think those protocols ignore the external SD. Since you have a RAZR Maxx, I assume you're using the USB Mass Storage setting, which is the best one to use for access to the external SD and internal storage.

    You might want to back up all of your SD data, then reformat the card and see if the problem persists.

    Posted via Android Central App
    Jack33 likes this.
    11-06-2013 07:45 AM
  7. scotts9219's Avatar
    I have the same SD card. Have not run into the problem you have had (just confirmed it). I would do as suggested and back up the card and reformat it. At the least, run check disk on it. I had a problem with mine for a while but it turned out to be a problem with dust in the socket. Blew it out and all the problems went away.
    Jack33 likes this.
    11-07-2013 02:11 PM
  8. Haalcyon's Avatar
    Yeahp, dust'll do it.


    Sent from that other phone
    Jack33 likes this.
    11-07-2013 02:49 PM
  9. Jack33's Avatar
    Thanks guys. You know what, I forget that despite the gHz internals and circuitry and what have not in these smartphones, sometime it's a simple thing like dust that can be the cause of the problem. My problem comes and goes, but the next I have trouble reading the card, I'll be sure to blow on the adapter ends to clear away the dust. Thanks again.
    11-08-2013 01:16 PM
  10. Jack33's Avatar
    I've given up on 64gb SD card.

    I've reformatted it, both on computer and on phone, I've rebooted it, factory reset it, multiple clear-cache it, air-blew the connector, and I still have problems having computer read the 64gb SD card. I save all my work files into the SD card so that I can take the phone home and plug it into my home computer to continue work - I don't like lugging laptops and don't like cloud storage (too paranoid and too expensive).

    But it appears that 64gb memory cards have their own problems syncing with the computer. Something Jerry Hildenbrand wrote about why Google was moving towards non-removable block memory (that having the phone constantly prepare the SD card for readability or something). Anyhow, I'm using the "mere" 32gb SD card and so far so good. I don't believe I've ever had SD card reading problem with 32 SD card.
    11-19-2013 03:20 PM
  11. ryanidcomm's Avatar
    format the SD card with the phone...

    also try and format the SD card in FAT32 ... NOT EXFAT32

    WIndows 7 cannot do this.. you will need to download a disk manager or use XP or MAC OS

    Also cheaper SD cards fail ... ALOT!! ha
    12-01-2013 11:03 PM

Similar Threads

  1. Kit Kat 4.4 being Tested on the Galaxy Note 3!
    By Preach2k in forum Verizon Samsung Galaxy Note 3
    Replies: 12
    Last Post: 11-11-2013, 11:55 AM
  2. Sony xperia L - all my songs on my playlists was suddenly gone
    By chel06 in forum Other Sony Android Phones
    Replies: 1
    Last Post: 11-11-2013, 03:48 AM
  3. Replies: 5
    Last Post: 11-05-2013, 02:26 PM
  4. 64gb Micro SD Card Won't Read on Maxx
    By Jack33 in forum Motorola Droid MAXX
    Replies: 2
    Last Post: 11-05-2013, 10:23 AM
  5. Tap on Notification and goes back to Clock
    By Floridadomer in forum Samsung Galaxy Gear
    Replies: 0
    Last Post: 11-05-2013, 08:08 AM
LINK TO POST COPIED TO CLIPBOARD