1. mr_nerd's Avatar
    Hi All,

    I am a rookie and need some help. I have a motorola razr maxx (asia retail). Recently (after a year) my phone got hung up, so i rebooted it and since then its stuck at the motorola logo. I believe the ROM is corrupt. Could i get some advice as to how to flash the ROM and install and new one. I was on 4.0.4 ICS.

    Please advise.
    01-12-2014 08:22 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Was it rooted to begin with? Have you tried to boot into recovery and then wipe the cache partition using these steps? https://motorola-global-portal.custh...17/action/auth
    01-13-2014 11:07 PM

Similar Threads

  1. Droid RAZR MAXX - Newest Verizon update 1/10/14
    By clownin72 in forum Droid RAZR MAXX
    Replies: 21
    Last Post: 01-27-2014, 09:17 PM
  2. Still no 4.3 in Asia? Particularly Phils?
    By popengchan in forum Samsung Galaxy SIII I9300
    Replies: 1
    Last Post: 01-18-2014, 04:16 PM
  3. Using my MAXX in France
    By YAYTech in forum Motorola Droid MAXX
    Replies: 5
    Last Post: 01-13-2014, 08:05 AM
  4. Replies: 1
    Last Post: 01-10-2014, 05:29 PM
  5. Droid MAXX - Active Notification not working for certain apps???
    By Huntrowmar in forum Motorola Droid MAXX
    Replies: 2
    Last Post: 01-10-2014, 04:24 PM