1. Abby Oliver's Avatar
    Yesterday, my Droid Razr Maxx fell in the toilet. I was able to fish it out and dry everything off. It appeared to be fine besides the fact that it has no signal/service to call or text. I put it in rice and it is still not working. Suggestions as to what might be wrong?
    02-25-2014 10:20 AM
  2. VDub2174's Avatar
    Welcome to AC!!

    If it was turned on before it was put into rice for 24-48 hours then something might have fried which is cause the signal error
    02-25-2014 10:23 AM
  3. Abby Oliver's Avatar
    Unfortunately I wasn't able to put in rice until I got home a few hours later. I tired restarting to see if it solved the issue.
    02-25-2014 10:43 AM
  4. VDub2174's Avatar
    There have been some cases here where even after was turned on before putting it in rice it ended up working again. You could always keep it in rice for a day of two and see what happens. Hopefully it'll work out for you
    02-25-2014 11:25 AM

Similar Threads

  1. ZTE Grand Memo II LTE: Android 4.4 and more!
    By Paul627g in forum ZTE Grand Memo II LTE
    Replies: 2
    Last Post: 03-27-2014, 12:05 PM
  2. Constant annoyance with uploading and finding music on my Galaxy S3
    By iainhasaface in forum Samsung Galaxy S3
    Replies: 8
    Last Post: 02-28-2014, 05:21 PM
  3. can any of you confirm Wallet Tap and Pay working with 4.4.2 KitKat?
    By Tyler Durden in forum Sprint Samsung Galaxy Note 3
    Replies: 5
    Last Post: 02-26-2014, 11:51 AM
  4. Options and Back key arent working.
    By John8Thomas in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 02-26-2014, 01:32 AM
  5. Lenovo S850 : Slim design and a great shooter !
    By Paul627g in forum Lenovo S850
    Replies: 1
    Last Post: 02-25-2014, 02:35 PM
LINK TO POST COPIED TO CLIPBOARD