1. sgx23's Avatar

    After purchasing the RAZR XT910(or DROID RAZR in other countries), I upgraded to ICS.
    Then I tried to redeem the 9 free EA games in the Moto Lounge. After downloading NFS Shift( or Need for Speed Shift HD XT910), it prompted to download
    another 150 mb.

    So I started the download and left
    it the whole night on my wifi. The progress bar got stuck at 100 percent and didn't go further. I've tried it more than 5 times and still, after reaching 100 percent, it gets stuck there. So I'm unable to play that game. I have not tried with other games, as many require large amounts of data downloads and I'm stuck with the first one I tried.

    Has anyone faced and/or resolved this issue?
    Please share.

    11-21-2012 12:08 AM

Similar Threads

  1. Razr Maxx Bluetooth Problems
    By LanciferR in forum New to the Forums? Introduce Yourself Here!
    Replies: 4
    Last Post: 09-13-2012, 12:12 PM
  2. EA Games Support w/ Nexus
    By MikeC_513 in forum Verizon Galaxy Nexus
    Replies: 5
    Last Post: 02-15-2012, 07:50 AM
  3. EA Games won't work
    By corneliusm in forum AT&T ATRIX
    Replies: 1
    Last Post: 02-21-2011, 05:35 PM
  4. EA Games Special!
    By Kevin_G_Sanchez in forum Android Apps
    Replies: 16
    Last Post: 12-24-2010, 03:23 PM
  5. Gameloft game problems.
    By bjones521 in forum HTC EVO 4G
    Replies: 7
    Last Post: 08-17-2010, 03:44 PM