08-15-2019 07:56 PM
46 12
tools
  1. TobyU's Avatar
    This happened to me a couple of months ago. All of a suddenwhen I would speak a text message it would star out profanity. I changed the setting and all was back to normal.
    Now just this week it is back to filtering and turning it off does nothing.
    SCREW GOOGLE!!!
    I WILL NOT HAVE THEM FILTERING MY-MY-MY- YES- MY text messages.

    I don't give a rat's asss this it is their voice to text service doing us a favor.....blah blah blah etc.
    I will find some other app to use...

    I have never owned, or wanted to own an apple prooduct. THIS WILL BE the end of me for android and all of googles other bullcrap...we're so big, we will buy everyone and make the rules. GO to hell google!
    Yeah. I'm pissed!

    Edit: cause I forgot to mention. Without the ability to speech to text profanity. I will have to type it out. Profanity has a place for me for emphasis many times.
    If I have to type it out I will end up texting while driving....it will happen. I will be distracted by having to type out a word etc simply because GOODY-TWO-SHOES google wants to make the world a better place and FORCE their will on us.

    NOT GOING TO HAPPEN!!!
    flampher likes this.
    09-07-2013 11:27 PM
  2. Carl Trusso's Avatar
    Google switched from their voice app to another app "talk...." the voice to text runs from their server rather from your phone
    09-22-2013 12:11 PM
  3. Moltres_rider's Avatar
    I have the SAME problem and NOTHING suggested has worked yet!!!! any help appreciated!!!
    10-05-2013 02:25 PM
  4. Andy Politano's Avatar
    Should be under settings > VOICE SEARCH > Block offensive words. You're welcome! Took me awhile to figure it out too.
    10-19-2013 01:10 PM
  5. Moltres_rider's Avatar
    should be under settings > voice search > block offensive words. You're welcome! Took me awhile to figure it out too.
    have you even read the thread????????????????????????????????????????????????????? That doesn't do it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Read the entire thread before suggesting something that many people tried and doesn't work!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    stircraz1972 likes this.
    10-19-2013 08:18 PM
  6. Jerry Hildenbrand's Avatar
    Looks like we need to add a filter for extra punctuation
    10-19-2013 09:57 PM
  7. Ktownbloody's Avatar
    when i first got my phone i had to disable the block. it worked fine for several months and then bam ! block back on- ive tried everything suggested and its still on. Did you have any luck yet ?
    10-23-2013 10:21 PM
  8. flampher's Avatar
    Been working normally now for a day or two... Fingers crossed
    11-02-2013 01:57 PM
  9. SAVAGE HNYBADGR's Avatar
    This happened to me a couple of months ago. All of a suddenwhen I would speak a text message it would star out profanity. I changed the setting and all was back to normal.
    Now just this week it is back to filtering and turning it off does nothing.
    SCREW GOOGLE!!!
    I WILL NOT HAVE THEM FILTERING MY-MY-MY- YES- MY text messages.

    I don't give a rat's asss this it is their voice to text service doing us a favor.....blah blah blah etc.
    I will find some other app to use...

    I have never owned, or wanted to own an apple prooduct. THIS WILL BE the end of me for android and all of googles other bullcrap...we're so big, we will buy everyone and make the rules. GO to hell google!
    Yeah. I'm pissed!

    Edit: cause I forgot to mention. Without the ability to speech to text profanity. I will have to type it out. Profanity has a place for me for emphasis many times.
    If I have to type it out I will end up texting while driving....it will happen. I will be distracted by having to type out a word etc simply because GOODY-TWO-SHOES google wants to make the world a better place and FORCE their will on us.

    NOT GOING TO HAPPEN!!!
    I fixed my galaxy S4 by going into all the settings including the settings for s voice and unchecking the hide profane language and now it curses just like me :-)
    11-29-2013 11:11 PM
  10. greyserf's Avatar
    I was having the same issue. Found that you do have to uncheck the "Block Offensive Words" in BOTH the Google Voice Typing Settings as well as the Voice Recognizer sections under Language and input. Once I also removed it from the Voice Recognizer setting, it started allowing curse words.
    02-12-2014 10:33 AM
  11. stircraz1972's Avatar
    had the same issue with a warranty replacement phone and I have done the settings disable block offensive words and they're still coming up with this f****** stuff right here
    numerous people unblock there Asterix and its just not working now anybody else have any other suggestions
    03-31-2014 07:28 PM
  12. stircraz1972's Avatar
    Thank You to whoever had the suggestion about the settings menu AND GOOGLE SEARCH there are two different boxes to uncheck for block offensive words
    03-31-2014 07:44 PM
  13. stircraz1972's Avatar
    Go to S-VOICE Google settings there's a block offensive words check box there too
    03-31-2014 07:50 PM
  14. Cay Roberts's Avatar
    I had this same problem, and turning the filter off didn't help.. HOWEVER, I added each word individually under Language & Input > Personal Dictionary..
    Worked instantly.
    Also got to add a lot of my own creative curses.

    Hope this helps!
    03-28-2015 05:05 PM
  15. 1cokezero's Avatar
    I have searched for one hour trying to find the place on this phone to uncheck the offensive texting part. Thank you for your correct answer.
    01-13-2016 09:39 AM
  16. buystockinfun's Avatar
    These forums are never any help. All it is is a bunch of people insulting each other and solutions that don't work. I almost have never gotten a problem solved from a stupid forum

    I have a samsung note seven. The box is an jack (unchecked google voice sicks) for blocking offensive words and in google and every other place I can look the box is the same and is an checked (unchecked. I hate thesr pos phones).

    Makes no sense but it won't f****** let me cuss. Instead of insulting everybody maybe somebody with half a brain could come up with a solution. Frustrating and then people that figure it out don't post an answer
    08-27-2016 08:11 PM
  17. Dick Headers's Avatar
    These forums are never any help. All it is is a bunch of people insulting each other and solutions that don't work. I almost have never gotten a problem solved from a stupid forum...

    ...Makes no sense but it won't f****** let me cuss. Instead of insulting everybody maybe somebody with half a brain could come up with a solution. Frustrating and then people that figure it out don't post an answer
    I feel your f****** pain. Which is why I joined this mother******* forum to tell you I finally f****** figured out how to remove the g****** censoring "feature" the a******* at Google forced on us.

    As odd as it sounds, on my S7 Edge, there is only one way to f****** curse without being blocked (even adding to my mother******* dictionary was useless as s***)...

    SETTINGS>GENERAL MANAGEMENT>VIRTUAL KEYBOARD>GOOGLE VOICE TYPING>BLOCK OFFENSIVE WORDS (UNCHECK).

    Boom! I can now tell my friends to go F*** themselves in the A**, and it works! F*** YEAH!
    06-24-2017 04:40 PM
  18. Yahtzee knows all's Avatar
    Don't worry to all of those that can't figure it out I got the solution. When you click your mic to do voice to messaging you will see a settings button to the left of the microphone. If you click that settings button it will bring up the Google settings and you can check off block offensive words so even if they're in your dictionary they will come up with asterixis unless you unblock it from the actual Google settings. So go in your messages as if you were going to voice message someone and when the mic pops up for you to record to the left of it is a settings button click on that and you will see the block offensive words and you can disable that. Everyone have a nice day.
    08-01-2017 03:56 PM
  19. Yahtzee knows all's Avatar
    It is really simple. It took me a minute to figure it out myself but I did it on my own because none of these forums help. Click on your mic as if you were going to message someone and when the mic pops up like it's recording to the left of it is a settings symbol click on that and then the settings for Google will pop up. Turn off block offensive words and it will no longer put the asterixis over your swear word.
    08-01-2017 04:03 PM
  20. Edwin Rosado's Avatar
    Got to go into your phone settings into language and input can into text correction and uncheck it there as well
    08-13-2019 09:52 AM
  21. NukaDadd's Avatar
    Open the keyboard, long press the 'comma' key, slide to the settings/cog icon and select 'Gboard keyboard settings'. Now you need to change a couple of things here:

    - Preferences. Enable 'voice input key'.
    - Text correction. Disable 'block offensive words'

    Took me way to long to figure this out after the "settings" in Google & phone were no help.
    08-15-2019 07:56 PM
46 12

Similar Threads

  1. Replies: 7
    Last Post: 10-02-2012, 03:11 PM
  2. Replies: 2
    Last Post: 10-01-2012, 01:14 PM
  3. After Bugfix Update...PIN Lock Now in Place
    By mthorn79 in forum Droid RAZR
    Replies: 0
    Last Post: 12-23-2011, 12:34 PM
  4. Replies: 11
    Last Post: 05-25-2010, 12:02 PM
  5. Apps running in background after i exit them?
    By joek71#AC in forum HTC Hero
    Replies: 13
    Last Post: 10-22-2009, 08:21 PM
LINK TO POST COPIED TO CLIPBOARD