1. EmeraldxxEyesx's Avatar
    I rooted my phone about a week and a half ago, everything went fine. Enjoyed my rooted phone, wasn't really sure what to do with it, but was learning and having fun. The 4.0.4 update came along and kept popping up on my phone so I installed it. It never said in any of the rooting things that I read that this would mess up my root. Now I have no idea how to fix it and I would really like to go back to 4.0.3 anyway. This update is totally sucking my battery dry. So my questions are: Can I go back to 4.0.3? And how do I fix my root?

    I guess I should specify and say that my superuser will not grant permission for /anything/ at all. And when I tried to run my wireless tether it first popped up and asked if my phone was rooted, then said superuser denied.

    I would love anyone who would help me out and please try to keep it in simple terms for me, I'm a newbie and don't really understand a whole lot yet but I catch on quick.
    08-01-2012 08:31 PM
  2. patrao_n's Avatar
    From now on know that taking any ota will destroy root. Doesnt matter what phone. To root 4.0.4 it would be best to find the ff18 one-click by sfhub on xda-developers.com. follow the instructions there to flash a prerooted ff18 touchwiz build by sfhub

    sent from my BAD A$$ Epic touch
    08-01-2012 08:37 PM
  3. patrao_n's Avatar
    Here it is http://forum.xda-developers.com/show....php?t=1721229

    sent from my BAD A$$ Epic touch
    EmeraldxxEyesx likes this.
    08-01-2012 08:38 PM
  4. EmeraldxxEyesx's Avatar
    Okay, I don't need to do anything prior to doing this?
    Is there any way to get back to 4.0.3 from the 4.0.4?
    I really hate the 4.0.4.
    08-01-2012 08:44 PM
  5. EmeraldxxEyesx's Avatar
    Sorry for the stupid questions but,
    Do I need to install the USB/Android Driver?
    I install for the reset data, right?

    Actually, just to make this easier, I've seen qbking77's name float around here, does he have any videos on this?
    08-01-2012 08:50 PM
  6. patrao_n's Avatar
    I would check youtube. I am sure he does. He makes one for everything it seems. Lol. Those one click are the absolute easiest for people new to odin. Yes you need those drivers. If you just go to the samsung site and grab kies it would have it in it. The no data version will allow you to keep the data for your apps and stuff. Seeing as your not rooted and couldnt use titanium backup this is your best choice. Nothing needs to be done prior since you wont be deleting your apps and would have no need to backup anything. For your convenience there is an option in the program to add cwm(clockworkmod) recovery. It allows you to flash all those zios files like roms and stuff

    sent from my BAD A$$ Epic touch
    EmeraldxxEyesx likes this.
    08-01-2012 09:12 PM
  7. EmeraldxxEyesx's Avatar
    I've tried to download the NoData three times and it keeps saying it was interrupted. I click the Mirror1, should I try clicking the Mirror2 instead?

    I'm understanding what to do now, he did have a video on youtube. If I would use my eyes once in a while it has a link right on that page that you gave me lol. Now I just need to find my usb for my phone. Tonight is just not my night..
    08-01-2012 09:22 PM
  8. EmeraldxxEyesx's Avatar
    Woohoo, found my cord. It was out in the car since my phone will not stay charged for anything. The Mirror1 NoData seems to be downloading now, it says 6mins left so we'll see. I'm sorry I'm being such a pain but I really don't know any of this stuff. I really appreciate your help!
    08-01-2012 10:12 PM
  9. patrao_n's Avatar
    M9rror 2 is waaay faster. Sorry should have told you

    sent from my BAD A$$ Epic touch
    08-01-2012 10:15 PM
  10. EmeraldxxEyesx's Avatar
    It's okay. Thanks for answering and sorry for being a pain xD
    08-01-2012 10:24 PM
  11. EmeraldxxEyesx's Avatar
    It's still saying the download was interrupted Dx
    08-01-2012 10:28 PM
  12. EmeraldxxEyesx's Avatar
    Okay well I don't know what it going on but it will not let me download the file. It repeatedly says download interrupted and I can't fix it.
    08-01-2012 11:12 PM
  13. patrao_n's Avatar
    How are you downloading it? I clicked on the link for the one click self extractor ff18. Clicked on mirror 2. Then clicked save and I fully downloaded it.

    sent from my BAD A$$ Epic touch
    08-01-2012 11:35 PM
  14. patrao_n's Avatar
    If you are doing it by phone and on wifi is your sleep policy never?

    sent from my BAD A$$ Epic touch
    08-01-2012 11:35 PM
  15. thenameisnigel's Avatar
    If you follow my guide, here, you shouldn't have any problems.

    EDIT: You're doing it by phone? I see...well. I'm tired, and my four year old is about to cry my eardrums out, so if you don't get it working by lets say 9am EST, you can PM me? Okay.
    patrao_n likes this.
    08-01-2012 11:48 PM
  16. patrao_n's Avatar
    Also this http://forums.androidcentral.com/sho....php?p=1609925

    sent from my BAD A$$ Epic touch
    08-02-2012 12:19 AM