1. erasat's Avatar
    Hi Guys.

    I got the phone last week and after a couple of days I updated to the Oreo Beta version, one thing I just noticed today after a reboot was that I had 3 Voice Mails after the reboot, those 3 calls were rejected by me but because I never got a Voice Mail notification I thought that they simply hanged up.

    The Visual Voice mail setting on the Phone app settings is turned on so I assumed that was all it was needed, but it's not. My current T-Mobile Plan includes Visual voice Mail so I already have that with the native phone app on the Galaxy S8+ and if I remember correctly it also worked when I had my Pixel XL, so I didn't download the T-mobile Visual Voicemail app thinking that I didn't need it.

    So today I downloaded it and when I opened the app it never registered, it got me an error every time that's when I decided to turn off the Visual Voice mail option on the phone app and it immediately registered and worked.

    Am I the only one? What about others t-mobile users with similar plans than mine, do you have it working or this simply doesn't work on T-mobile?
    12-03-2017 08:20 AM
  2. modifier's Avatar
    100%. I get VVMs all the time on TMO with mine. It works with the stock Phone app.

    My second PH-1 is on Oreo but doesn't have a SIM.
    12-03-2017 12:11 PM
  3. erasat's Avatar
    100%. I get VVMs all the time on TMO with mine. It works with the stock Phone app.

    My second PH-1 is on Oreo but doesn't have a SIM.
    Thanks for your reply but like I mentioned above, it doesn't work for me, if it's not for TMobile Visual Voice mail app I'd need to be dialing up the voice mail number to hear if I have VM pending or waiting for a reboot to be notified.

    So the one working for you is on the Nougat build then? Interesting.
    12-03-2017 12:15 PM
  4. modifier's Avatar
    Thanks for your reply but like I mentioned above, it doesn't work for me, if it's not for TMobile Visual Voice mail app I'd need to be dialing up the voice mail number to hear if I have VM pending or waiting for a reboot to be notified.

    So the one working for you is on the Nougat build then? Interesting.
    Well, you asked if you were the only one so my reply was in regards to that. I have a business account on TMO and VVM works perfect with the stock phone dialer. I don't know if Oreo doesn't work but Nougat works fine. I can't see this being broken in Oreo but my best recommendation would be to test it with Nougat to eliminate variables.
    12-03-2017 12:37 PM
  5. erasat's Avatar
    Well, you asked if you were the only one so my reply was in regards to that. I have a business account on TMO and VVM works perfect with the stock phone dialer. I don't know if Oreo doesn't work but Nougat works fine. I can't see this being broken in Oreo but my best recommendation would be to test it with Nougat to eliminate variables.
    I also have a business account just like you but I didn't test it while it had Nougat, so at least I now know that it may have worked on Nougat, but yes, it seems it's broken on Oreo, if I turn the Visual Voice mail option on on the phone app it doesn't give any error but it never notifies or even looks for the new voice mails and like I mentioned before the TMobile VVM app only works also if I disable this.

    It would be interesting to have more inputs from T-Mobile users with both Nougat and Oreo builds to see if it's something isolated on my phone/account or if it's a widespread bug with the Oreo Beta.

    Thank you.
    12-03-2017 12:45 PM
  6. erasat's Avatar
    I couldn't resist not knowing if it was going to work for me on Nougat so I downgraded to Nougat (I was having other issues here and there so it wasn't that bad after all) and yes, it worked as expected on the first try.

    So it seems it is indeed broken on Oreo for those of you interested, at least for me on T-Mobile.
    12-03-2017 04:40 PM
  7. modifier's Avatar
    Contact them through the beta page on their site and let them know. https://www.essential.com/developer/beta-feedback
    12-03-2017 06:51 PM
  8. erasat's Avatar
    Contact them through the beta page on their site and let them know. https://www.essential.com/developer/beta-feedback
    I'll do that.

    Knowing that you have T-Mobile, 2 more things that I've been working on and looking around but can't seem to find an specific answer;

    1-) Native Video Call option - Have you tried it? Does it work? As far as I can see the only way you can make a video call is by installing Google Duo and it's kind of hit or miss, we are supposed to see the Video icon on if the contact has Du installed and set but NONE of mine have that on, the same on the Messages app, the only app where I have something that looks like it works as it should is if you are on the Phone app and look at the Call history or do a search for a contact, if that contact has duo, then it shows a Video icon and if you click on it, it opens Duo and make the video call.

    2-) RCS in Google Messages - Is this really working on T-Mobile? I can't see any setting to turn it on or off the only thing I've found online is that the Messages app should not being Optimized in the Battery settings, but mine is not optimized and still no show of this settings.

    Sorry to bother you but being an "Essential newbie" I still getting adapted to the main differences with my other phones.

    Thank you.
    12-03-2017 07:04 PM
  9. modifier's Avatar
    My phone is under MDM and Google Duo isn't an allowed app in my organization. If I can get some time to set it up on my spare phone for testing I will.

    Not sure about RCS in Messages. The app is currently disabled. I use Yaata instead. I don't believe RCS works, however.
    12-03-2017 07:30 PM
  10. erasat's Avatar
    My phone is under MDM and Google Duo isn't an allowed app in my organization. If I can get some time to set it up on my spare phone for testing I will.

    Not sure about RCS in Messages. The app is currently disabled. I use Yaata instead. I don't believe RCS works, however.
    Ok, thanks
    12-03-2017 07:42 PM

Similar Threads

  1. Phone is going into bootloop after installing/updating apps
    By Android Central Question in forum Ask a Question
    Replies: 5
    Last Post: 02-13-2018, 10:58 AM
  2. Replies: 12
    Last Post: 12-08-2017, 05:08 PM
  3. Phone wont turn on, flickering and loop in charging logo while charging
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 12-04-2017, 05:38 AM
  4. why is my Lg-Ls970 not charging?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-03-2017, 10:55 AM
LINK TO POST COPIED TO CLIPBOARD