1. ThePiePieper's Avatar
    A bit of back story. The fiance and I both bought Galaxy S6's. Works great except one thing. My Facebook app takes forever to load over WiFi. Her seems to work fine though. My WiFi is plenty fast enough and I've tried uninstalling/re-installing the app. Even went as far as factory resetting my phone.
    I'm sure their is some switch or setting i clicked that she didn't.
    Thanks in advance.
    04-27-2015 10:12 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! But does it load normally on mobile data?
    ThePiePieper likes this.
    04-28-2015 01:05 AM
  3. ThePiePieper's Avatar
    It does. Over 4G it works fine. Everything else seems to work well over WiFi as well (BaconReader, Twitter, Chrome)
    04-28-2015 08:46 AM
  4. ThePiePieper's Avatar
    Scratch that. The Google Play store seems to run a touch slow as well. Not sure if related.
    04-28-2015 08:50 AM
  5. B. Diddy's Avatar
    Ok, and is it the same on any wi-fi network, or just yours?
    04-28-2015 11:02 AM
  6. ThePiePieper's Avatar
    All that I have tried.
    04-28-2015 11:48 AM
  7. B. Diddy's Avatar
    Go to Settings>Wi-Fi, tap Menu>Advanced. Are any of the options turned on? Try turning off Smart Network Switch, if present. Also turn off an "Wi-fi Optimization" option, since that's more for battery saving rather than improving reception.
    04-28-2015 05:00 PM
  8. ThePiePieper's Avatar
    I went ahead and unchecked all additional options and its still not helping.
    04-28-2015 06:29 PM
  9. B. Diddy's Avatar
    $%@#$%!!! Sorry, I'm out of ideas.
    ThePiePieper likes this.
    04-28-2015 09:17 PM
  10. ThePiePieper's Avatar
    Thanks for the support. I'm going to try and reset the phone...again and then reset my router/modem (Netgear AC1750 Model 6300). Maybe i'll luck out and it'll just work itself out.
    B. Diddy likes this.
    04-28-2015 10:35 PM
  11. decomush's Avatar
    This problem was driving me crazy for the last 5 days.
    This solved my problems:
    "Based on what you've said there's a good chance your issue is related to the bugged Android System Webview update. Could you look under App Manager > All and see if you're running version 37 or 42?
    If it's 42 try rolling back to v37 by uninstalling it from either the app manager or play store. The newest version has been giving a lot of people issues."
    ThePiePieper likes this.
    05-05-2015 12:17 PM
  12. ThePiePieper's Avatar
    I tried that but still nothing. Been riving me insane too, nothing i do helps and my fiance remains issue free.
    05-05-2015 10:45 PM
  13. ThePiePieper's Avatar
    One thing i did discover is that the phone works great without the SIM card. After pulling it out, all aps work great overwifi. Not sure if that helps or not.
    05-06-2015 12:19 AM
  14. ThePiePieper's Avatar
    Replaced the SIM card in my new phone, still no luck
    05-06-2015 09:41 PM
  15. Bruce Rechichar's Avatar
    Did you resolve this? I just started having this problem as well. Just rolled back to Android System WebView v37 and I still have the same issue. Speed Test on wifi shows I have over 22Mbps down and 1.8Mbps up. FB app photos and videos barely load or don't load at all if I turn off wifi everything in the fb app works and works faster
    09-09-2015 01:45 PM
  16. ThePiePieper's Avatar
    Nope, never was able to fix this. Wasn't until after I bought a Motorola Surfboard and Net gear Nighthawk did the problem go away. Guess it was my setup afterall.
    09-12-2015 12:39 AM
  17. 15Elbows's Avatar
    Had this problem when my wife bought a Galaxy S5. Facebook, instagram and pinterest pictures would take forever to load. It got to the point she went back and swapped it for an iphone 5s and it worked fine. Then we got a galaxy tab and the same thing happened. I was determined to figure it out this time....
    Turns out after trying a bunch of settings, turning off IPv6 on my router solved the problem. Voila! Hopefully this can help some of you guys out....dont know why the samsung devices cant handle it...
    dbla likes this.
    09-30-2015 10:34 PM
  18. ForElise's Avatar
    Some of the suggestion helped my problem too. thanks.
    10-05-2015 11:11 PM
  19. johnniewalk's Avatar
    Did you check your internet data it is working fine on that
    10-07-2015 07:11 AM
  20. dbla's Avatar
    Had this problem when my wife bought a Galaxy S5. Facebook, instagram and pinterest pictures would take forever to load. It got to the point she went back and swapped it for an iphone 5s and it worked fine. Then we got a galaxy tab and the same thing happened. I was determined to figure it out this time....
    Turns out after trying a bunch of settings, turning off IPv6 on my router solved the problem. Voila! Hopefully this can help some of you guys out....dont know why the samsung devices cant handle it...
    Thanks for the suggestion to roll-back the WebView app. It corrected the issues that I was having (for now at least) and my browsing experience and apps are working much better when connected to WiFi.
    03-30-2016 06:54 PM
  21. Alawishis's Avatar
    Thanks for the suggestion to roll-back the WebView app. It corrected the issues that I was having (for now at least) and my browsing experience and apps are working much better when connected to WiFi.
    I tried all of the suggestions except for the router changes with no success and I stumbled upon the issue. In my case it was an app called Clean Master. I noticed it was validating my application updates, something I didn't recall giving it permission to do . Uninstalled it all fixed. Hope this helps someone.
    05-15-2016 01:16 PM

Similar Threads

  1. Galaxy S5 Fingerprint Scanner Not Working
    By Dylan Jenkins in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-27-2015, 07:02 PM
  2. Replies: 1
    Last Post: 04-27-2015, 11:52 AM
  3. Why won't the touch on my screen work?
    By Jaecie_Paige in forum General Help and How To
    Replies: 1
    Last Post: 04-27-2015, 11:51 AM
  4. Replies: 0
    Last Post: 04-27-2015, 10:08 AM
  5. Best set of config tweaks to preserve battery on Lollipop?
    By pcguys in forum Samsung Galaxy Note 3
    Replies: 0
    Last Post: 04-27-2015, 09:59 AM
LINK TO POST COPIED TO CLIPBOARD