1. AC Question's Avatar
    So a few days ago, my Facebook app uninstalled itself. I don't know how did it happen, but I tried several basic methods including clearing the cache for Google Play, Google Services and all, restating my phone, pretty much almost everything the internet has to offer. No, my phone isn't rooted.

    The error that popped up is 'Error: -110'

    I've found no solution to this so far. Other apps I've tried installing works perfectly well. My device storage is around 700 mb. Can someone help me out with this?
    04-20-2016 06:47 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which phone? 700 MB is pretty small--Facebook may need more available free space to install comfortably.

    Does this happen on both wi-fi and mobile data?

    Try going to Settings>Apps>All, select Google Play Store, and Clear Cache/Clear Data, then Force Stop. Do the same for Download Manager. Now try again.
    04-21-2016 02:21 PM

Similar Threads

  1. Why are my text messages now appearing in Facebook messenger?
    By AC Question in forum Samsung Galaxy S6 edge
    Replies: 7
    Last Post: 10-25-2016, 05:17 PM
  2. Replies: 1
    Last Post: 05-18-2016, 02:40 PM
  3. Replies: 1
    Last Post: 04-25-2016, 06:43 AM
  4. How do I open wifi and Bluetooth on my Samsung Galaxy S3?
    By Patrick Mercado in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 04-21-2016, 02:28 PM
  5. Why am I unable to root my Android?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 04-20-2016, 07:09 AM