1. wenchzilla's Avatar
    Hello, I would like to start by saying that I have looked for the past 2 hours for a solution to this problem and nothing has worked. If you are going to tell me to just reboot into recovery by holding any variation of the volume buttons and power button, save your breathe. That is not the solution.

    I rooted my g2x with the superoneclick, that worked fine. After, I was having a difficult time booting up into recovery. Whenever I held the volume down and power button, it would go to a s/w upgrade screen where nothing would happen. I tried every combination of removing the battery, plugging the usb in, holding just the volume down button and power, holding both without power, holding both with power... nothing worked to get it into recovery. So I installed ROM Manager on the marketplace, that way I can reboot into recovery without having to worry about getting into it using hard buttons. I was successful with that, and when I got into clockwork recovery, I tried to do a superwipe, which didn't work. It kept telling me there was a missing file, I wish I'd have documented it a bit better, but I didn't.

    So I tried a manual super wipe - big mistake. I wiped everything, and I don't mean factory reset, I mean one by one, system, sd card, cache, etc. I rebooted my phone and it sent me in a boot loop. I assume because of my jerry-rigged superwipe.

    This is where I'm stuck.

    Boot loop doesn't get past the lg logo. My computer does not recognize my phone even though it has all of the proper drivers installed, whether the phone is at the s/w upgrade screen, in the boot loop or off. I was able to hold the volume down and power for a while and get the android loading screen, the one that makes you think you've succeeded, except it keeps rebooting before it can enter recovery.

    I'm stuck, I can't find anyone with this problem, everyone who I did find said they had to send it to t-mobile, but my phone is rooted and I feel like that won't fly with them. All of the other people who say they had this problem, were able to fix it with common solutions. I'm not as fortunate.

    If you guys have any sort of insight, I would greatly appreciate it. I was hoping there was a way to flash a new ROM via my computer, but I don't know what to do if my computer doesn't recognize my phone, I fear my phone won't connect to usb. Which reminds me, in recovery, prior to this whole debockle, I could not connect to my usb in the mount settings. It kept telling me...there was an error, I wish I could remember what.

    I don't know, please help. And for the love of god if someone tells me oh its easy just put your phone in recovery and flash a new ROM, I'm gonna stick needles in my eyes.
    03-02-2012 07:57 PM
  2. GTWalling's Avatar
    Go here and read all the documentation. This will flash the Real Clockworkmod so you can bring your phone back to life. Rom manager is bad on the G2x. It is a Fake Clockworkmod and sometimes the backups made by it does not work.

    [RECOVERY][APP]Update 09-23: One-Click NvFlasher ClockworkMod 5.0.2.0 and 4.0.1.5 - xda-developers
    03-03-2012 05:18 PM
  3. wenchzilla's Avatar
    I was really excited about your response, cause it's nothing I've seen or found before. Unfortunately my phone is not recognized by nvidia. It's recognized by my computer, well actually its a different computer. It can identify that it's plugged in, but the program doesn't see it, any suggestions? I'll post a similar reply to the other post
    03-05-2012 05:55 PM
  4. wenchzilla's Avatar
    Scratch that! It worked!!!!! Thank you so much, you are my messiah
    03-05-2012 06:09 PM
  5. quitcpr's Avatar
    I have in the screen S / W upgrade
    and after doing all the installation in xda forum and reboot the phone the same message appears on the screen.
    05-18-2012 04:49 AM
  6. gzakk22's Avatar
    i have the same s/w upgrade problem. after flashing with nvflash, before i put the battery back in its stuck at s/w upgrade page thenafterwards no power at all i put the battery in cant turn my phone on
    11-05-2012 05:10 PM
  7. haikunikki's Avatar
    Please help me!! I'm having the same problem and I'm trying to solve it before work. What do i do when I get to the site? How did u get urs to work properly? Please save me too!!! <3
    04-19-2013 10:25 AM
LINK TO POST COPIED TO CLIPBOARD