1. Captian4Phones's Avatar
    I tried to root/flash a rom to my Galaxy player 5.0 and it worked. Come to find out there was no play store so I decided to go back to stock and downloaded something that I thought was a "back to stock" rom and I got bricked. Now I'm in download mode and I can't find the stock FIRMWARE because all the links go to pages that say "download this download manager and we will give you what you ask for" but I still can't find the firmware.

    If anyone can find a link to an actual firmware that I can plug in to Odin3 please do so. I've been looking for hours now.

    Sent from my SAMSUNG-SGH-I997 using Android Central Forums
    07-31-2012 12:10 AM
  2. piizzadude's Avatar
    well looking in the usual good places turned up nothing for me. Since you are in dl mode I would say flash one of these (the correct one for your device) [GUIDE][01.07.2012]The Samsung Galaxy Player/S Wifi 4.0, 5.0 All-In-One Thread - xda-developers

    Then find the play store apk and just install that.
    07-31-2012 12:52 AM
  3. Captian4Phones's Avatar
    I have finally fixed it. I may have taken 6 months but ive finally fixed it.

    SGS3, 5-inch SGP, BB9300, and others.
    01-13-2013 12:17 PM