1. gm_mike's Avatar
    I brought a Galaxy S6 AT&T unlocked phone and put cricket service on it. Not sure if this is the right section for it but I'm still stuck on 5.1.1. I had the phone for awhile now and been checking to see everyday to see if there any updates but none. Does anyone know when 6.0 is going to be available on my phone?
    10-02-2016 01:21 AM
  2. B. Diddy's Avatar
    A carrier-specific phone generally has to be on that same network in order to get the official update OTA. From what I recall, I think the AT&T phones are also hard to update via Smart Switch, but you could try: SmartSwitch: Install & update or replace firmware. Or you could also try flashing the firmware using Odin: http://forums.androidcentral.com/amb...interface.html
    10-02-2016 02:01 AM
  3. gm_mike's Avatar
    I already downloaded Smart Switch on my laptop. I used it a couple times but it tells me I'm already on the latest software also. About using ODIN I'm not completely comfortable using it yet.
    10-02-2016 12:44 PM
  4. B. Diddy's Avatar
    You could also try bringing it to your local Best Buy (if there is one) and ask the Samsung rep there to flash the latest update, if they can. A last resort that would cost a few bucks would be to buy prepaid SIM from AT&T and just use it for that month, to allow you to access the update on the AT&T servers.
    gm_mike likes this.
    10-02-2016 04:55 PM
  5. gm_mike's Avatar
    Will a sim card from a t-mobile phone work? I can borrow it from my mom's phone to see if that will work. If not I'll try Best Buy tomorrow.
    10-02-2016 07:06 PM
  6. B. Diddy's Avatar
    No--it has to be the AT&T network.
    10-02-2016 11:59 PM
  7. gm_mike's Avatar
    So even though the service is through cricket I still have to use a AT&T sim card? Because right now I have a cricket sim in it right now.
    10-03-2016 12:23 AM
  8. B. Diddy's Avatar
    What I mentioned before is that a carrier-specific phone (your phone was originally an AT&T phone) usually has to be on that carrier's network in order to get the official OTA update. That means you have to be on AT&T. I don't think using an MVNO that uses AT&T's towers counts as the same thing.
    10-03-2016 02:16 AM
  9. gm_mike's Avatar
    Oh ok thanks I'll look into it tomorrow
    10-03-2016 02:19 AM
  10. gm_mike's Avatar
    Thanks man. I went to Best Buy earlier today and they did it for me. Now I'm on 6.0.1
    B. Diddy likes this.
    10-03-2016 08:32 PM
  11. B. Diddy's Avatar
    Great! I'm glad they were able to help you there.
    10-03-2016 09:14 PM
  12. mike568's Avatar
    You should be on build number MMB29K.G920AUCS5DPI1. You should have wifi calling and advance texting. I am not sure if they will work since it isn't ATT postpaid account.
    10-04-2016 07:02 AM

Similar Threads

  1. The lag on the phone is unacceptable
    By Miguel Medina1 in forum Samsung Galaxy S7 edge
    Replies: 45
    Last Post: 10-09-2016, 12:28 AM
  2. Replies: 1
    Last Post: 10-02-2016, 12:57 PM
  3. Why is my screen black on my kyocera?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2016, 07:08 AM
  4. How to create a movable and resizable keyboard on android
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-01-2016, 11:45 PM
  5. Replies: 0
    Last Post: 10-01-2016, 11:34 PM
LINK TO POST COPIED TO CLIPBOARD