1. Xebec01's Avatar
    I just switched to T-Mobile from Sprint yesterday. My daughter and I both work in the same building in Midtown NYC, but on different floors (3 and 7). She has a 7+, I have an LG V20.

    First day in the office and neither of us can get data. We both have the 4G LTE symbol, the arrows are flashing, but nothing loads. Outside the building things load, but very slowly.

    Is this typical for midtown NYC? Anything I can check or settings I can change to improve the data signal? I'm worried that I have to figure out how to go back to Sprint or go to Verizon...

    Thanks!
    anon(749368) likes this.
    02-22-2017 12:39 PM
  2. SpookDroid's Avatar
    I'm not in NYC to check, but unfortunately that's why networks are only good if their coverage works for you If the coverage in your area (in this case, your building) isn't good with T-Mo, then that might not be a good choice for you. Fortunately you should be able to undo the move within 7 or 15 days (forget what the period is). Does anyone else have a T-Mobile phone in your building that could verify if it's a phone or a network issue? If you have WiFi that allows it, you could ask T-Mobile for a personal cell that uses WiFi to connect to their network and relies the signal to their personal cell... would be like having a tower inside your building. (or you could just use the wifi on your phone and use WiFi calling).

    They also have a 'repeater' window unit, which amplifies the signal from outside a building, but this would need a strong-enough signal outside or near a window of your building for this to work.
    Laura Knotek and Almeuit like this.
    02-22-2017 03:32 PM

Similar Threads

  1. Prevent "Android System" from being seen in the Recent list.
    By coffee-turtle in forum Android 6.0 Marshmallow
    Replies: 1
    Last Post: 02-23-2017, 02:40 AM
  2. Noise and wind reduction in calls
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-22-2017, 05:30 PM
  3. Where is the sim card in this phone the ZTE N817
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-22-2017, 02:38 PM
  4. Replies: 2
    Last Post: 02-22-2017, 01:55 PM
  5. Why can't I type in my Google search engine?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-22-2017, 09:55 AM
LINK TO POST COPIED TO CLIPBOARD