1. pwkwsfi's Avatar
    FYI my device is a Droid X with Android 2.2 unrooted. I have been scouring the site and forums for something like this and have yet to find a similar issue.

    Current state:
    • Cannot install apps (new or already purchased).
    • Cannot uninstall apps (though OS or via store app).
    • Apps on SD card are listed by ROM name in the setting menu.
    • The same apps show as not installed on my DX when I try to open them. I removed the shortcuts.
    • Core apps and widgets installed on the phone still run.
    • This all applies to apps from both the Amazon and Google app stores.


    What happened? Last week I checked the Amazon Market app for updates like I have done before. I started queuing updates and eventually selected all 30ish apps that needed it. Later the device told me some apps could not be updated (actually all of them failed). Since then I am only able to purchase apps from either outlet.

    On the Google Android Market the download does not begin when I hit "Ok." From the Amazon store it seems that the apk files download then the process gets stuck in the installation step (never ending progress bar). Likewise the uninstall process dead-ends in the same way. I have not attempted a sidestream installation.

    Short of a factory reset, I would like to get my apps running again. It seems the SD card is working as I can read/write files on it. I see photos, downloads, and stored app data where they should be. In the meanwhile I will try to figure out what broke this functionality and try to reverse it. So far I tried unmounting the card then resetting the device. I had to toggle the Verizon connection today because it was not properly connecting (1-2 signal bars when my other phone showed 3G). This is probably just a red herring.

    Thanks for reading.
    07-25-2011 12:47 PM
  2. yodatom10's Avatar
    Have u done the gb update. Your phone seems to be messed up I might try formatting the SD card. If that fails u might need to do a factory reset

    Sent from my Xoom using Tapatalk
    07-25-2011 02:12 PM
  3. pwkwsfi's Avatar
    a brief update:

    I pulled the SD card, powered on, and removed a few apps that were installed to the card. I tested a couple of downloads and installations without the card, then checked for a system update. Turns out there is one, so I'm downloading it now.

    Thanks for the feedback.
    07-25-2011 05:04 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD