1. froggersloth's Avatar
    A strange problem that I've had 5 times now in 2 weeks with my phone: If I am in an app and I press the "home" button, it does not take me home; rather, it simply remains in the app or screen that I'm currently in. For example, this morning when I first turned on the phone, it was in the browser. I hit "home". The haptic buzz occurred, but it remained in the browser. I stabbed incoherently at it a few more times with the same results. Then I explored a little... I found that I could drag down the notifications and go to the utilities or apps shown there-- no problems. But, from the notifications or from those other apps, I still couldn't go "home" with the button. Eventually, I restarted the phone; problem (temporarily) solved. The search key does nothing when the phone is in this state. Also, I just discovered a few minutes ago that the option to change USB connection types when connected to a computer also vanishes from the notifications dropdown.

    This is an Evo 3D, but I don't see anything to indicate that this is a phone-specific problem.

    Is this a common thing? Any suggestions? I've seen suggestions that the phone be reset to factory state, but I see no reason to think the problem won't just come back.
    08-28-2011 09:04 AM
  2. Moscow Desire's Avatar
    Seems you already did a little troubleshooting, and are headed in the right direction.

    It's more than likey a software issue, especially when you reboot the phone and the problem goes away for a spell. This tells me it has to do with running apps and cach memory.

    You're going to have to take a look at your apps running, as I suspect they are the culprit. Things like task killers, battery optimizers, and apps similar to system utilities. You can try first, to go into the suspected apps through Settings/ applications/manage applications, and delete the cach settings from each. See if that helps. If it does, I'd remove the offending downloaded app.

    In the worst case, you can Reset to factory. This will of course, wipe your downloaded apps, and your contacts/sms/calender, so it's best to back these up first (paid apps will always be registered on Market). It will not mess with anything on your SD card. It's not such a bad idea to do, and watch the phone for a week or 2 before installing any apps. If the problem comes back before installing apps, then, turn the phone in for replacement. Leave it running so you can show the rep the issue.

    I'm pointing my finger at a downloaded app, or maybe 2 or 3. Just because an app is on the market, doesn't mean it's a good app
    08-28-2011 09:55 AM
  3. froggersloth's Avatar
    Thanks for the reply. I've started doing as suggested, but I've also tried extending the idea logically. I went and emptied caches. Unfortunately, the problem recurred rather quickly a couple of times. I then figured that perhaps some persistent process might contribute to the problem. I started removing widgets. Pandora was the last added, so it was the first to go. Still had the problem. I removed the MixZing widget next. I haven't had the problem since then, but I did shut down the phone to save the battery when I was away from a charger, so that's not a clear test. I'll let that go for a while and see what happens. Again, thanks for the help.
    08-29-2011 02:39 PM
  4. Jude526's Avatar
    As mentioned there are applications that very well can be the problem. Definitely using a task killer can cause problems. Android devices don't need a task killer. It really dampens the functioning.

    Sent from my ADR6300 using Tapatalk
    froggersloth likes this.
    08-29-2011 02:46 PM
  5. ls377's Avatar
    Haptic feedback rules out it being a hardware problem. Has this been happening since day one? It's possible (though unlikely) that the software was corrupted when you got it, so it isn't an app problem. If it still happens after a factory reset, then it's time for a replacement.

    Like Moscow said, it's probably some sort of utility app. I would start with those, and leave the more common apps (Pandora, etc.) for later.
    froggersloth likes this.
    08-29-2011 04:45 PM
  6. froggersloth's Avatar
    Thanks for the reply. With the exception of any utilities supplied by HTC or Sprint, the following are the only ones that I would characterize as "utility":

    Astro -- File manager
    Battery Status -- A utility to show the battery % on the notification bar
    SystemPanel -- A fairly complete task manager. This doesn't appear to be persistent, since when I look at the built-in task manager, it doesn't appear as a running app even after being run. It seems well-behaved, but I'm clearly no expert.
    Tasker -- Has a couple of tasks running which perform tasks based on charge state and SSID finding.

    So far, these all seem to be decent apps, but I'll focus more attention on them. As long as I've removed the MixZing widget, I suppose I might as well see what comes of it, but if the problem returns I'll focus on utility apps instead.

    Again, thanks for the help. The pointers are greatly appreciated.
    08-29-2011 05:30 PM
  7. Moscow Desire's Avatar
    As Is377 said, your haptic works, so it's most likely not a hardware issue.

    Astro -- * this is an ok app.
    Battery Status -- these types of battery monitoring apps are useless in my opinion. Not to mention they use resources. (arrest warrant for loitering)
    SystemPanel -- Suspect #1 (wanted for questioning)
    Tasker -- Suspect #2 (arrest warrant issued)

    It could be that uninstalling the apps will not fix the issue, as the damage is already done. Most of these "Utility" apps, are just a lazy person's way of doing things. Yeah, they sound cool and convienant, but remember, they too use system resources. Some more than others. Usually, a person can do the same, just by learning how to configure their phone properly, and understanding battery management. Some apps though, are really useful, so I don't take anything away from the dev's.

    On their own, they probably run ok. But install several, and chaos could erupt. Some apps just don't play well with others, and there's no initial way to find out which ones before installing them.

    Back up your stuff. A reset is in order as it's the only real method to ensure you get a working OS. The Market will remember your paid apps.
    froggersloth likes this.
    08-30-2011 01:05 AM
  8. froggersloth's Avatar
    Well, it turns out that suspect #2 is the one. In particular, I had a task set to disable the PIN entry when I'm at home. More specifically, "when near" my home SSID, set keyguard to off. I killed off Tasker, verified that it was no longer running (active background, or service) and tested. No more problems. I'm a bit disappointed... I knew that an app like Tasker would have to exert extensive control over the device, so I researched it for a while before testing and buying. Well, problem solved. Many thanks for the diagnostic helps.
    08-30-2011 02:56 PM
  9. Moscow Desire's Avatar
    Glad you got it going

    We were glad to help!!

    (we like it when you hit the "thanks" button)
    froggersloth likes this.
    08-30-2011 10:11 PM
  10. froggersloth's Avatar
    Oh, look at that. There is a "thanks" button!
    08-31-2011 12:37 PM
  11. Moscow Desire's Avatar
    You're too much!!!!

    Actually, we get a free phone based on the thanks we generate.
    08-31-2011 12:51 PM
  12. jobzombi's Avatar
    Hey I just found this thread intersting as I am having a similar issue. Haptic feadback works, it lights up too. Yet the home and search buttons do nothing. I think it may be a setting, just I have no idea where. I was cleaning up the phone and I went into manage application and a I cleared the cache and data on same apps that I figured were ok to do so with. Everything else was fine, but since then those two buttons do nothing but blink and vibrate.
    08-01-2012 11:08 PM
LINK TO POST COPIED TO CLIPBOARD