1. larrytxeast's Avatar
    I have an LG Optimus V, rooted, 2.2 (not sure what it's rooted to, it arrived that way). It has worked fine (except auto-rotate quit awhile back, I gave up trying to fix it) but for the last 2 days or so, GMail absolutely WILL NOT send. Every single email I try to send, it always gets hung on "Sending..." and it won't move a muscle.

    It has nothing to do with the quality of the connection, I'm at home operating over a Wi-Fi.

    Moreover, the "Sending..." never goes away unless I "wipe" the phone. Even turning it off & on won't do it, and I have no way of deleting it without deleting the entire conversation. I look up and every email I've sent, EVERY ONE has "Sending...." on the screen, and short of doing a "wipe" it absolutely won't go away.

    What's going on?

    11-18-2011 12:12 PM
  2. srkmagnus's Avatar
    Try force stopping the Gmail app. If that doesn't work out, try backing up important data and performing a factory reset and see if that fixes it.

    Sent from my HERO200 using Tapatalk
    11-18-2011 12:43 PM
  3. larrytxeast's Avatar
    Nope, it didn't work. Force-stopping it & then restarting it didn't fix it. I already did a factory reset earlier to "unstick" an earlier occurrence, and it's back to doing it again. In fact, for probably the last 2 days, I've been totally 100% unable to send any email from my phone at all whatsoever, unless I log into the website & do it that way, and that's completely unacceptable.

    UPDATE: this seemed to fix it. http://mobile.jack-frost.co.uk/andro...ot_sending.php

    It involves clearing the cache (which will cause you to lose any unsent items like the ones "showing red.") As they explain it:

    Go to the Settings menu, and then to Applications, then Manage Applications.
    Find the Google Mail and Google Mail Storage entries. Open the Google Mail one. Press Clear data, and OK to the prompt.
    Now go back and do the same with Google Mail Storage.

    Now, when you re-load the GMail app, you will see "Your email will appear shortly", and when it does, hopefully it should be fixed.

    It did seem to. I tried replying to one of the emails and this time, finally, it went through.
    11-18-2011 01:28 PM
  4. berdinkerdickle's Avatar
    Clearing data worked for me.
    02-24-2013 04:13 PM
  5. bwolmarans's Avatar
    In 4.1.2 and latest gmail app, from gallery, I attached some pics and had same issue.
    Fix was to go to gmail, click on inbox in top-left, then go to outbox, hit refresh. It immediately sent.

    { DC, Cloud, InfoSec Musings } | ...a needle in the Internet haystack
    RichardChapman likes this.
    07-30-2013 03:39 PM