1. Hugh Johnson's Avatar
    I use Link2SD and it automatically moves most apps to my SD card. For some reason my SD card won't let me transfer most things to it now. When trying to link apps to the SD I get the error messages shown below and if I connect to the phone with Wifi Explorer Pro some files won't upload and it says I/O error. I've used Root Explorer to change the data directory to r/w and it still doesn't seem to help. Any ideas?
    03-05-2012 09:35 AM
  2. pazzo02's Avatar
    Sounds like your SD card might be corrupted. This happened to me once, from unplugging from the computer without doing "safely remove hardware" first. You'll need to reformat the card. You might be able to copy the contents to your computer first, depending on how bad the corruption is.
    03-05-2012 10:48 AM
  3. Devinator's Avatar
    This happened to me once, from unplugging from the computer without doing "safely remove hardware" first.
    Yea, I learned the hard way back in the day on a thumb drive that you wanna make sure to do this. I didn't lose any data, but, I was going from one version of Windows to another without safely removing and it wasn't being recognized on the second version. Took me a while to figure out what the issue was.

    But, if you want to see if the SD card is indeed the problem, if you have another SD card, you could try and use that. If you are successful, you know it's the SD card, if not, then at least you have ruled out the SD card being the issue and we can try something else.
    03-05-2012 11:25 AM
  4. Hugh Johnson's Avatar
    I did a little more research into it and apparently "error 22" is fairly common when using Link2SD. I guess the mounting script gets deleted sometimes.

    Anyway, it looks like the easiest thing for me to do is just backup my apps and wipe the SD card. Thanks
    03-05-2012 12:55 PM
  5. Devinator's Avatar
    I did a little more research into it and apparently "error 22" is fairly common when using Link2SD. I guess the mounting script gets deleted sometimes.

    Anyway, it looks like the easiest thing for me to do is just backup my apps and wipe the SD card. Thanks
    No problem. Thanks for coming back and posting your findings!!
    03-05-2012 12:58 PM
  6. pazzo02's Avatar
    I did a little more research into it and apparently "error 22" is fairly common when using Link2SD. I guess the mounting script gets deleted sometimes.
    You could try using App2SD. I've never had that error with it.
    03-05-2012 08:51 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD