05-05-2014 02:30 PM
57 123
  1. Anisai101's Avatar
    Okay, I just switched from iPhone to Android on the weekend, and discovered that my previous contacts using iMessage could no longer text me unless iMessage was turned off on their side.

    I've tried unregistering the device from the AppleSupport website, and removing my phone number from the account. That did not fix the problem.

    I then spent three hours on the phone with an Apple Tech support employee, trying every possible solution. End result being him asking me to wipe my iPhone. Which I did. Still, the problem was not fixed. He sent a request to the Engineering Department and told me they would contact me in two days. I waited four with no response.

    I called them. Proceeded to spend an additional four hours with them on the phone. No solution.

    At the end they told me the 'only resolution' was to wait 30 days to see if the glitch would work itself out.

    30 days?! Can they legally force me to be an Apple customer? They won't give me a loaner phone until they work out their problems, they won't reimburse me for loss of services. They refuse to do anything.

    Slender Troll likes this.
    06-28-2012 07:45 PM
  2. Paradocks's Avatar
    iMessage is not compatible with Android. The only way for you to receive an iMessage from your friends is to have them send it as a regular text message.

    Sent from somewhere
    06-28-2012 08:08 PM
  3. Anisai101's Avatar
    Yes, I am aware of this.

    I am not trying to use iMessage...People are trying to text me a regular text message and iMessage interferes and won't let the text come through to my number.

    I spent hours on the phone with Apple Tech support and they can't figure the problem out at all. Their only solution was to have me wait 30 days in hopes that the problem will correct itself.

    Meanwhile, I am paying for services I cannot use.

    Can Apple legally do that?
    06-28-2012 09:44 PM
  4. Anisai101's Avatar
    Even my service provider tried to help me by contacting Apple and weren't able to get anywhere with them.

    My service provider ended up getting so fed up with Apple that my service provider offered to give me a new iPhone for free to correct the problem because Apple refused to do anything.

    Now I am literally being forced to be an Apple user when I want to be an Android user.

    It's not fair to me as the customer, to the service provider who is losing money to deal with Apples mess, and it's really not fair to Android because they've now lost me as a customer.

    Plus, Android loses all potential customers who are coming from iPhone because Apple won't fix their glitch thus forcing people to stay with them. Isn't that a Monopoly?
    06-28-2012 09:50 PM
  5. Paradocks's Avatar
    That is weird. So your phone number is tied to the iMessage server, and anytime one of your friends tries to send you a regular text message it is being intercepted by iMessage and won't go through? That's just wrong. I don't know what else I can say to help you. Sorry!

    Sent from somewhere
    06-29-2012 04:25 PM
  6. Patton12's Avatar
    I had a similar issue when I switched from iPhone to android. I ended up finding the option to turn off iMessage on my iPhone and that solved it. It was frustrating so I can relate to your issue. Good luck.
    06-29-2012 11:26 PM
  7. slydog21272's Avatar
    If I remember you have to put your sim in an iphone and turn off the imessage feature for your account. But i could be mistaken.
    06-30-2012 08:56 PM
  8. okbow68's Avatar
    I had a similar issue when I switched from iPhone to android. I ended up finding the option to turn off iMessage on my iPhone and that solved it. It was frustrating so I can relate to your issue. Good luck.
    That's what I had to do. I could text people with iMessage from new android but their replies were all going to my iPhone which was at home. That was an interesting day lol! Got home turned iMessage off on Iphone and problem fixed.
    07-01-2012 02:23 PM
  9. XChrisX's Avatar
    Glad to see this problem addressed here, as I have been receiving too many texts to my iPhone LOL. Glad to see the fix is as easy as just turning off iMessage.
    07-01-2012 09:37 PM
  10. miro7007's Avatar
    07-27-2012 11:37 PM
  11. Dantheman1880's Avatar
    Try this link iOS: Troubleshooting Messages

    Down the bottom of the page....insert sim, switch off iMessage and Robert should be your fathers brother....worked for me
    allpurposebeatz likes this.
    08-22-2012 07:05 AM
  12. incastillo's Avatar
    Make sure your friends have SMS enabled on their iMessage settings. That should do it
    09-18-2012 01:56 PM
  13. pluvc1993's Avatar
    Alright here's my fix for the iMessage dilema...First go to apple and unregister the iphone you were previously using. This has worked on occasion but like in my case it reappeared again for some reason. Step 2) Shut off your Android device. Take the sim card out of your new Android Device and put it in your old iPhone 4 or 4s. Now turn iPhone on it should now be working. Go into settings on your iPhone and down to messaging..Now turn off iMessage and turn on SMS...Wait a few minutes...Now shut off iPhone and take out sim card and put your sim card back into your android phone. Now start it up....Wahla!!! That should have taken care of the problem...For those of you who either sold or lost your iPhone..borrow someone elses and do the same thing. If you dont know how to open your iphone sim tray just stick a paperclip in the hole and push. Would love some feedback if it worked for you.
    K Mcshane likes this.
    10-09-2012 10:50 AM
  14. desiph3r's Avatar
    The problem I have is that sim card for my android phone is much larger then my sim card for my iphone4
    10-11-2012 11:56 AM
  15. shockzor's Avatar
    I've pretty much tried everything. I made the huge mistake of swapping my sim from my Note to my old 3GS to play with iOS for the day and now I'm screwed. Hopefully I can call AT&T and complain until they offer me a free phone or something...
    10-22-2012 10:18 AM
  16. kf6kmx's Avatar
    Having the same issue here. But changing sim across not an option as I'm on Verizon.
    The problem I'm having is after going from iphone back to android all imessages are going to my desktop mac and not to my phone as sms... Until I am home I don't see any of them.
    Cannot find anything on the imessages software to control it.. In fact nowhere does the desktop app even show my phone number... But it is still getting all of them...

    Sent from my Galaxy Nexus using Tapatalk 2
    10-27-2012 06:23 PM
  17. aliventhismoment's Avatar
    Does anyone have any other fix to this problem? I called AT&T support, and they said to unregister my phone. It worked for about 2 minutes and now I'm back to now being able to receive messages from my iPhone friends. They all say my text messages are blue on their phone which means their phone thinks I still have iMessage. I've removed my SIM completely from my iPhone and that didn't help, so I put it back in, turned off iMessage, and it still doesn't work. Nothing seems to be helping. This is a ridiculous problem, and it's very frustrating.
    11-06-2012 01:29 PM
  18. Nate_mn_dd13's Avatar
    Go into the preferences on your messages application on your computer. Disable the account and sign out. It took about 5 minutes and I started receiving txts on my phone from everyone.
    11-09-2012 02:53 PM
  19. Tyler Evans's Avatar
    I just did the same thing. I was on the phone for hours. I eventually got on the phone with some engineer or some manager. He told me that had this issue a couple of weeks ago and he explained what happened. So, my story is that I switched to android three days ago. I have been extremely frustrated the whole time because I wasn't getting texts from all of my friends with iPhones. The engineer on the phone told me that the iMessage server received a token four days ago saying that the phone number was still an active member of the iCloud account. The engineer then proceeded to tell me that it takes 14 days for the server to recognize that a device is no longer being used. So pretty much you have to wait 14 days after you switch from iPhone so the iMessage server will be updated. He also told me that I can go to icloud.com and to find my iphone. Then under my devices that it found, you can go in and erase your iPhone remotely (even if you have the iPhone right in front of you, you should do it this way). He said this should work as well. I just did that and it hasn't updated quite yet I think (meaning that on my brother's iPhone, my number is still recognized as an iMessage device). But I am not worried, because maybe the servers haven't updated yet or something. But the engineer was very confident that if you wait two weeks the device will no longer be recognized as an iMessage device.
    12-02-2012 04:33 PM
  20. Matthew Curry's Avatar
    The SAME EXACT thing is happening to me!!! I was on an android first before I bought an iphone. Then I went through about an hours worth of work with a verizon representative to activate my number on the iphone. After using the iphone 4s for a little less then a month I realized the iphone 4s was extremely limited in what it could do so i switched back over to my android Motorola Razr Maxx.

    I'm having the same annoying thing where iMessage is some how intercepting text messages. And the damnest thing is I feel like it is doing it randomly. I'm not sure how it is doing it but I'm guessing this is going to be a mess to fix. Does anyone know how to resolve this issue?
    12-12-2012 03:39 PM
  21. bigrat's Avatar
    Dont know if this helps. I read this method from some other sites and able to fix it after a few trials and errors. First back up and restore the iphone through itunes (please back up if you still want to keep the data & apps), then go to the apple website to unregister your apple id and uncheck your old iphone as registered product. Restart the phone. It may take about a day for the process before you can test if it works. Send a test imessage to your new android phone. The sender should soon receive an error message, then iphone should immediately re-try and send it through sms. Hope it helps. Note: my iphone was with AT&T.
    12-20-2012 06:57 PM
  22. K Mcshane's Avatar
    This worked for me (Above post about swapping SIM to Iphone and turning off Imessages). i had already got O2 to provide me with a new SIM but no matter what I did I couldn't receive messages from Iphone users and they just went to my old Iphone 4s. After this they started to come through on my Galaxy S3. Thanks, kev
    12-26-2012 04:36 PM
  23. paul9019's Avatar
    Simple fix for everyone on I phone go to settings messaging and turn off I message worked for me
    12-31-2012 04:05 AM
  24. dycorrado1974's Avatar
    Hi Tyler, was wondering if the issue was resolved after 14 days? Thanks.
    01-02-2013 11:20 PM
  25. maswebon's Avatar
    What do i do if i no longer have the iphone? I sold it to Best Buy. Please help
    01-03-2013 07:05 PM
57 123