1. afh081's Avatar
    So i just moved from RIM to Android and got the GS3. I am still getting used to it, but I seem to be having a serious issue with my email. I have set it up so that it checks every 5 minutes if there is a new email for either my gmail account or my work (imap) account. For some reason it will go hours before the emails come in.

    Is there some kind of thing that when the screen turns itself of after that given amount of time of no use that it won't send or receive, because I notice that when i check my phone after an hour or so, all of a sudden it will prompt me and tell me that there are X amount of emails in my inbox.

    Any help on this would be great.

    Thanks
    07-07-2012 11:39 AM
  2. PvilleComp's Avatar
    In settings, under Accounts and Sync, make sure your email accounts are set up for background data and auto sync.
    07-07-2012 06:56 PM
  3. afh081's Avatar
    I tried that, and it didn't seem to work. Also tried deleting the two email accounts and re-adding them and I am getting the same thing. It takes at least half an hour for an email to come through, sometimes longer. The RARE time it comes in within the 5 minute check which i have set on both accounts. Could it be a provider thing? I had a blackberry before (blackberry plan) with rogers.
    07-10-2012 07:26 PM
  4. Devinator's Avatar
    Is it only emails that are delayed? Are text messages delayed too? Just curious if it's notifications, or, just an email issue.

    Check to make sure your battery mode isn't set to maximum battery saver.
    afh081 likes this.
    07-10-2012 07:31 PM
  5. afh081's Avatar
    I turned off the power saving and that seemed to do the trick, at least on the test i tried. What a stupid thing to do to save battery power.
    07-10-2012 08:13 PM
  6. Devinator's Avatar
    Lol, well, I guess with some of the poor battery life on these phones they tried to add every trick in the book to improve battery life. But, glad that worked for ya.
    07-10-2012 11:11 PM
  7. afh081's Avatar
    Spoke too soon. I received an email in my gmail account at 2:18. At 3:30 on my phone within the native email app (not the gmail app - i have both work and gmail synced to the native inbox) I hit the "refresh" button and at the bottom of my inbox a little message popped up that said "last updated at 1:32" - so it hadn't checked for new emails in over 2 hours, but it's setup to check every 5 minutes (as a former blackberry user who gets a lot of emails you can imagine how frustrating this is).
    07-11-2012 02:42 AM
  8. afh081's Avatar
    And yes, it's just the email. I get all other messages when they are actually sent.
    07-11-2012 02:43 AM
  9. Devinator's Avatar
    Do you have Data Saver on? That delays emails with attachments greater than 750 KB until you are on WiFi. It's in the same menu as the Battery Mode options.
    07-11-2012 07:48 AM
  10. afh081's Avatar
    No, and I am on wifi, this is all happening within my home.
    07-11-2012 12:16 PM
  11. Devinator's Avatar
    If it were just Gmail, or, just your work email, it might be easier, as it would probably be an issue with an App or an account or something. But, since it's both, it must be some setting somewhere. Your work email is IMAP, and, the Gmail App might very well be too. If it is, that is really the only thing that is standing out, that they are both IMAP.

    Did you try going into anything Email/Gmail related in Manage Apps and clearing out cache, data, etc.? I dunno man, I don't really have any other ideas.
    07-11-2012 12:28 PM
  12. RunSilent23's Avatar
    Spoke too soon. I received an email in my gmail account at 2:18. At 3:30 on my phone within the native email app (not the gmail app - i have both work and gmail synced to the native inbox) I hit the "refresh" button and at the bottom of my inbox a little message popped up that said "last updated at 1:32" - so it hadn't checked for new emails in over 2 hours, but it's setup to check every 5 minutes (as a former blackberry user who gets a lot of emails you can imagine how frustrating this is).
    As a former Blackberry user, I hear you. When I converted to Android, I never knew when I would get my MSN email in the stock email app.

    I would go the other way. Link your imap acccount to your gmail and use the Gmail app to get your email. You can respond using either account (imap or gmail) and the response time will be more in line with what you were getting on your Blackberry.
    07-18-2012 01:23 PM
  13. bpzilla's Avatar
    I think I have the solution... As I was getting the same problem. I have a hotmail account but I wouldn't receive all my emails only selected emails. Extremely annoying. LONG STORY SHORT THIS IS WHAT I DID....

    1. delete your hotmail/msn/live account.
    2. add 'other email'
    3. type username and password, click default email
    4. you get a settings menu> click next
    5. you should get all your recent emails.
    07-20-2012 06:20 AM
LINK TO POST COPIED TO CLIPBOARD