1. basportsaddict's Avatar
    My device:
    I have a 7" iDeaUSA YG A777 Android Tablet that is rooted. The version of Android it is running is 4.0.3. The kernel on the device is 3.0.8-tcc root@kf-mid #97.

    My problem:
    When I try to back up my device using the MyBackup app, the device reboots in the middle of the backup. When I attempt another back up after the reboot, I get the same results. I've tried uninstalling and re-installing the app, but that doesn't work. Clearing the app's cache doesn't work, either. I read a few posts that suggested that the SD card or USB flash drive might be the cause, but that isn't the case (at least in regards to my situation) because the same thing happens when I try to back up online to MyBackup's database with no SD card or USB flash drive attached.

    I also tried using Titanium Backup ★ root, but I got the exact same results as I did with MyBackup, so the problem isn't app specific. One thing that did work was not allowing root access to MyBackup. When that is denied, I can back up my device as many times as I want. However, since MyBackup has been denied root access, it can only back up the apps on my device, not the data that accompanies those apps. That's a problem because the main reason that I'm backing up my device is to back up the apps on my device AND its data.

    I've been at this for three days. During that time, going through all of the steps that I've listed here has made the backup go through completely without rebooting once or twice, but the reboot problem persists more often than not. Im out of ideas to try. Any suggestions would be helpful.
    07-10-2012 02:32 AM
  2. Devinator's Avatar
    You said you got the backup process to go through once or twice, do you mean when you denied root access it worked, or, it worked with root once or twice.

    Are you experiencing any other issues with your tablet?

    When did you buy the tablet?
    07-10-2012 08:15 AM
  3. basportsaddict's Avatar
    It worked once or twice with root access. So, it has worked with root access, but very rarely. It works all the time when root access is denied.

    I don't have any other issues in regards to the tablet rebooting on its own. That only happens during backups. I do have problems with my built in camera, which only works after doing a power cycle. If I try using the camera after the tablet has been used for a while, I get a "Camera Error - Cannot connect to camera" error message.

    The tablet was actually a birthday present, which was bought sometime around June 9 (probably on June 8).

    Thanks for your reply.
    07-10-2012 12:58 PM
  4. Devinator's Avatar
    Okay, I gotcha. Well, at least you know you can backup, it just might take a couple of times.

    Well, if you want to backup, but, can't, maybe you should try and swap it out for a new one. If it's a problem with your tablet, it would be nice to have the same tablet, only without that problem. And, if you return it and a new one of the same model is doing the same thing, then you know that that model has a problem and you could get a different one.

    Do you know anyone else with this tablet that you could test out backing up on? Or, maybe a store that sells them that you could go in and pretend you are interested in buying it, but, had problems with backup before and wanted to make sure backup worked before you buy?

    Unfortunately I have no experience backing up and that's the best I can offer, hopefully someone with more experience will chime in.
    07-10-2012 01:04 PM
  5. basportsaddict's Avatar
    Yea, unfortunately, the one or two times that the backup worked was out of around 20 times doing it. Plus, even if I do back it up successfully, I'm not convinced that I'll be able to restore my device successfully if the situations gets to where I need to do a factory reset. Unreliability in backing up/restoring a device is never good.

    It's starting to look like I may have to return it. I don't know anyone else who has the exact same tablet as me (it's an obscure brand). I'm also not sure where the person who bought it for me got it. I'll have to find out.
    07-10-2012 01:19 PM
  6. Devinator's Avatar
    Yea, that's a good point. If it doesn't backup well, why should you expect it to recover well.

    Well, before you return it, you could always try a reset. I didn't suggest it at all because we were trying to backup here. Yea, it's definitely an obscure brand. Maybe that is why the backup isn't working. Might just be a good idea to return it anyway and get something more main stream. I love my Prime!!
    07-10-2012 01:23 PM
  7. basportsaddict's Avatar
    I forgot to mention this before, but I've actually already done a few factory resets and restored everything manually in my attempt to find an answer. It didn't work.

    I'd love to have something more mainstream (if for anything, for more support and familiarity with the brand), but I can't afford anything better right now, so I'm stuck with my Chinese-made tablet for now. It's actually not a bad tablet, it's just when something goes wrong, there aren't very many places that I could ask for help and get the problem resolved (case in point: my current situation).
    07-10-2012 01:48 PM
  8. Devinator's Avatar
    Ohh, well, then, yea, if factory resets aren't fixing the issue, I think you'd probably want to return it.

    Ahh, okay, I gotcha. Well, maybe return it, take that money, and, save it. Then try and keep saving until you can get something better. Or, hope that someone can come in here and help you with the issue. Sorry I couldn't help you solve it.
    07-10-2012 01:51 PM
  9. basportsaddict's Avatar
    It's all right. I appreciate you at least trying. Out of the four forums that I've posted this problem in, you're the only one who has responded. Haha.
    07-10-2012 01:54 PM
  10. Devinator's Avatar
    I hope the other three were different sites and not AC. I like to think we are a cut above the rest here.

    If I have any other ideas I'll come back and let you know. If not good luck.
    07-10-2012 01:59 PM
  11. basportsaddict's Avatar
    They were three other sites with Android forums.

    All right, sounds good. Thank again for your help!
    07-10-2012 02:02 PM
  12. Devinator's Avatar
    Good. Glad they weren't AC. We got a good group here.

    No problem!!
    07-10-2012 02:05 PM
  13. basportsaddict's Avatar
    I finally figured out what the problem was. I mentioned in my first post that I used Titanium Backup and got the same results as I did with MyBackup Pro. However, when I used Titanium Backup, MyBackup Pro was still granted root privileges. I think when Titanium Backup got to the MyBackup Pro app to back it up, it activated something with the app that was causing it to reboot my tablet. In other words, what I did to fix my problem was I denied root privileges to MyBackup Pro and Titanium Backup now works fine and produces a successful backup everytime. So, MyBackup Pro was the problem.
    Devinator likes this.
    07-17-2012 02:08 AM
  14. Devinator's Avatar
    Huh, that's interesting. Sounds like a conflict of interest between the apps. Well, thanks for coming back and posting a resolution. I never would have thought of that.

    Man, we spent a week working on that.
    07-20-2012 11:25 AM
  15. basportsaddict's Avatar
    I didn't have Titaninum backup installed when I ran most of those failed backups using MyBackup Pro, so my guess is the problem purely has to do with the MyBackup app having problems working with my tablet.

    Anyway, it's fixed, but it certainly took a while. Haha.
    07-20-2012 02:01 PM
LINK TO POST COPIED TO CLIPBOARD