1. Carameldry's Avatar
    Hi everyone, i have Paid US$ 2.91 for a game,Plant VS Zombie from play store. But after i finished downloding and installed it, I open the game, but it says "application is not authorized for use on your android device". And i tried uninstall an install again, but its still the same. My android is 4.0 version. Can I know what's the problem? Who have this problem before? How can I solve it? If there's no way to solve this problem can I get my money back?? please Help, thank you.
    08-03-2012 07:21 AM
  2. vishalsrivastava's Avatar
    Sir,/Madam

    I have purchased an application 'Need for speed Most wanted' from google play (online) and installed on my device 'Micromex A101'. But after installation, when I open such application, it shows 'THIS APPLICATION IS NOT AUTHORIZED FOR USE ON YOUR ANROID DEVICE', which is so disappointing. When such application was not authorized for use on my anoroid device HOW it has been installed on my anroid device. Please help me in refund the amount spent to purchse such application.
    11-24-2012 10:54 PM
  3. B. Diddy's Avatar
    Do both of you have wifi or 3G/4G mobile data on when you're trying to run your games? More and more games these days require an internet connection on startup to check the license.
    11-24-2012 10:58 PM
  4. ThePurpleAndroid's Avatar
    With purchased apps, they give you 15 minutes to try it and return it. You might have to contact Google Play and explain the situation to them.


    ~~HTC Evo Design~~
    11-25-2012 06:41 AM
  5. Krunal Surti's Avatar
    Here I have also the same problem of MRS Mostwanted. I have Sony Xperia E,.. Nd I have 3g speed... Bt I m still getting this error of unauthorination. Can any one help me???
    06-29-2014 06:46 AM
  6. Rukbat's Avatar
    As B. Diddy said, since it's been more than 15 minutes, contact Google and explain the situation and ask for a refund. (Not all apps are written to run on all versions of all phones. The developer has to upload versions for all versions of Android for all phones and mark them properly, so Play sends you the right one. If the developer makes a mistake there, you get the wrong version and it won't work on your phone.)
    06-29-2014 02:37 PM
  7. raptir's Avatar
    Both apps people are complaining about here are EA games, and I've run into the issue with EA games in the past. It works for me by just uninstalling and reinstalling the application. I'd try that first, but if that does not resolve it then contact Google.

    https://support.google.com/googlepla..._topic=3364671

    I tried contacting EA but never received a response back, so I would go straight to Google.
    06-30-2014 09:56 AM
  8. Nyi Thike's Avatar
    Hi ,
    Help me. Your plants and zombies could not authorized on my phone.
    My phone is 5.1.1 version.
    Help me please...
    06-24-2017 06:12 AM
  9. belodion's Avatar
    Hi ,
    Help me. Your plants and zombies could not authorized on my phone.
    My phone is 5.1.1 version.
    Help me please...
    Welcome.

    Have you tried the suggestions in the posts above?
    06-24-2017 07:10 AM
LINK TO POST COPIED TO CLIPBOARD