1. safmedina's Avatar
    I've just recently jumped ships from iphone 4s to samsung galaxy S3. Unfortunately i'm having a problem mounting it on the iMac. It does not show up, the internal storage or the sd card storage. Tried switching on MTP (Media device) and PTP (Camera), but that does nothing, Even tried switching on debugging USB, but that didn't work as well. At the moment relying on synching data using the browser, using applications like "iSyncr", and using Windows 8 Beta, which apparently works fine. But there is the hassle of boot camping, changing from OSX to Windows. I know there is a way round it, but that is to root your device, and install an app SGS3 Easy UMS. But that will be my last resort. Any one out there with any ideas?
    09-20-2012 07:51 AM
  2. crackberrytraitor's Avatar
    This will solve your problem!
    http://galaxys3root.com/galaxy-s3-tu...-a-disk-drive/

    Sent from my Nexus 7 using Android Central Forums
    safmedina likes this.
    09-23-2012 02:45 PM

Similar Threads

  1. Samsung Galaxy s3 headphones not working (Volume Control buttons)
    By rjenkin41 in forum Sprint Galaxy S III
    Replies: 33
    Last Post: 01-26-2014, 09:48 AM
  2. Replies: 31
    Last Post: 09-12-2012, 07:15 PM
  3. Sprint Samsung Galaxy S3 Blue Brand New in Box
    By NickB2005 in forum Marketplace Archive
    Replies: 5
    Last Post: 09-11-2012, 11:54 PM
  4. Replies: 2
    Last Post: 07-18-2012, 02:49 PM
LINK TO POST COPIED TO CLIPBOARD