07-08-2014 01:46 PM
74 123
  1. codysanbor's Avatar
    I have metrocast in Va king George county and I'm having the issue still. I went to another wifi and it works. The people from metrocast came out and the tech said he's having the same issue at his home with his daughters ipod with YouTube while on wifi. I they are monitoring my line to see what they can discover.
    Ah I'm in colonial beach va! Close to me
    10-07-2012 10:06 PM
  2. codysanbor's Avatar
    How do you change Dns server...

    Amd Metrocast sucks
    10-07-2012 10:17 PM
  3. Lawndawg's Avatar
    Found this thread because I'm having the same issue. Using dlink 655 and all the sudden youtube stopped working on all wifi devices except wife's laptop. N7 and two iphones. Work fine on bro-law's wifi. Very frustrating. Have reset router and modem. Also on metrofail but so in my bro-law. Tried to mess with anti-virus(avg) but no luck with it either.
    10-07-2012 10:45 PM
  4. bigcatman's Avatar
    So I changed my DNS to Google's. All is well now. Change your primary to and your secondary to in your Router settings. Weird. Thanks for the tip.
    10-07-2012 10:49 PM
  5. Aegeis's Avatar
    Glad to help.
    bigcatman likes this.
    10-07-2012 10:54 PM
  6. codysanbor's Avatar
    So I changed my DNS to Google's. All is well now. Change your primary to and your secondary to in your Router settings. Weird. Thanks for the tip.
    I have a net gear something nv200 or 300.

    Why do I set it to that? Just curious
    10-07-2012 11:01 PM
  7. codysanbor's Avatar
    I will let you all know if this works in am when i get off work around 7:30
    10-08-2012 12:32 AM
  8. juggy4805's Avatar
    I had the same problem on an Ipad, two IPhones, and a Xoom. Changing the DNS settings to Google's fixed the problem. I also have Metrocast in Maryland.
    10-08-2012 06:17 AM
  9. juggy4805's Avatar
    10-08-2012 06:20 AM
  10. booyamachine's Avatar
    Also on Metrocast & also in NH and having these same issues on 2 iphones and an ipad
    I know this is an Android forum, but I just wanted to thank you guys for the fix, I'll be trying the DNS change when I get home from work today.

    I really wish there was another option for internet service around here.
    10-08-2012 08:36 AM
  11. mscfl's Avatar
    I'm the oddball, not in NH and not on metrocast. I'm on Nefcom in Florida. Having the exact issue. The DNS change fixed it....Thanks!

    Can anyone explain what the issue might be if changing the DNS fixed it?

    ETA: This could be totally unrelated but I just thought of something. I received notice from my ISP the other day that they are about to offer us Google Apps. They said there could be outages during the migration over to google. I wonder if they changed something that caused this....
    10-08-2012 10:50 AM
  12. PeteNH's Avatar
    Ok, thanks to this thread I was able to fix the issue as well. I'm also a NH Metrocast subscriber. I called Metrocast today and they are aware of the issue and are instructing people to use Google's DNS. From what he said, they use a third party company for their DNS server and it could very well be that some of these other non Metrocast ISP's are using the same company.

    I've had issues in the past with Metrocast's DNS not loading certain pages that loaded fine everywhere else.
    10-08-2012 01:04 PM
  13. codysanbor's Avatar
    Worked like a champ! Thanks guys!!
    10-08-2012 01:41 PM
  14. chbartel's Avatar
    Worked like a champ! Thanks guys!!
    I am also having the exact same issue..I have been ready/trying different things for two days now. It seems to have started I think maybe a week or so ago, but I don't know exact timing.

    I have a Samsung Galaxy SII, and also TWO Samsung Galaxy Note II's. All three of these are doing the exact same thing as you describe above. Originally I had stumbled upon an issue with not being able to download Google Play updates to apps on my phone when I was connected to my local wireless network. BUT, if I was connected to 3G/4G coverage, it updated fine. AT same time, I realized I was also having issue getting Youtube to play on my phone. I checked the other two phones, they are all having same issue.

    I took my phone to another wireless network and it downloads fine with youtube. As soon as I hit my wireless at home, same issue comes up. I have played with settings and here is what I have to do to make it work:

    "forget" network. Re-add the wireless network back in. Let it get IP address. I then go in and edit network settings and change to fixed ip and not using DHCP. I then change DNS to either the OPENdns servers or Google servers(as listed above). It then works fine. BUT, if I reboot my phone, or if I leave the house(so it disconnects from router), then I come home and re-connect back up, it will not work again! I then have to manually do as I describe and each time I can get youtube videos to play. Also note that when youtube quits working, I also can't update my google apps in the google play store. As soon as I change the wireless settings as I describe above, I can then connect to youtube and also google apps will update(and I can download new ones as well).

    This is driving me crazy. I can't imagine what could be causing it on my wireless network. It only affects youtube and the google apps store on my phones, I can watch youtube fine on all my 7 other pc's in my house. My router is a pretty new model.. A Netgear R6300 with all firmware updates. I have opened a ticket with Netgear, but don't yet have a response back from them yet.

    I have Comcast here where I am.

    Anyone else have ideas or a solution?
    12-16-2012 10:22 PM
  15. chbartel's Avatar
    I have hard reset my wireless router, this didn't do anything. I have tried lowering security on my wireless as Netgear thought that could possibly be causing it, but no resolution. My router has worked fine though the past 6 months with same devices, so I thought that was a long shot. My next step is to call Comcast, grrr...
    12-17-2012 11:37 AM
  16. pontiac005's Avatar
    I had problems awhile back not being able to connect to YouTube, and amazon etc. I tried power cycling my router and that did not work. I ended up resetting my Comcast cable modem and it worked after that.

    Sent from my Galaxy Nexus using Android Central Forums
    12-17-2012 11:42 AM
  17. chbartel's Avatar
    I think I have found the issue or what is causing it, waiting on Sprint to resolve. I think this is possibly happening on other networks as well, read here:

    Sprint Community: Youtube error while on wireless router at home "connection to server lost"
    12-21-2012 03:31 PM
  18. Vilmantas Klinavicius's Avatar
    So I changed my DNS to Google's. All is well now. Change your primary to and your secondary to in your Router settings. Weird. Thanks for the tip.
    03-22-2013 05:23 AM
  19. Nilesh Shah1's Avatar
    Its the problem from google as they have removed the proxy server so wont able to download any app from play store and even youtube wont work on wifi we have to wait untill they fix the prob
    03-25-2013 11:15 PM
  20. Lukashenko's Avatar
    Changing DNS definitely fixes this issue, i had the same problem, couldn't get youtube on the browser and the app. So if anyone else gets this problem again try this app to change your dns (root required) http://urlmin.com/r89
    07-07-2013 12:11 AM
  21. Keepitcool Jimmybob's Avatar
    Another thing you could try is a complete factory reset of the device. This seems to have worked for me.
    07-11-2013 11:01 AM
  22. ashraf11_11's Avatar
    For about a week now, I am having the same issue described above with my Note 10.1 and Note 3 phone.
    I have tried resetting the Note 10.1 to factory setup and it did not fix the problem. I have also, after seeing this thread, tried changing my DNS setting to point to google's and that did not fix the problem either. On the Note 3 I tried also disabling the wifi power safe mode and that did not help.

    Any more ideas?
    01-22-2014 09:15 AM
  23. tiddyt's Avatar
    I know that this is an old thread. But I figured I'd weigh in as a quick google search reveals that many have this issue...but is not much out there in the way of a fix.

    Yesterday I came home and many apps would not load on both my Nexus 5 and Nexus 7 while connected to my home wifi. YouTube, Google Play, Facebook, Instagram...all would not connect on my home network. They worked fine over mobile network...but not on my home wifi. Anyway...I tried restetting router, forgetting networks, etc. None of it worked...BUT the DNS fix above worked!!! Changing to Google's DNS, primary and secondary, has fixed the problem! Odd that this would also fix the connectivity issues with Facebook and Instagram...but it has.
    02-22-2014 08:10 AM
  24. Siddhant Bhutoria's Avatar
    easy fix.... goto your wifi settings on your phone or laptop thats facing this issue and change the DNS to google DNS...

    Should I use my ISP's DNS, or Google's - Server Fault

    wont effect your browsing speed.... i had faced the same issue
    07-08-2014 01:46 PM
74 123

Similar Threads

  1. Need some help, ROM Manager not working right
    By grazamataz in forum T-Mobile Vibrant Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 09-15-2011, 07:42 AM
  2. Need some help, ROM Manager not working right
    By grazamataz in forum T-Mobile Vibrant
    Replies: 1
    Last Post: 09-15-2011, 07:42 AM
  3. Youtube not working on 3g (only on wifi)
    By Peter_bchs in forum HTC EVO 4G
    Replies: 0
    Last Post: 04-01-2011, 11:49 PM
  4. Bluetooth and youtube not working on ANY custom rom
    By samirv79 in forum Epic 4G Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 03-24-2011, 05:21 AM
  5. D2 wifi disaster - need help asap!!!
    By Rev2010 in forum Motorola Droid 2
    Replies: 8
    Last Post: 12-09-2010, 09:25 AM