08-07-2016 10:54 PM
41 12
tools
  1. Rukbat's Avatar
    There's a problem if a manufacturer just puts Play Store on a phone without getting Google involved in the process. What "not compatible with this device" means in that case is (we didn't authorize the manufacturer to use the Google Play Store, so you can't download apps from here".

    Your best bet, when common apps give you that error is to get the Amazon App Store app and download your apps from there. It's as safe as Google and they have pretty much the same apps.
    ezzcrits and Cheryl Ann1 like this.
    04-30-2014 07:08 PM
  2. Henners Tucker's Avatar
    i have an Htc one mini and im trying to download an app called blastron it says my device isnt compatible with this version
    05-18-2014 02:36 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Are you trying to install from Google Play? https://play.google.com/store/apps/d...abam.blastbots
    05-18-2014 02:59 PM
  4. aysha saeed's Avatar
    So I tried to download some app on play stor like snapchat line etc but it said " your divice isn't compatible with his version" I used HTC Verizon
    09-30-2014 07:21 AM
  5. B. Diddy's Avatar
    Welcome to Android Central! Apps are not necessarily compatible with all devices. It may depend on hardware or firmware issues.
    10-01-2014 07:41 PM
  6. Cheryl Ann1's Avatar
    Thank you! After many unsuccessful attempts to find resolution, yours was right on target.
    11-06-2014 02:41 PM
  7. Micmichael Adflak's Avatar
    I just got it, it can't be too old. What am I missing in my device, how do I check?
    I have China made tablet. I was unable to download apps from Google play also. I searched for a solution and found an app called "mobile 1 market." It is just like Google play but does not block devices it finds incompatible. I was able to download every app on mobile 1 market that Google play denied me to download. Hope this helps you out.
    01-03-2015 09:07 AM
  8. r thejaswi's Avatar
    I tried to download what's up n fiber from play store n its says my device is not compatabile?
    01-19-2015 11:42 AM
  9. Rukbat's Avatar
    As B. Diddy said, not all compilations of all apps are necessarily compatible with all devices. That's just how it is. (Does a size 44 long fit all men? How about if it comes in sizes from 38 to 46, long and regular? Still some men it won't fit? Why don't they make those pants in a 52 inch waist with a 28 inch inseam? Or a 30 inch waist and a 40 inch inseam?)
    01-19-2015 05:51 PM
  10. Mussa Ali's Avatar
    samsung star 2 duos g130e
    i cant install instagram and retrica
    please help
    02-11-2015 07:19 AM
  11. SONYMANO's Avatar
    I've been try to fine a way to download the genuine TomTom UK for my Android car stereo unit which google play indicates is not compatible. I've got a not so genuine copy on the device which works fine but I do want the original so I can also have traffic updates plus any other in app purchase. Apparently there is currently no way to root this unit so I cannot edit the build.prop file. I do not have another android device either. Is there a solution that will allow me to download the original TomTom to the device ?
    03-14-2015 12:15 PM
  12. Rocky Antoky's Avatar
    Got Mobile 1 market, found New Words with Friends which wouldn't work on my tablet from Google play.. Downloaded from Mobile 1 Market and presto changeo I am in business!
    03-16-2015 10:04 AM
  13. SONYMANO's Avatar
    To get apps that are free on Google play that aren't compatible on your device are available from several other sites but to get original paid apps that aren't compatible on your device is more challenging unless the android device has been rooted which my device isn't able.
    03-16-2015 11:06 AM
  14. Joshua Gonzaga's Avatar
    MY DEVICE IS SAMSUNG GALAXY S3 I WANTED TO DOWNLOAD DUBSMASH BUT IT SAYS "Your device isn't compatible with this version" Sad life pls help me i don't know why
    04-14-2015 09:54 AM
  15. anonyma's Avatar
    guys.
    i have tghe same problem...I have sony xperia S..even on my factory apps in google play store when i want to update them (including walkman, album, games and apps) it writes that my device isn't compatible with this version.
    When i've got the phone the first apps i was downloaded from the play store was Dubsmas..it was full of bugs ..i deleted..reinstalled...nothing...
    a couple days i updated my software and when i wanted to reinstall dubsmash i did't find in play store's search..just in my downloaded apps. and then i saw that most of the factory apps are in the same situation..can't update them...
    i tried everything but no ideas anymore. plese help!!!
    05-15-2015 05:56 AM
  16. Kayla waxza's Avatar
    I'm not trying to make a joke but Egypt is a desert so there's probably not enough signal to reach its compatibility
    08-07-2016 10:54 PM
41 12

Similar Threads

  1. Any way to fix "your device isn't compatible with this version"?
    By jimmiegeddes in forum Verizon Galaxy Nexus
    Replies: 5
    Last Post: 08-25-2017, 09:15 AM
  2. Is there any way to fix "your device isn't compatible with this v
    By jimmiegeddes in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 2
    Last Post: 03-24-2012, 10:24 PM
  3. Rooted Nook Color your device isn't compatible with this item
    By melanie_mg in forum Barnes & Noble Nook Color
    Replies: 3
    Last Post: 03-21-2012, 11:11 AM
  4. Is anyone else noticing "device is not compatible with this item"
    By f75gunslinger in forum Verizon Fascinate
    Replies: 9
    Last Post: 01-23-2012, 02:43 PM
  5. Your device is not compatible with this item!
    By Adibidah in forum Barnes & Noble Nook Color
    Replies: 8
    Last Post: 10-01-2011, 11:08 AM
LINK TO POST COPIED TO CLIPBOARD