1. dsw_android's Avatar

    I am using the Alcatel OT-918d (stock rom, root access enabled) and while playing videos in the browser, I do not get an action prompt to choose from the available video players and browser plays the video using "default video player".

    The so called "default video player" has been uninstalled though. Have cleared cache, clear defaults, clear data for the browser but still do not get a prompt to choose a video player while playing videos from the browser.

    Also installed the "Default App Manager" to check for the default video player. However, it indicates no defaults to play any videos (either from file or streaming videos).

    (If I play a stored video from phone or SD card, I do get the prompt to choose a video player. But do not get a prompt if playing any video in the browser.)

    Please help me to solve this.
    malik_ammar likes this.
    12-03-2012 06:57 PM
  2. B. Diddy's Avatar
    I'm confused. You say the browser plays the video using "default video player" without prompting you, but you also say it's been uninstalled. Do you know the exact name of the video player that is automatically playing your videos?

    If you're not rooted, you can't uninstall stock apps, and there should be a stock video player on your phone. You said you're using the stock ROM, but with root enabled. So did you actually remove the stock video player? If not, I suggest go to Settings/Apps/All and look for an app like "Video player" or "My Gallery" (the name of the stock video player may vary with each device). Select the app, scroll down, and clear defaults.
    dsw_android likes this.
    12-03-2012 07:16 PM
  3. dsw_android's Avatar
    Thank you so much for your reply....

    Yes, I have removed the stock "Video Player" app and also the "Gallery" app using titanium back-up. After uninstalling these, if I play a video which is stored on my phone or SD card, I do get a prompt to choose which video player to choose. (Other video players in the phone - doubleTwist and QuickPic). However, when I get this prompt, there is no "use this app by default" checkbox in the dialog prompt.

    Now when I use the browser (stock or other ones like Dolphin) and use one of the sites (say dailymotion or youtube either in Desktop mode or android browser mode), there is no prompt to choose the video player... The video just plays using the default media player of android. It's strange...

    If I navigate to Settings > Apps > Browser/Dolphin - the "Clear Defaults" button is not enabled. So deleted the cache / data which were enabled. Also using titanium back-up, used the "Wipe data" option for these browsers.

    Installed the "Default App Manager Pro" and I have set the Video Play and Video Streaming option to be defaulted to say "doubletwist" player. Yet no luck...

    Have I missed any steps...? Any other ways in which I can try...?

    (Another info.. not sure if it's relevant or not - When i try to uninstall "com.mediatek 2.3.5" from titanium back up, it displays an error 'Cannot remove system app. Unable to locate apk file')
    12-03-2012 08:01 PM
  4. B. Diddy's Avatar
    I'm not well-versed in the rooted world, so there are probably other people on this forum better qualified to help you. But it puzzles me how videos chosen from your browser will still play on the stock media player if you actually uninstalled the stock media player. It makes me think that there is some other app on your phone besides doubleTwist or QuickPic that can also play videos, and that app for some reason has become the default player when you select videos from the browser. Do you have Total Commander, Astro File Manager, ES File Explorer, or any other 3rd party file manager app? A lot of those apps have built-in media players now.
    12-03-2012 08:07 PM
  5. dsw_android's Avatar
    Thank you again...

    If there would be any other video player on the phone, then it should display as an option while playing videos from phone or SD card...? But only 2 options are displayed and nothing else.

    None of the 3rd party file manager have been installed. It's been more than 4 days now and unable to get rid of this...
    12-03-2012 08:20 PM
  6. B. Diddy's Avatar
    Are you also sure that it isn't the browser itself playing Flash videos?
    12-03-2012 08:25 PM
  7. dsw_android's Avatar
    Sorry for the late reply, was out of town and hence the delay...

    Your guess is spot on and I guess that's the issue.... I followed these steps: Dolphin browser > Disable the Flash Player > Make 'Desktop' as the User Agent and then access m.youtube.com and now any video will be played using the doubleTwist player... (but the video quality was pathetic even for HD videos probably coz of wrong combination of user agent and the URL used..?)

    Next did the following - Dolphin browser > Disable the Flash Player > Make 'Android' as the User Agent and then access m.youtube.com and now any video that is played is using the default media player of the android (or should I say flash player..? But the quality of the same video is quite good and played in HD too...).

    Any suggestions as to how we can play those "flash based" HD quality videos of m.youtube.com(and other sites) in custom media player like doubleTwist...?
    B. Diddy likes this.
    12-06-2012 06:52 PM

Similar Threads

  1. MX Video Player - cant play certain .avi files
    By nasellok in forum Verizon Galaxy Nexus
    Replies: 9
    Last Post: 07-04-2015, 03:45 PM
  2. How to "enable video" in settings for use with Skype
    By rocksdahouse in forum Samsung Galaxy Tab 10-inch
    Replies: 1
    Last Post: 10-03-2011, 11:28 AM
  3. Phone not playing any videos
    By remarsh2003 in forum Droid Charge Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 07-16-2011, 07:21 PM
  4. Video How To Enable Stock Wireless Hotspot
    By joshua.worth in forum Virgin Mobile Optimus V
    Replies: 20
    Last Post: 05-05-2011, 06:20 PM
  5. My Nook Color isn't able to play any video files!
    By wangdw611 in forum Barnes & Noble Nook Color
    Replies: 12
    Last Post: 03-19-2011, 10:37 AM