1. flancrestenterprises's Avatar
    I'm running a Galaxy Note with Android 4.0.4 Ice Cream Sandwich, unlocked. I got it three weeks ago, and not once have I managed to get Google Talk to log in... except when I'm using wifi. On wifi, it's totally fine. But try to use it on the data connection, and it just refuses to log in. No errors, no explanations... it just goes grey and nothing will happen. It's driving me absolutely crazy, but I use Google Talk constantly -- it's really making me regret giving up my old T9 Nokia, because at least that ran Google Talk properly. I'm tearing my hair out over it, and I can't find any support anywhere -- the product forums for Talk have been dead 18 months, the blogs for it even longer, there doesn't appear to be any support email address... so I'm really hoping that someone here might understand the problem, and be able to offer me a tip.

    I don't really know what other useful information I can provide. There's no error message to describe. Every other app works perfectly fine over the data connection, including Trillian (connecting to the exact same Google Talk account) and Gmail. Never had a problem with anything else. I have tried removing that Google account from my own and re-adding it. I have tried force-stopping and disabling the Google Talk process and clearing its data (though the option to clear its cache is greyed out). Neither brings any chance. I've tried double-checking my APN settings; the only two I have are the currently-used one and the MMS one. I've called my service provider and asked if they maybe blocked any ports or anything; they haven't. I have made sure that Google Talk wasn't set to 'restrict background data' in the data manager; it wasn't.

    So I'm compeltely out of ideas. What could cause this? What can I check?
    01-24-2013 06:14 PM
  2. Shadowriver's Avatar
    Google Talk is XMPP network, you can use any XMPP client that behaves better to connect to it. You can even make account in diffrent XMPP server and talk to google talk user but only those who got gmail address), thats buity of XMPP, email-like stuctured IM network... to bad there need to be 2nd popular open XMPP network like google talk to make people realize that and demend from closed IM services to open up for eachother, so no more multi communicators would be needed.
    01-24-2013 09:48 PM
  3. moosc's Avatar
    Have u tried clearing cache and data in settings? Have u flashed a rom and the most current gapps package? Have no idea what the previous post was about. But gtalk should work on any network connection.

    Sent from my Galaxy Nexus using Xparent Cyan Tapatalk 2
    01-24-2013 09:52 PM
  4. flancrestenterprises's Avatar
    No; flashing a new ROM invalidates my warranty, and I can't afford to do that. I've cleared the data (which didn't help), but clearing the cache isn't a selectable option (even with the process disabled).
    01-25-2013 03:11 AM

Similar Threads

  1. Google Now only working on WI-Fi
    By karlito24 in forum Google / Samsung Galaxy Nexus
    Replies: 3
    Last Post: 12-22-2012, 09:53 AM
  2. SiriusXM app only works on wi-fi??
    By noshooz in forum Android Apps
    Replies: 24
    Last Post: 08-23-2010, 02:28 PM
  3. Moment not connecting to Wi-Fi
    By laughingperson5 in forum Samsung Moment
    Replies: 0
    Last Post: 06-24-2010, 01:08 AM
  4. Won't connect to Wi-Fi
    By clucas#AC in forum HTC Droid Eris
    Replies: 4
    Last Post: 03-25-2010, 10:32 AM
  5. How to mount Droid via Wi-Fi/3G and Windows 7?
    By matrix2004 in forum Motorola Droid
    Replies: 0
    Last Post: 03-13-2010, 11:08 PM