1. nyeark's Avatar
    Actually solved this issue as I was typing this post - was originally going to ask for help, figured I'd post this in case anybody else ran into the same thing.

    My dad bought a Samsung Captivate the day after I bought mine and showed it off, he was so impressed by it. The only problem was he had a 2GB microSD card that would not work in his phone, but worked perfectly in mine.

    Upon inserting the card, his phone displayed the error "Unable to mount SD card, mount point is absent or incorrect". I could remove it and insert it into my phone and it would work flawlessly.

    Googling for that error message turned up zero results (not just nothing valid, literally ZERO). Turns out it's a super easy fix though, just mount the internal storage via PC and delete/recreate the 'sd' folder. I suspect the folder itself was set to 'read only' rather than just the contents inside, which is how my phone was setup - I'm not entirely sure, but hopefully this proves useful to someone.
    08-01-2010 09:00 AM
LINK TO POST COPIED TO CLIPBOARD