1. Spencer Parsons's Avatar
    I was trying to update my samsung galaxy exhilarate using Kies but it wasn't working so I unplugged it. But now my phone says "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again." I can't get it off that screen. Also it says...

    Don't know what to do, please help.
    04-21-2013 05:57 PM
  2. Scott Kenyon's Avatar
    Download the firmware onto your computer from the internet. Make sure it's the right one. Download the drivers for your phone from the internet. Again, be sure it's the right thing. Download the Android SDK from the Android developer site. Get the drivers installed, then setup the SDK. When you're done doing that, use file explorer to go to the platform_tools folder in the SDK, right click on the platform-tools foler and launch command line there.
    Plug your phone in powered on and type "abd devices" without the quotes. If you see the device come up under your devices list you're ready to continue. If the phone does not appear you've either installed the wrong drivers or not installed them properly, go back to the drivers step and get them right untill your phone comes up under the ADB devices list. When that's done, go back to file explorer and find where you downloaded the firmware to, and cut/paste it into the platform-tools folder. Then type adb push filename.ext to /sdcard/. replace filename.ext to the firmware file. When that's done pushing, type adb reboot recovery and it should bring you back to your recovery screen on your phone. Then simply install zip from sdcard and choose the one you pushed onto the phone.

    I personaly avoid kies at any cost.

    As an afternote to all of this, and not to be a ****: Don't EVER unplug a phone while it's updating. Even if it doesn't look like it's working, sometimes it's just very very slow. If you unplug it you probably WILL soft brick your phone just as you've done.

    Good luck, and let me know if you're having any trouble.

    04-21-2013 08:28 PM
  3. Spencer Parsons's Avatar
    I downloaded the Android SDK, but I don't know how to get the correct firmware and driver download. I tried but I think I got the wrong one. What should I look up and how do I know if it's the right one. And I know I shouldn't have done that, it was stupid of me. I made a small thing a lot worse.
    Thanks for the help.
    04-21-2013 09:48 PM
  4. Scott Kenyon's Avatar
    Firstly, I assumed you are using Windows. If this is wrong correct me.
    Search Google for Samsung android driver. Is easy enough to find. Then search for the stock rom for your phone on your carrier. It won't matter for now if it's the updated version or not, let's focus on getting your device working again. Roms differ between carriers. When I get to my laptop I'll be able to find some links for you if you cannot locate them yourself.

    Sent from my Galaxy Nexus using Android Central Forums
    04-22-2013 11:06 AM
  5. Scott Kenyon's Avatar
    This should be easier for you.

    Dev-Host - I577_GB_Stock.tar - The Ultimate Free File Hosting / File Sharing Service

    Download that, it's the stock TAR for the Galaxy Exhilarate. Push it on using ODIN and your phone should be back to stock Gingerbread.

    I haven't used ODIN in awhile, but you install driver (Support - AT&T Cell Phones SGH-I577 | Samsung Cell Phones), boot into ODIN mode, open ODIN and select the TAR you downloaded from the link above, then let it do it's thing. You're probably better off reading up on using ODIN but it's pretty simple if you don't know how.
    Good luck and please let me know how it works out.
    OsoVandalo likes this.
    04-22-2013 12:25 PM
  6. Spencer Parsons's Avatar
    No I am using a mac. Do I need to be using windows?
    04-22-2013 02:42 PM
  7. Scott Kenyon's Avatar
    I'm looking into whether or not there's a working Odin for mac that doesn't suck.
    04-22-2013 03:02 PM
  8. Scott Kenyon's Avatar
    It would seem Odin itself isn't made for Mac. There is a command line utility that does the same sort of thing called Heimdall.

    How to use Heimdall Terminal (Odin for Mac) | iPad, iPhone, and iPod touch forums | iFans

    As far as using it, I have no experience. You may have to get with some mac guys and have them walk you through the commands to use it. The image (tar) I posted above should restore your phone to GB, you just need the vehicle to get it there. Good luck.
    04-22-2013 03:10 PM
  9. Scott Kenyon's Avatar
    Any luck? I've been hoping you have it worked out.

    Sent from my Galaxy Nexus using Android Central Forums
    Spencer Parsons likes this.
    04-24-2013 11:50 AM
  10. Spencer Parsons's Avatar
    I tried for a while without any luck. I ended up taking it in to the AT&T store and they fixed it in about 15 minutes. I should have done that earlier. But thank you so much for your help. It probably would have been easier if I had a PC but thats ok. Again thank you.
    04-25-2013 08:13 PM
  11. Scott Kenyon's Avatar
    Anytime sir. Glad you have a working device again.

    Sent from my Galaxy Nexus using Android Central Forums
    Jorge Veliz likes this.
    04-25-2013 08:45 PM
  12. muhammad sidat's Avatar
    i had the same problem from the last guy...i was trying to upgrade firmware but its shown firmware upgrade encountered an issue please select recovery mode in kies and try again......please help me....thank u
    06-02-2013 06:54 PM
  13. Jorge Veliz's Avatar
    Help my verizon galaxy s4 is stuck on firmware upgrade encountered an issue
    08-10-2013 12:57 PM
  14. Jorge Veliz's Avatar
    can you help me please my verizon galaxy s4 is stuck in Firmware upgrade encountered and issue
    08-10-2013 01:01 PM
  15. Scott Kenyon's Avatar
    can you help me please my verizon galaxy s4 is stuck in Firmware upgrade encountered and issue
    Download Odin, the Samsung adb/usb drivers, and the stock s4 factory image for the Verizon S4. Instructions and links can be found here:

    Follow those steps and you should be good to go.
    08-13-2013 12:10 PM
  16. OsoVandalo's Avatar
    Thanks for the firmware link Scott was looking for that, well for the ics one but I guess i can go with this and upgrade.
    08-14-2013 05:47 PM
  17. Scott Kenyon's Avatar
    Thanks for the firmware link Scott was looking for that, well for the ics one but I guess i can go with this and upgrade.
    No problem. I want you to get a working phone. You can always go back to modding after you're working properly.

    Sent from my HTC One using Mobile Nations mobile app
    08-14-2013 06:10 PM
  18. Vicentte760's Avatar
    Firmware Encountered an issue tmobile s4 Help
    01-08-2014 05:50 PM
  19. Rukbat's Avatar
    What you do depends on whether you initiated the update (you downloaded a file, etc.) or it was OTA (over the air). If it was an OTA update, bring it to a TMobile store and let them fix it, it's their problem, since it's their update.

    If you did it, it depends on what version it was being updated to. Anything lower than 4.3 should be fixable by Kies. Tools/Emergency Firmware Recovery. If it's stuck in 4.3 and Kies won't find firmware for it, Firmwares | SamMobile has an image for it. (Put m919 in the search box.)
    01-09-2014 12:40 AM

Similar Threads

  1. Help my phone is stuck in bootloader
    By Ktroberts in forum HTC EVO Shift 4G
    Replies: 6
    Last Post: 12-14-2014, 11:37 AM
  2. Replies: 41
    Last Post: 09-18-2014, 01:47 PM
  3. My phone is stuck on Hboot screen? HELP :(
    By Nora Hasan in forum AT&T Inspire 4G
    Replies: 6
    Last Post: 01-24-2013, 11:43 PM
  4. HELP! My phone is stuck on Google logo screen when start up!!!
    By nexus_justice in forum Google / Samsung Galaxy Nexus
    Replies: 4
    Last Post: 07-22-2012, 03:03 PM
  5. Tried rooting now my phone is stuck on the Google screen Help!
    By craigrn16 in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 7
    Last Post: 05-25-2012, 06:14 AM