02-23-2016 05:14 AM
285 ... 101112
  1. Dean Niner's Avatar
    Hi all, first-time poster here. Also having issues with "SD card unexpectedly removed" and then immediately remounted. Didn't have problems when phone was new (5-6 weeks ago), but now it seems to be getting worse and worse. Galaxy S4, PNY 16 MB class 10 micro SD card.

    Call me crazy, but... I was convinced this was not a mechanical problem (pulling card out, blowing in slot (a la NES), cleaning contacts, etc) didn't seem to make a difference.

    But I was just playing around a bit more with the phone. I actually had the back cover *off* with the phone on. Lightly pressing down on the SD card (in the middle of the card, or at the contacts, or wherever) was giving me this "SD card unexpectedly removed" error. As soon as I let go, the SD card was found again. Every time, 20 out of 20 times.

    I tried stuffing a piece of index card (cut down to the right size) in the slot between the SD card and that outer metal/blue-tape piece of the slot to see if that would create a better electrical contact between SD card and phone. That made no difference. *But*, when I put the index card on the under-side of the SD card (between the SD card and the phone, careful to not insert the paper too far as to block electrical contacts), this seemed to fix the problem. I'm unable to get the "unexpectedly removed" message anymore (for the last hour, at least). (Easier to insert the index card if you remove the SD card and then put both (index card/SD card sandwich) in together.)

    Can anyone else with this issue see if they can reproduce what I've said here? Was the solder job too weak in the manufacturing of this phone? Or do I happen to just have a completely different problem (mechanical contacts, vs everyone else with a software bug)?? Will update if I get this "unexpectedly removed" error again...

    10-19-2014 05:15 PM
  2. PersianStudios's Avatar
    Restart Device
    use reset factory
    format sd card
    11-11-2014 02:55 PM
  3. yavuzkeskin's Avatar
    Hi, unfortunately i have the same "SD card unexpectedly removed" issue with my S4 as well. My first 32GB Sandisk Ultra 10 worked like a month and then suddenly i started to receive these messages. I was able to access my files through my PC and thank to god i copied all my files. I kept physically move the SD card, restart the phone to be able to use the card again and one day it didn`t work at all. My PC did not recognize the SD card, either. It is just fried. Then, I used another 32GB Sandisk Ultra Class 10 micro SD card and this one survived only 2 weeks and then it is also completely became unresponsive -fried-. During these two weeks, I had to go through the same annoying process over and over again (unmounting, mounting, restarting).

    Then, I got a new 64GB SAMSUNG Pro Class 10 micro SDXC card just hoping that it works since it is Samsung brand and very high quality (purchased directly from Amazon) and i had the same message "SD card unexpectedly removed" in 15 minutes.

    I always have the most updated version of the android software - i think i have KitKat now- and i use my cell phone gently. I am looking for an answer for a long time but it is very surprising that Samsung does not provide a solution and don`t even recognize this as a problem. They don`t want to admit it because they know they made a defective device . I think this is a phone issue and i really regret that i did not return my phone while i had a chance. i spent $750 for this phone and one of the main reason was the SD card support. I am very upset and definitely won`t buy Samsung phone again. On the other hand I have friends using Samsung S4, S5 or note4 without having this issue. I think I was just one of those thousands of unlucky people!!!
    12-07-2014 12:08 AM
  4. rondip's Avatar
    I have an even more bizarre problem with my 64gb SDXC card in my Galaxy S4. I loaded 35 GB of music files using Isyncr. Took forever but it finally copied all the files. Here's the issue now. When I view the SD card in storage in settings it shows only .5 GB used and I get the same results when using the my files app. When I use some music apps none of the songs appear but when I use the "play music" app all the songs appear and play fine. Anyone see anything like this before?
    06-12-2015 10:21 AM
  5. Chuman88's Avatar
    Thanks for your suggestion! That worked like a charm! Previously I had reformatted my memory card twice, but the issue kept reappearing. Thank you for stopping this insanity! I tried the following steps
    1. Power device down
    2. Remove sd card and battery
    3. Replace sd card and battery
    4. Turn phone on
    5. Enjoy functioning phone again!

    These steps are the standard method of powercycling the phone, but I decided to try it anyway. It worked!

    This worked for me as well.
    07-10-2015 09:36 AM
  6. MKweb2000's Avatar
    I was having the exact same problem with my GS4, with 2 different 64GB SDcards (the 2nd one even a Samsung branded card). I also suspected that it was a physical issue with the slot itself and faulty contacts. I'm guessing even just a momentary lapse of connectivity to the card causes the phone OS to throw up the error and then go through a remount to re-verify the card integrity. I even think that my original 64GB card eventually became corrupted from this happening so many times in 2 and a half years since I was unable to re-format it on phone or even on my PC.

    What I just did right now to try to resolve the issue is to unmount the card, then remove it (no phone shut down or re-start required). I then removed the back and *very gently* pressed down on the metal SDcard 'dock', focusing on the edges of it where it connects to the phone body. If this doesn't work, I'll try your suggestion of using a spacer underneath the card, between it and the phone body. I'm also wondering if it would be worth it to try to place a small piece of tape over the entire card dock or at least the exposed part of the card itself (being careful not to block any other areas of the phone body) to prevent moisture from entering the dock area.

    Additionally, I have also received "No SIM card" errors that required a phone restart to fix, though not as frequently as the SDcard errors, and I suspect that it's a similar root cause of momentary loss of contact to the card. Has anyone else had this? I suppose this is what happens when you have a phone with a removable back and openings on the back that allow moisture and high humidity to access the phone body and these card ports. This might also explain Samsung's noticeable silence on the issue, since they would have to admit that it's an actual phone hardware design problem.

    Finally, as far as SD cards themselves, cards of 32GB and less should be formatted as FAT32, and cards larger than 32GB need to be formatted as exFAT. As far as I'm aware, NTFS formatted cards will not work in the phone.
    12-08-2015 10:46 AM
  7. faisalbright's Avatar
    Problem solved. On samsung galaxy s4,
    1. Insert the sd card in your s4
    2. Format the sd card
    3. Unmount sd card then remove it
    4. Use sd card adaptor to read the card in computer
    5. Delete the .android_secure folder
    6. Create new folder and transfer all the files in that.
    6. Click on eject sd card safely on computer
    7. Remove the card from computer
    8. Insert card in s4
    9. Enjoy your files
    12-10-2015 09:45 AM
  8. hunterkye's Avatar
    Yes I am having this same issue, whenever I touch the SD card lightly the SD card will remove itself and reconnect, I should try index card trick and see if that makes a difference, I am having this issue on an LG Optimus l90
    01-11-2016 07:24 PM
  9. Lihol182's Avatar
    Its happening on my samsung galaxy 3.7 tablet and my lg stylus phone so i agree with the update causing this problem. Ive tried all these rebooting and sd reinserting, chking crappola and keeps happening. Its ok sometimes but keeps coming back.
    Im going to metro for help where i bought this phone less than a year ago so hope they can help. I have insurance but i am 99% sure its a software problem causing the issue.
    The reason we dont see more of our problem is bcuz i had to sign up and register to post. Maybe more than just me r lazy bones.
    Good luck to all of us )
    01-23-2016 01:18 AM
  10. Lilly7's Avatar
    I have the same problem with S4 “SIM card removed- restart” – every 20 minutes! It’s very irritating and very inconvenient! Requested a new SIM from my mobile provider but it didn’t solve the problem. It’s obviously a software problem and SAMSUNG should take a responsibility for selling this faulty model S4 and replace it with new phones. Why customers should suffer?
    02-23-2016 05:14 AM
285 ... 101112

Similar Threads

  1. Galaxy S4 SD card issue
    By JamesM1 in forum Samsung Galaxy S4
    Replies: 70
    Last Post: 10-18-2014, 02:48 PM
  2. Cannot move apps to SD card with Samsung Galaxy S4
    By nkboy9 in forum Samsung Galaxy S4
    Replies: 89
    Last Post: 11-11-2013, 09:46 AM
  3. Replies: 55
    Last Post: 10-31-2013, 09:41 PM
  4. AT&T Galaxy S3 SD Card issues..
    By joe.kent in forum Samsung Galaxy S3
    Replies: 38
    Last Post: 03-02-2013, 05:57 PM
  5. SD card issues
    By vbsoulpole in forum Software Development and Hacking
    Replies: 1
    Last Post: 02-07-2010, 03:04 AM